Tastiera numerica non funzionante

20

Utilizzo Ubuntu 10.04, completamente aggiornato, da un disco rigido USB esterno. Tutto funziona molto bene, tranne la tastiera. Il tastierino numerico non funziona. I tasti non fanno nulla, con o senza NumLock attivo.

Le Preferenze tastiera sono impostate per PC 105-Key (Intl) generico. La tastiera stessa, su questo computer, è PS2.

Qualche idea su dove cercare di risolvere il problema?

    
posta UrkoM 21.09.2010 - 05:16

4 risposte

29

A volte, nelle macchine che connetto tramite i tasti del mouse VNC viene abilitato misteriosamente. Forse questo è il tuo problema.

Fai clic sul menu di sistema - & gt; Preferenze - & gt; Tastiera. Nella scheda Tasti mouse verifica che il puntatore possa essere controllato usando la tastiera sia disabilitato.

    
risposta data Javier Rivera 21.09.2010 - 08:50
13

Pubblicherò un'altra risposta perché mi ci sono voluti anni per capirlo. Sembra che le cose siano state spostate un po 'nelle recenti versioni. La scheda "Mouse Keys" non era presente nelle mie preferenze Keyboard (Ubuntu 11.10, shell gnome), quindi la soluzione di @ JavierRivera mi ha impostato sulla traccia corretta, ma non risolveva il problema di disattivare il "control pointer using keypad" opzione. Questo è dove l'ho trovato:

Settings > Universal Access > Pointing and Clicking

Ho anche abilitato "I tasti numerici della tastiera funzionano come con Macintosh" poiché sto usando una tastiera imac. Questa opzione si trova in:

Settings > Keyboard Layout > Layouts > Options > Miscellaneous compatibility options

che sembra essere necessario per me.

    
risposta data Ian Hincks 06.03.2012 - 03:43
4

Per Ubuntu 12.10:

  • Fai clic sul menu di sistema - & gt; Impostazioni di sistema - & gt; Accesso universale - & gt; Punta e fai clic su

  • Disattiva "Tasti del mouse"

risposta data pasdenom 08.08.2013 - 11:19
0

Se stai usando XFCE4 (ad esempio Xubuntu):

  • Vai a Gestione impostazioni & gt; Accessibilità & gt; Mouse
  • Deseleziona "Usa l'emulazione del mouse"; se è già deselezionato, prima controllalo e poi deselezionalo (suppongo, per qualche ragione, che la GUI non sappia che il Numpad sta emulando il mouse)
risposta data Azmisov 23.11.2016 - 19:11

Leggi altre domande sui tag