Steam non si aprirà in Ubuntu 15.10

19

Ho provato ripetutamente, ma non succede nulla. Ho provato a reinstallare Steam insieme a Ubuntu ma non ho fatto nulla. Ho provato altri forum con suggerimenti utili ma non va bene. Sono a corto di idee e non so cos'altro posso fare. Qualcuno può aiutarmi prima che inizi a strapparmi i capelli? Sto impazzendo.

    
posta Travis Toompas 25.10.2015 - 07:43

2 risposte

27

Basato su questa domanda , esegui i seguenti comandi :

mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}
mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}

L'idea è che Steam usa le sue librerie dinamiche, ma Ubuntu ne ha alcune nuove o qualcosa del genere, in qualunque modo funzioni!

NOTA: se si installa Steam per la prima volta, sarà necessario eseguire i comandi una seconda volta dopo l'aggiornamento iniziale. Questo richiederà un lonnnnnnnng tempo!

UPDATE:

Se usi 16.10, i ragazzi di Ubuntu hanno fornito un programma di installazione modificato che si occupa di questi problemi. Consiglierei di installare Steam dai repository di Ubuntu

    
risposta data Dan 26.10.2015 - 19:42
3

Basato sulla risposta di Daniel (non ho il rep per commentare!), su un ubuntu-gnome 15.10 di vanilla dove ho fatto un 'apt-get install steam' ho dovuto eseguire questi comandi modificati:

mv ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}
mv ~/.steam/steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}

Quindi modificando semplicemente .local / share che non era presente sul mio sistema

    
risposta data Henri Cook 12.11.2015 - 22:57

Leggi altre domande sui tag