Aggiornamento firmware per iPod Touch (iPhone)?

18

Ho bisogno di aggiornare il firmware del mio iPod Touch (iPhone) in Ubuntu e come ho fatto con iPod Touch jailbroken ho bisogno di iTunes per installare app, ma sfortunatamente non ho ancora trovato alcun modo per farlo in Ubuntu. So che è possibile utilizzare VirtualBox o Wine , ma ancora nella maggior parte dei casi in cui iTunes non vuole lavorare su Wine e per VirtualBox ho bisogno di installare di nuovo quel Windows da cui sono passato in Ubuntu solo pochi mesi fa e non voglio tornare ad esso.

Che cosa fanno in questo caso gli utenti Linux che hanno iPod Touch (iPhone)?

Qualsiasi suggerimento per risolvere il problema sarà soddisfatto.

E infine, quanto tempo ci vorrà prima che Apple sviluppi iTunes per Linux OS?

    
posta Bakhtiyor 29.07.2010 - 00:30

6 risposte

9

Mentre alcune vecchie versioni di iTunes possono essere attualmente realizzate per funzionare con Wine (o Crossover), non possono essere utilizzate per aggiornare o sincronizzare gli iPod più recenti

Il motivo è che Wine non ha un gestore per i driver di dispositivo USB Windows e l'iPod funziona come un dispositivo USB personalizzato. Questa è la stessa ragione per cui anche il software che richiede una chiave hardware speciale non funziona (ancora) in Wine. Ci sono alcune patch preliminari disponibili per questo, e puoi leggere più storia nella wiki del vino , tuttavia non aspettarti che qualcosa funzioni .

Gli unici iPod che funzionano attualmente su Wine sono vecchi iPod che fungono da semplici dispositivi di archiviazione di massa USB. E anche allora hai ancora bisogno di trovare iTunes più vecchio e funzionante.

A causa di questo problema in Wine, per eseguire l'aggiornamento del firmware è necessario configurare una macchina virtuale con Virtualbox o VMware o, forse più semplicemente, prendere in prestito il computer di qualcun altro.

    
risposta data Scott Ritchie 30.09.2010 - 18:05
4

Non so se funziona con il tuo iPod touch, ma funziona con i miei vecchi iPod: link

    
risposta data manyxcxi 29.07.2010 - 00:37
3

Osservando Crossover pagina per iTunes , un paio di versioni sono state segnalate per funzionare un po '. Il crossover costa denaro, ma potrebbe valerne la pena.

    
risposta data mac9416 29.07.2010 - 00:36
3

Firmware-Upgrade non ha funzionato per me: Ubuntu 8.04 LTS con vmplayer e un vecchio XP con iTunes.

Nessuna possibilità. l'iphone era fuori uso per il resto della giornata fino a quando non l'ho collegato al mio pc di Windows sul mio lato di lavoro.

Da questo punto di vista: i prodotti apple sono assolutamente da non perdere! Perché ho bisogno di Windows o Mac con iTunes per avere un telefono? Dove si afferma che al momento dell'acquisto di quella "cosa-a-magia" ho bisogno di un iTunes in esecuzione per farlo funzionare? Chi conosce i costi prima?

    
risposta data Ice 06.08.2010 - 23:36
2

libimobiledevice

È ancora sperimentale, ma dovresti controllare libimobiledevice . Non ci sono ancora GUI, ma stanno lavorando per far funzionare i modelli ipod touch su Linux (compresi i software up e downgrade).

Modifica: in base al Wiki di Ubuntu questo è il valore predefinito dal 14.04 e implementato in vari progetti. Controlla le notizie e lo stato sulla pagina del progetto libimobiledevice per i dettagli. Attualmente sostengono di supportare iOS 9, che era ancora in fase beta al momento della scrittura.

    
risposta data PierreS 05.12.2010 - 17:22
0

Sono stanco di aggiornare il firmware del mio iPhone v2 alla v3 utilizzando iTunes in esecuzione su VMware. Il processo si è interrotto a metà del flusso e l'iPhone è stato reso inutile. L'ho collegato alle macchine Windows di un amico e dopo diversi tentativi di aggiornamento è tornato in vita.

Gli aggiornamenti con le stesse versioni principali funzionavano bene in iTunes / VMware però.

    
risposta data A.B. 20.10.2010 - 10:10

Leggi altre domande sui tag