I driver nvidia di Ubuntu 16.04 non funzionano

20

Ho appena installato una nuova ubuntu 16.04,
nuova installazione pulita, la prima e unica cosa che ho fatto è aver selezionato il driver proprietario 361 per nvidia, riavviato la macchina.
dopo il riavvio posso accedere ma l'unità non viene visualizzata, posso ancora fare clic con il tasto destro del mouse e aprire il terminale, ho provato molte risposte:
link1 link2

non ha aiutato, sono stato frustrato, ho fatto il boot in USB e l'ho appena installato di nuovo, questa volta ho provato 340 driver lo stesso problema.
Voglio dire questo è 16.04 LTS per l'amor di dio.
Ho due schede grahpic nvidia gt 740m, intel costruito su laptop ASUS.

output di grep "EE \ | WW" /var/log/Xorg.0.log:

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    23.758] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    23.761] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[    25.323] (WW) Unresolved symbol: fbGetGCPrivateKey
[    25.448] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[    25.613] (WW) modeset(G0): Option "AllowEmptyInitialConfiguration" is not used
[    25.613] (WW) modeset(G0): Option "IgnoreDisplayDevices" is not used
[    25.902] (EE) NVIDIA(0): Failed to initiate mode change.
[    25.902] (EE) NVIDIA(0): Failed to complete mode change
[    26.214] (WW) evdev: SteelSeries Sensei Raw Gaming Mouse: ignoring absolute axes.
[    26.216] (WW) evdev: SteelSeries SteelSeries Apex Raw Gaming Keyboard: ignoring absolute axes.
[    26.272] (II) XINPUT: Adding extended input device "USBest Technology SiS HID Touch Controller" (type: TOUCHSCREEN, id 16)

file di registro completo LOG

file xorg.conf:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:[email protected]:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:[email protected]:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection
    
posta saeed hardan 23.04.2016 - 12:30

8 risposte

1

Trovato la soluzione (questa volta per davvero),
ho deciso di essere un esperto di Ubuntu, quindi sono andato su google e ho digitato:

  

debug ubuntu

poi mi ha dato la pagina Debug e ho selezionato l'unità.
in parte dovevo fare:

$ unity --advanced-debug
GNU gdb (GDB) 7.2-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>

...

(gdb) set logging file unity.log
(gdb) set logging on
(gdb) b _exit
Function "_exit" not defined.
Make breakpoint pending on future shared library load? (y or [n])
[Answer yes (y)]

(gdb) run

[ and when compiz/unity crash, do...]

(gdb) bt full

[ then CTRL-D or re-run compiz to continue working ]

(gdb) run

dopo aver eseguito ciò ho notato l'errore:
compiz (core) - Errore: Plugin 'opengl' non caricato.

ho cercato questo errore su google e mi ha fornito questa discussione Unità mancante? Impossibile vedere i pannelli superiori o laterali , la risposta qui funziona.

    
risposta data saeed hardan 27.04.2016 - 18:23
9

Ho anche installato Ubuntu 16.04, installazione pulita su un nuovo hd e tutto ha funzionato bene fino a quando non sono passato al driver NVIDIA. Dopo il riavvio non sono riuscito a superare la schermata di accesso. La soluzione che ha funzionato per me era quella di disabilitare l'avvio sicuro .

Mentre rimanevo bloccato nel ciclo di login, sono passato alla console Ctl+Alt+F1 , riavviato e disabilitato l'avvio sicuro in UEFI . Ora tutto funziona con il driver nvidia installato.

    
risposta data Karhu 27.04.2016 - 22:37
3

Anch'io ho avuto questo problema. Ho appena eseguito questo in una console (premere Ctrl + Alt + F1 , nella pagina di accesso per mostrare il primo tty virtuale):

sudo apt-get purge nvidia*

Dopo questo, riavviato e quindi potevo accedere. Successivamente ho installato i driver intel e poi nvidia-361.

Questi sono stati i passi che ho seguito:

  1. sudo apt-get purge nvidia*
  2. riavvio (ora avevo un nuovo driver di visualizzazione funzionante)
  3. sudo apt-get install intel-microcode
  4. sudo apt-get install intel-gpu-tools
  5. Riavvia (per test, tutto funzionava bene)
  6. sudo apt-get install nvidia-361 (Penso che nvidia-current sia l'opzione migliore a lungo termine).
  7. Reboot

Ora ho questi (mi dispiace sono in spagnolo):

Driver aggiuntivi

    
risposta data Shosta 23.04.2016 - 18:36
2

Ho anche un problema con 16.04 e il driver Nvidia 361.42. Puoi utilizzare prime-select intel o Nouveau driver come soluzione temporanea. Ho avuto problemi infiniti con i driver ufficiali di Nvidia Ubuntu nel corso degli anni, è molto povera. Ho pensato che l'introduzione di Steam OS e il numero crescente di utenti / giocatori Linux potrebbero incoraggiarli a supportare meglio Linux: /

    
risposta data neutreno 23.04.2016 - 12:52
1

Penso di aver trovato la soluzione. Ho avuto terribili problemi con l'installazione di 16.04 sulla mia macchina principale. I driver Nvidia si bloccano e non è possibile accedere e si deve ricorrere a sudo apt-get purge nvidia- *. Chrome si stava bloccando.

Non ho avuto problemi con la mia macchina secondaria che ha un bios tradizionale. È solo la mia macchina principale con il firmware UEFI. La cosa più frustrante è che stavo correndo 16.04 da una build quotidiana per alcuni mesi ed era solido come una roccia.

Ho notato che l'installer richiede una password se si scaricano driver durante l'installazione. La soluzione è DISATTIVARE SCATTO SICURO. L'installazione di Ubuntu (dall'opzione UEFI nel menu Bios) procede senza problemi e il sistema sembra stabile. 16.04 non è perfetto per es. per installare Chrome devi usare gdebi, ma almeno ora è utilizzabile.

    
risposta data Roderic Jones 03.05.2016 - 17:09
1

Per me la soluzione dopo molte ricerche è stata quella di disabilitare UEFI nel BIOS. La mia macchina esegue solo Linux, quindi disabilitare UEFI non era un grosso problema.

Stavo avendo problemi con VirtualBox e NVIDIA e non potevo neanche lavorare con Ubuntu 16. Stavo cercando "ubuntu 16 UEFI Virtual Box Fail kernel build" e ho trovato un link riguardante Virtualbox che mi ha fatto pensare a UEFI e disabilitarlo.

Dopo aver disabilitato UEFI ho reinstallato Ubuntu 16. Durante l'installazione la finestra di dialogo che aveva la voce "Secure boot" era priva di quel contenuto.

Sono felice di annunciare che Ubuntu 16 è in esecuzione e non ho problemi con NVIDIA o VirtualBox! Entrambi funzionano come previsto.

Grazie a coloro che hanno condiviso le loro conoscenze in modo da poter andare avanti.

    
risposta data D.Howland 06.05.2016 - 03:33
1

Ubuntu 16.04 viene fornito con xserver Xorg 1.18 e la configurazione è leggermente diversa da prima. In una configurazione con doppia GPU, dalla wiki di Arch Linux , il / etc / X11 / xorg.conf dovrebbe essere come questo:

Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "AllowEmptyInitialConfiguration"
EndSection

Sostituisci PCI: 1: 0: 0 per il tuo ID bus nvidia. Puoi verificarlo con:

$ lspci | grep -E "VGA|3D"

Funziona con il mio laptop HP con doppia GPU: Intel (Skylake) e NVIDIA 940m. Ricorda che è possibile passare da un'applicazione all'altra con prime-select comando (come root) o applicazione ufficiale nvidia-settings e riavviare il tuo computer.

    
risposta data Jaime M. 23.05.2016 - 20:49
0

Ho avuto un problema simile, ma il mio problema in particolare è stato causato dal ESET NOD32 Antivirus .

L'installazione del driver, sia dal repository ubuntu che dall'installazione manuale del driver NVIDIA, si è bloccata nella costruzione dei moduli DKMS.

Ho trovato istruzioni su come disinstallare ESET e dopo averlo disinstallato, ho impostato la mia esecuzione -level a 3:

sudo systemctl enable multi-user.target
sudo systemctl set-default multi-user.target

Lista nera:

Modifica /etc/modprobe.d/blacklist.conf come super utente e aggiungi:

blacklist nouveau

Quindi elimina NVIDIA e riavvia:

sudo apt purge nvidia*
sudo reboot

Una volta nel livello di esecuzione 3, ho installato manualmente il driver NVIDIA più recente, reimpostato il livello di esecuzione su 5 e riavviato.

sudo sh ./NVIDIA...
sudo systemctl enable graphical.target
sudo systemctl set-default graphical.target
reboot

Le cose stavano finalmente funzionando, quindi ho reinstallato l'antivirus. Dovrà attendere un aggiornamento del kernel per garantire che il driver NVIDIA venga ricostruito in quel momento.

    
risposta data DavidG 19.03.2017 - 04:18

Leggi altre domande sui tag