Permesso negato durante il download con la trasmissione deamon

22

Ho installato xubuntu e il demone di trasmissione, impostato il percorso di download sui miei programmi TV / utente / TV e ottengo un'autorizzazione negata quando provo a scaricare i torrent tramite la trasmissione.

Ho provato chmod -r 777 su questa cartella senza successo.

per favore aiuto!

output di ps -ef | trasmissione grep

[email protected]:~$ ps -ef | grep transmission
109       1023     1  1 21:46 ?        00:00:35 /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info

[email protected]:~$ ps aux | grep transmission
109       1023  3.2  0.4  47684 16620 ?        Ssl  21:46   1:20     /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info
chen      1852  0.0  0.0   4200   772 pts/0    S+   22:27   0:00 grep --color=auto transmission

enter code here
    
posta Chen Kinnrot 23.11.2012 - 20:55

9 risposte

41

Supponendo che il percorso della cartella di download sia /home/chen/TV shows , eseguire quanto segue:

  • aggiungi chen al gruppo di trasmissione debian

    sudo usermod -a -G debian-transmission chen
    
  • cambia la proprietà della cartella

    sudo chgrp debian-transmission /home/chen/TV\ shows
    
  • concedi l'accesso in scrittura al gruppo

    sudo chmod 770 /home/chen/TV\ shows
    
  • Ferma il demone con

    sudo service transmission-daemon stop
    
  • L'ultima cosa da fare è cambiare la maschera di creazione del file, in modo che i file scaricati siano scrivibili da chen.

    sudo nano /etc/transmission-daemon/settings.json
    

    ... e modifica "umask": 18 in "umask": 2 . Premi Ctrl + O per salvare e Ctrl + X per uscire.

Avvia il daemon con

sudo service transmission-daemon start
    
risposta data mikewhatever 23.11.2012 - 21:58
4

Questo è un problema di autorizzazione basato sull'ID utente che sta eseguendo Transmission. La trasmissione imposta un utente predefinito che non ti aspetti alla prima installazione. Il nome utente è debian-transmission .

Spiegherò come cambiarlo:

  1. Arresta il daemon Transmission sudo service transmission-daemon stop
  2. Apri il file di configurazione della trasmissione per la modifica: sudo nano /etc/init.d/transmission-daemon
  3. Trova la riga che dice USER=debian-transmission e cambiala all'utente che possiede la cartella in questione. Se non sei preoccupato per i problemi di sicurezza, puoi anche utilizzare USER=root in questo file. (Non consigliato, ma utile per la risoluzione dei problemi).
  4. In alternativa (invece del punto numero 3), modifica il cartella / etc / fstab per montare la cartella con le autorizzazioni corrette per l'utente che esegue il daemon di trasmissione.
  5. Avvia il daemon Transmission sudo service transmission-daemon start
risposta data Terry 16.11.2013 - 08:09
4

Controlla se stai utilizzando una cartella "incompleta". L'errore può essere fuorviante in questo caso e potrebbe essere la cartella incompleta a cui non si ha accesso in scrittura.

    
risposta data blockdor 23.09.2015 - 19:41
1

Questo mi è appena successo. Ho trovato questa pagina, sono stato intimidito da tutto il gergo, quindi ho riavviato la trasmissione, ho prenotato il file torrent in una posizione diversa e ho salvato i dati del torrent nella stessa posizione diversa (desktop). Ha funzionato come un incantesimo ...

    
risposta data Alexia 31.07.2015 - 17:02
0

Questo potrebbe essere un problema con il profilo di un apparmore. La trasmissione gira sotto il profilo sanitized_helper in apparmor.

Cerca reclami in /var/log/kern.log. grep transm /var/log/kern.log , in particolare subito dopo aver tentato di eseguire la trasmissione e fallendo.

    
risposta data Jim Salter 24.11.2012 - 00:58
0

Poiché questo è il risultato di ricerca più alto in Google, per chiunque stia leggendo questo argomento, trascorro più di un'ora cercando di farlo funzionare. Risulta, la cartella di download specificata in settings.json è "Download" invece di "download". Prendi nota del caso.

    
risposta data SomeGuest1425125125 23.11.2016 - 14:21
0

Nel mio caso il problema era come veniva montato il convertitore. L'utilizzo di questo in /etc/fstab ha funzionato per me:

UUID=2069-1A05  /mnt/ext   vfat   rw,user,exec,umask=0000   0   0
    
risposta data davidcm 02.01.2017 - 20:24
-1

Ho avuto lo stesso problema, ed è stato un errore che ho fatto quando ho collegato la directory di download della trasmissione alla mia directory home / user /, ho cambiato la proprietà del file sym-linked che, di conseguenza, ha cambiato anche la proprietà di la directory 'download' della trasmissione ...

Ho appena restituito la proprietà di 'debian-transmission' e ha funzionato come un incantesimo (senza bisogno di riavviare il servizio)

#chown debian-transmission:debian-transmission /var/lib/transmission/downloads

(beh, dovrai verificare in base alla tua distribuzione linux qual è il proprietario corretto e infine anche il percorso corretto per la directory dei download)

    
risposta data baobab33 09.12.2014 - 11:37
-1

Ho avuto un problema simile con la trasmissione. Ho ricevuto l'errore di autorizzazione durante il download anche con le corrette impostazioni dell'autorizzazione della cartella sull'HDD USB esterno.

Ho appena montato l'HDD esterno su /home/pi/ con le stesse autorizzazioni e ha funzionato correttamente.

mount /dev/sda /home/pi/USB-HDD-MOUNTED

le autorizzazioni sono drwxrwxrwx (0777) pi:debian-transmission . il nome utente è cambiato in pi in /etc/init.d/transmisssion-daemon .

    
risposta data Akos 12.02.2016 - 11:00

Leggi altre domande sui tag