Posso aggiornare il kernel della mia 10.04 LTS al kernel più recente?

19

Voglio aggiornare la versione del kernel del mio attuale LTS 10.04 ad almeno 2.6.37 (perché i driver per le mie interfacce eth0 e wlan0 sono inclusi nel suddetto kernel).

Se è possibile, come posso farlo? C'è un repository che aggiungo alla mia lista delle fonti?

    
posta baktin 09.06.2011 - 10:44

3 risposte

10

Non devi aggiungere il PPA. Basta installare il pacchetto linux-image-generic-lts-backport-oneiric dalla suite lucid-updates:

sudo apt-get install linux-image-generic-lts-backport-oneiric

Se stai utilizzando moduli fuori dall'architettura come Virtual Box o driver proprietari, probabilmente avrai bisogno anche delle intestazioni:

sudo apt-get install linux-headers-generic-lts-backport-oneiric

Altri nomi di pacchetti possono essere trovati su link

    
risposta data ohitsanazn 27.11.2011 - 23:55
2

Non è più necessario usare un PPA per installare 2.6.38 su Ubuntu 10.04 Lucid.

Il repository di ubuntu-updates per Luc ha ora. Probabilmente lo hai già dentro /etc/apt/sources.list

$ apt-cache policy linux-image-2.6.38-12-generic 
linux-image-2.6.38-12-generic:
  Installed: (none)
  Candidate: 2.6.38-12.51~lucid1
  Version table:
     2.6.38-12.51~lucid1 0
        500 http ://packages/ubuntu-updates/ lucid-updates/main Packages
        500 http ://packages/ubuntu-security/ lucid-security/main Packages

$ sudo apt-get install linux-image-2.6.38-12-generic

Si noti che il "-12" sarà incrementato per le versioni future, "-12" è la versione di oggi.

Per cercare le versioni future:

$ apt-cache search linux-image-2.6.38

Anche ppa: kernel-ppa / ppa è stato sostituito con ppa: canonical-kernel-team / ppa
Vedi: link

    
risposta data nutznboltz 27.10.2011 - 22:47
0

Seguo sempre queste istruzioni per Ubuntu / Mint, impiega circa 5 minuti + tempo di download. Come sempre essere più cauto quando si aggiorna a un nuovo kernel: a volte rompe la compatibilità con determinati software / hardware.  Non ho mai avuto problemi io stesso, ma è ovvio che pratichiamo la prudenza e teniamo in mano l'ultimo kernel funzionante

link

    
risposta data Wolver1n3 14.02.2012 - 12:16

Leggi altre domande sui tag