systemd: risolve l'utilizzo della CPU dopo l'aggiornamento alla 17.04

21

Ho recentemente aggiornato Xubuntu dal 16.10 al 17.04.

Ogni cosa funziona bene eccetto systemd-resolve. alcune volte rende l'utilizzo della cpu troppo alto e non so perché questo problema è stato raggiunto.

Ed ecco l'output del comando top :

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                               
  1114 systemd+  20   0   51532   6744   4504 R   100  0.0   9:51.67 systemd-resolve                       
  1152 dnsmasq   20   0   64360   2892   2480 R  38.9  0.0   4:05.53 dnsmasq                               
  1245 root      20   0  376644  89644  64436 S   1.7  0.5   0:35.69 Xorg                                  
  1624 asus      20   0  370160  45820  28488 S   0.7  0.3   0:00.90 python2                               
  2238 asus      20   0 2562816 553112 128492 S   0.7  3.4   2:41.20 firefox                               
    16 root      20   0       0      0      0 S   0.3  0.0   0:01.05 ksoftirqd/1                           
   708 root     -51   0       0      0      0 S   0.3  0.0   0:01.20 irq/95-ELAN1000                       
  1302 root     -51   0       0      0      0 S   0.3  0.0   0:03.68 irq/142-nvidia                        
  1734 asus      20   0  483388  11060   8560 S   0.3  0.1   0:05.45 conky                                 
  2820 root      20   0       0      0      0 S   0.3  0.0   0:00.14 kworker/5:1                           
  3420 asus      20   0   53384   3932   3200 R   0.3  0.0   0:00.76 top                                   

Non so perché questo problema è accaduto, ma di solito si verifica quando esegui alcuni comandi come sudo apt update .

(Sto usando tor e obfs4proxy, potrebbe essere utile per la risposta)

    
posta Ali Razmdideh 27.04.2017 - 16:50

4 risposte

30

Ho avuto un conflitto simile tra systemd-resolve e dnsmasq sulla porta 53.

link

e

link

mi ha spinto ad aggiungere DNSStubListener=no in /etc/systemd/resolved.conf e poi sudo service systemd-resolved restart .

    
risposta data MetricMike 27.04.2017 - 17:47
16

Problemi causati con altre app (teamViewer nel mio caso)

Suggerito da un altro Passi di soluzione

Aggiungi la riga DNSMASQ_EXCEPT=lo a /etc/default/dnsmasq

sudo nano /etc/default/dnsmasq

Riavvia dnsmasq tramite

sudo service systemd-resolved restart

Dire grazie Se ho aiutato, è tornato alla normalità e NON si avvita con altre app, come il metodo precedente DIED.

Cheers, Mark

    
risposta data markackerman8-gmail.com 24.10.2017 - 01:42
6

systemd-resolved diventa folle quando qualcuno modifica il file /etc/resolv.conf , che intende indicare il proprio indirizzo di ascolto 127.0.0.53.

Qualcuno potrebbe essere uno script attivato da eventi di rete (VPN in arrivo o in discesa, DHCP, ecc.)

Se si imposta il server dei nomi su 127.0.0.53, la risoluzione del sistema si "calmerà" pochi secondi dopo.

Supponendo che tutti rispettino le regole e solo usando resolvconf per modificare la configurazione del resolver, puoi anche fare questo:

Il file /etc/resolvconf/interface-order specifica l'ordine in cui verranno utilizzati i server dei nomi, a seconda dell'interfaccia di rete dalla quale sono stati ricevuti.

Se aggiungi una voce per systemd-resolved nella parte superiore del file, verrà sempre considerata per prima e il file non verrà modificato.

    
risposta data xalkina 02.11.2017 - 18:12
1

Ho avuto lo stesso problema nel 18.04. systemd-resolved e dnsmasq tendono al ciclo. L'ho risolto in questo modo:

Aggiungi o esclude il commento dalla seguente riga in /etc/default/dnsmasq :

IGNORE_RESOLVCONF=yes

Crea il tuo file resolv ( /etc/resolv.personal ) per definire i server dei nomi. Puoi usare qualsiasi server dei nomi qui. Ne ho presi due da OpenNIC .

nameserver 5.132.191.104
nameserver 103.236.162.119

In /etc/dnsmasq.conf aggiungi o esclude la seguente riga:

resolv-file=/etc/resolv.personal

Quindi riavvia dnsmasq e disattiva il resolver predefinito: systemd-resolved .

sudo service dnsmasq restart
sudo systemctl stop systemd-resolved
sudo systemctl disable systemd-resolved
    
risposta data Daniel Pernold 22.08.2018 - 22:45

Leggi altre domande sui tag