Problema Installazione e configurazione di PostgreSQL

18

Sono un principiante qui e per l'amministrazione del server. Un paio di giorni fa ho registrato un server con Hetzner con Ubuntu 11.04.

Ho intenzione di lavorare con PostgreSQL, per il quale ho installato dal sorgente dopo aver fallito l'installazione usando apt-get. L'installazione non ha esito negativo, ma il servizio PostgreSQl non si avvia automaticamente o quando provo ad avviarlo manualmente. Non riesce con il seguente messaggio di errore quando provo a fare qualcosa con esso:

[email protected]:~$ sudo su postgres -c psql template1
psql: could not connect to server: No such file or directory
    Is the server running locally and accepting
    connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?

Questo era l'errore che stavo ottenendo quando ho installato PostgreSQL usando apt-get e l'ho reinstallato dal sorgente. Quello che segue è l'output che ho ottenuto quando l'ho installato dal sorgente. Ciò conferma che PostgreSQL è effettivamente installato.

make -C config install
make[1]: Entering directory '/home/manager/postgresql-9.0.4/config'
/bin/mkdir -p '/usr/local/pgsql/lib/pgxs/config'
/bin/sh ../config/install-sh -c -m 755 ./install-sh '/usr/local/pgsql/lib/pgxs/config/install-sh'
make[1]: Leaving directory '/home/manager/postgresql-9.0.4/config'
PostgreSQL installation complete.

Ma il servizio non si avvia automaticamente? Non qui:

[email protected]:~$ ps auxw | grep post
manager   6734  0.0  0.0   4156   868 pts/0    S+   14:10   0:00 grep --color=auto post

Questo sta pagando un pedaggio sulla mia pazienza e fiducia. Per favore aiutami a risolvere questo problema.

    
posta Syed Aslam 11.05.2011 - 14:48

5 risposte

27

Rispondere alla mia domanda. Questo è un po 'fastidioso, la prima domanda su qualsiasi sito StackExchange non va bene per me.

L'avevo già fatto, ma in qualche modo ha funzionato questa volta. Questo:

  1. sudo apt-get update & amp; & amp; sudo apt-get upgrade
  2. sudo apt-get purge postgresql *
  3. sudo apt-get -f install
  4. sudo apt-get install postgresql

Funziona come un fascino.

Nota: aggiungendo il comando * nel comando purge verranno eliminati tutti i pacchetti che iniziano con postgresql

    
risposta data Syed Aslam 11.05.2011 - 17:54
6

Anch'io ho affrontato questo problema con Hetzner e molto fastidioso. Ecco come l'ho risolto Suggerimento: alcuni script del pacchetto pg

sudo apt-get purge postgresql* # ending * è importante

sudo apt-get install postgresql

Sospetto che l'immagine di 11.04 di Hetzner sia bacata o che sia Ubuntu .deb (comunque improbabile).

    
risposta data Shekhar 02.09.2011 - 20:10
2

Non ho visto questo errore su launchpad in associazione con Natty. Lo stesso problema è stato sollevato come un bug sul launchpad per Hardy e ottenuto un risolvere. Quindi seguendo questa logica mi aspetterei che fosse un bug ed è probabilmente una buona pratica inserire un bug su launchpad.

Guardando oltre, ho trovato 2 argomenti interessanti (ancora vecchi) che mostrano lo stesso identico errore che sembra valga la pena di esaminare:

Questo argomento del 2006 parla dello stesso identico problema e afferma che

sudo /etc/init.d/postgresql-8.1 stop

sudo /etc/init.d/postgresql-8.1 start

psql template1

opere.

Su ubuntuforums c'è un argomento del 2008 sullo stesso errore e ha uno stato 'risolto'. Si prega di dare un'occhiata ai molti suggerimenti in tale argomento.

    
risposta data Rinzwind 11.05.2011 - 15:15
2

psql è il cli client, non avvia il server PostgreSQL. Per avviare il server, è necessario utilizzare:

/etc/init.d/postgresql start

quindi puoi collegarti ad esso usando psql.

Per avviare PostgreSQL all'avvio, dovresti fare quanto segue:

update-rc.d postgresql enable

Puoi anche dare un'occhiata a questo:

link

    
risposta data Cliff Wells 15.05.2011 - 03:14
0

Avendo Ubuntu 14.04, stavo avendo problemi simili e non riuscivo a farlo funzionare usando le soluzioni di cui sopra. Alla fine ho trovato la mia risposta qui .

a) Ho eseguito questo comando aptitude search postgresql|grep ^i nel terminale e ho ottenuto i seguenti risultati:

i   postgresql                      - object-relational SQL database (supported 
i A postgresql-9.3                  - object-relational SQL database, version 9.
i A postgresql-client-9.3           - front-end programs for PostgreSQL 9.3     
i A postgresql-client-common        - manager for multiple PostgreSQL client ver
i A postgresql-common               - PostgreSQL database-cluster manager

b) Quindi: sudo aptitude purge postgresql postgresql-9.3 postgresql-common

c) Infine: sudo aptitude install postgresql

Tutto ora funziona bene.

    
risposta data 8bithero 15.04.2014 - 14:32

Leggi altre domande sui tag