Come modificare le autorizzazioni predefinite dei file creati da transmission-demone?

19

Ho una macchina con un server Ubuntu 12.04 con demone di trasmissione in esecuzione per gestire i bitorrenti. Tutto funziona bene, tranne che il demone di trasmissione crea file come utente / gruppo, debian-transmission e con 744 autorizzazioni di file.

  • Vorrei poter eliminare e spostare questi file da una condivisione samba.

  • Ho preso in considerazione di cambiare il gruppo principale della trasmissione debian utente, ma ero preoccupato che potesse compromettere l'accesso ad altri file.

  • Ho pensato che sarebbe stato meglio cambiare il permesso di default dei nuovi file creati da debian-transmission in 774 e aggiungermi al gruppo debian-transmission.

    So che questo può essere fatto con una umask, ma la mia comprensione è che questo sarebbe stato impostato nel file .profile e poiché la trasmissione debian non ha una cartella home non sono sicuro che quel file esistesse per l'utente. Quindi come posso realizzare questo?

    Suggerimenti o soluzioni alternative sono i benvenuti. Grazie in anticipo.

posta jpetersen 29.06.2012 - 07:31

2 risposte

39

È possibile specificare una umask nel file di configurazione della trasmissione ( /etc/transmission-daemon/settings.json ). Umask normalmente rappresentiamo in ottale, ma sfortunatamente, json non lo supporta, quindi dobbiamo convertirlo in base 10. Puoi farlo nella shell in questo modo:

$ echo $(( 8#022 ))
18

Questo è il valore predefinito, ma probabilmente vuoi 002, che è lo stesso in decimale, quindi

sudo editor /etc/transmission-daemon/settings.json
# change "umask": 18 to "umask": 2 and save
sudo reload transmission-daemon # tells transmission-daemon to re-read the config 
                                # file. This is important, otherwise, the changes
                                # will be lost

Un'altra cosa. Se si modifica la proprietà del gruppo della directory di download e si aggiunge il bit setgid, tutti i file creati in tale directory avranno lo stesso proprietario del gruppo di quella directory.

sudo chgrp "$USER" /path/to/transmission/download/dir
sudo chmod g+s /path/to/transmission/download/dir

Non influenzerà i file già esistenti. Vedi link per ulteriori informazioni.

    
risposta data geirha 29.06.2012 - 08:29
0

Prova questo:

mkdir /your_path/progress
mkdir /your_path/completed
sudo usermod -a -G debian-transmission your_user
chgrp debian-transmission /your_path/progress
chgrp debian-transmission /your_path/completed
chmod 770 /your_path/progress
chmod 770 /your_path/completed
sudo service transmission-daemon stop
sudo adduser your_user debian-transmission
sudo nano /etc/init.d/transmission-daemon
sudo chown your_user -R /var/lib/transmission-daemon/info/
sudo chown your_user -R /your_path/progress
sudo chown your_user -R /your_path/completed
sudo chown your_user -R /etc/transmission-daemon/settings.json

E cambia nel file:     sudo nano /etc/transmission-daemon/settings.json

"rpc-whitelist": "127.0.0.1" > "rpc-whitelist": "*.*.*.*",
"rpc-password": "password" > "rpc-password": "your_password",
"download-dir": "/var/lib/transmission-daemon/downloads" > "download-dir": "/your_path/completed"
"incomplete-dir": "/var/lib/transmission-daemon/downloads" > "incomplete-dir": "/your_path/progress"

Riavvia il demone:

service transmission-daemon start
    
risposta data costales 21.10.2013 - 20:11

Leggi altre domande sui tag