Nessuna connettività Internet in virtual-box con host e sistema operativo virtuale 12.04

19

Ho Preciso 12.04 installato come sistema operativo host. In VirtualBox, ho anche installato 12.04.

Non riesco a connettere Virtual 12.04 all'host internet. Ho provato a selezionare tutte le opzioni disponibili negli adattatori di rete (NAT, Host only, Bridge, ecc.), Ma non funzionano. In alcune opzioni alcune cose devono essere inserite manualmente, che non so cosa inserire.

Dove sto andando male nelle impostazioni?

    
posta Nirmik 29.05.2012 - 18:44

5 risposte

22

La connessione NAT doveva essere selezionata con l'hardware:

AMD PCNet FAST III (Am79C973, the default)

Funziona con quasi tutti i sistemi operativi (come menzionato nella pagina della guida di Virtualbox ). L'impostazione Intel per qualche motivo non ha funzionato.

Per le impostazioni di rete con impostazioni router pesanti, potrebbe essere necessario utilizzare l'opzione Bridged con "PCNet FAST III" come impostazione predefinita.

    
risposta data Nirmik 30.05.2012 - 09:15
3

VB probabilmente crea una connessione "Unidentied Network" con la tua macchina reale e la usa come sorgente per la connessione a Internet. Segui le impostazioni di seguito per verificare le basi per far funzionare Internet nel tuo sistema operativo virale.

Impostazioni di rete: * Seleziona NAT sotto "Allegati a:" * "Adapter Type:" MT Desktop (può essere modificato solo quando vm è spento) * La casella "Cavo collegato" è spuntata

Impostazioni di sistema: * La casella "Rete" è selezionata nell'elenco "Ordine di avvio:".

    
risposta data Benjamin 15.05.2013 - 18:34
2

Volevo solo far sapere a tutti che ho risolto il problema disinstallando Virtualbox dal Software Center e installando la copia che ho trovato sul sito web virtualbox.org. Poi ho anche impostato l'adattatore su AMD PCNet FAST III (Am79C973, l'impostazione predefinita)

    
risposta data alemur 18.03.2013 - 15:22
0

Usando Debian nella mia VM, ho dovuto modificare / etc / network / interfaces per usare eth0 come interfaccia di loopback predefinita:

...
auto eth0
iface eth0 inet dhcp
    
risposta data Greg K. 24.12.2015 - 00:49
0

Rimuovi tutti i pacchetti virtualbox dal sistema quindi installa il pacchetto da Virtualbox.org è tutto a causa della mancanza di /usr/lib/virtualbox/VBoxNetNAT binario, l'accesso a Internet in modalità di rete NAT non funziona. Questa non è un'opzione NAT predefinita.

Normalmente dovrebbe eseguire questo file come:

/usr/lib/virtualbox/VBoxNetNAT --ip-address 10.0.2.1 --netmask 255.255.255.0 --network NatNetwork --trunk-type whatever

Ma senza questo file, gli ospiti ottengono solo l'indirizzo IP dal server DHCP e non possono connettersi a Internet. La comunicazione tra gli ospiti funziona molto bene.

Dopo aver disinstallato tutti i pacchetti virtualbox e installato il pacchetto (5.1.4-110228 ~ Ubuntu ~ fidato) da VirtualBox.org, /usr/lib/virtualbox/VBoxNetNAT si connette molto bene a Internet.

    
risposta data Borys 09.09.2016 - 16:29