Come posso impedire a Skype di avviarsi automaticamente all'avvio?

27

La mia ragazza ha effettuato l'accesso al suo account Skype dal mio netbook Xubuntu 12.10 e da allora Skype si avvia automaticamente ogni volta che avvio. Come posso evitare che ciò accada?

Cose che ho provato:

  • Rimuovendolo dalla Gestione impostazioni - & gt; Sessione e Avvio - & gt; Autostart dell'applicazione - non è stato possibile trovarlo nell'elenco.
  • Controllo di un'impostazione pertinente in Skype stesso - impossibile trovare nulla del genere. (Ricordo che c'era un'impostazione simile di Skype da qualche parte ogni volta che l'ho usato su Windows. Considerando che la mia ragazza è un utente di Windows, potrebbe essere che questa è un'impostazione disponibile sul client Windows ma non su quella Linux, e in qualche modo trasferito?)
  • Usando BUM per disattivarlo, ancora una volta, non è stato possibile trovarlo nell'elenco.
  • Disinstallazione di Skype con apt-get remove skype --purge e sperando che rimuova anche tutte le impostazioni - non lo ha fatto.

Salva per la reinstallazione, che altro posso provare?

Mentre si è sulla stessa nota: come è possibile che Skype esegua l'avvio automatico senza passare per la normale rotta Upstart?

EDIT: un paio di altre cose che ho provato:

  • Cercando qualcosa di simile nel supporto Skype - Non mi aspettavo di trovare nulla, e non l'ho fatto.
  • Esaminare la cartella .Skype nella mia home directory. Ho trovato un paio di file che sembravano promettenti ( .Skype/shared.xml , .Skype/[my username]/config.xml , .Skype/[girlfriend's username]/config.xml ), ma guardare attraverso di loro non ha dato alcun risultato. Un sacco di file SQLite però. Potrebbe essere che questa impostazione è da qualche parte all'interno?
posta Andrey 17.03.2013 - 12:05

10 risposte

23

Ho avuto lo stesso problema e il seguente sembra aver preso cura di esso: vai a (Xubuntu) Impostazioni & gt; Sessioni e avvio & gt; Sessione, trova Skype e fai clic con il tasto sinistro del mouse dove dice "Se è in esecuzione" e modificalo su "Mai".

    
risposta data azeam 19.03.2013 - 10:15
27

Per la nuova versione 2017 di skype che è abbastanza sfacciata da aggiungersi all'autostart ogni volta che viene avviato (seriamente? Non installarlo mai sul mio computer) è sufficiente creare una cartella con lo stesso nome di un file che sta tentando di creare :

rm ~/.config/autostart/skypeforlinux.desktop
mkdir ~/.config/autostart/skypeforlinux.desktop
    
risposta data int_ua 16.11.2017 - 13:48
12

Dal momento che sembra che le risposte qui cambino sempre, a partire da un'installazione di skypeforlinux di questa settimana (versione 8.11.0.4), sono riuscito a far arrestare l'avvio automatico con due passaggi.

Per prima cosa, apri Skype, vai su Strumenti & gt; Impostazioni e deseleziona "Avvia automaticamente Skype".

Quindi, ispirato al suggerimento di azeam, vai a (Xubuntu) Impostazioni & gt; Sessioni e avvio & gt; Avvia automaticamente l'applicazione e rimuovi l'elemento per Skype. Non sono sicuro che la deselezione funzioni; L'ho provato per primo, ma potrebbe essere in conflitto con le impostazioni interne di Skype quando l'ho provato.

    
risposta data Dan 10.12.2017 - 18:47
7

Ho avuto lo stesso problema. Sono stato in grado di impedire l'avvio automatico rimuovendo skypeforlinux.desktop da ~/.config/autostart/ . Sto usando lubuntu; la posizione della cartella di avvio automatico può variare. Puoi trovare usando:

$ locate skypeforlinux.desktop

In realtà, vuoi solo eliminare la copia nella directory chiamata autostart , altrimenti non sarai in grado di avviare l'app dall'icona.

Suppongo che la prossima volta che eseguirai intenzionalmente Skype (spero, in nome della tua sanità mentale, che questo giorno sia lontano in futuro) che cercherà di mettere quel file indietro. In tal caso, potrebbe essere necessario eliminarlo nuovamente o setacciare Skype per l'impostazione che impedirà tale comportamento.

    
risposta data Thismatters 01.11.2017 - 14:44
5

Vai a Strumenti - & gt; Opzioni - & gt; Impostazioni generali. Deseleziona l'opzione "Avvia Skype all'avvio". Salva ed esci da Skype.

    
risposta data Massdon1 17.03.2013 - 12:23
2

In Kubuntu 14.04, il problema è stato risolto andando su Startup and Shutdown, quindi su Gestione sessione e selezionando Start con una sessione vuota e Applica.

    
risposta data Craig 05.05.2014 - 20:07
1

Per la normale Ubuntu 16.04, cerca "Startup Applications". Quando la finestra si apre, basta rimuovere il segno di spunta da Skype per impedirne l'avvio all'avvio, quindi fare clic su rimuovi mentre si seleziona Skype per cancellarlo dall'elenco.

    
risposta data yusko 20.05.2018 - 20:55
0

Sembra che il "closing" di Skype in realtà non lo stia davvero chiudendo. Lo puoi notare anche dal fatto che se lo riapri, è già registrato.

Puoi davvero chiuderlo digitando nella riga di comando:

killall skype

In questo modo non verrà salvato nella sessione di lavoro quando esci dal tuo computer e quindi non verrà ripristinato automaticamente al riavvio del computer.

    
risposta data Thijs 16.08.2014 - 00:54
0

Chiusura di Skype non equivale a Uscire da Skype. Ho fatto tre cose in Kubuntu 14.04. Dopo aver aperto Skype, sono andato su Skype (Menu) & gt; Opzioni & gt; Generale e selezionato "Avvia Skype ridotto a icona nella barra delle applicazioni". Quindi seleziona Opzioni & gt; Avanzate e deselezionate "Verifica aggiornamenti all'avvio". Infine, anziché "Esci", ho fatto clic su "Esci" nella parte inferiore del menu. Credo che sia stato il passo finale a fare il trucco.

    
risposta data WGCman 19.03.2015 - 01:41
0

Impostazioni Skype (per Linux)

Apri Skype - Menu: extra - & gt; impostazioni - & gt; categoria: start e close

1. Avvio automatico di Skype

cambia impostazione:

true :

/home/$USER/.config/autostart/skypeforlinux.desktop

= & gt; file esiste

false :

/home/$USER/.config/autostart/skypeforlinux.desktop

= & gt; il file NON esiste!

rm -rf /home/$USER/.config/autostart/skypeforlinux.desktop

Elimina l'avvio automatico, ma questo file viene creato nuovamente dopo le modifiche!

Quindi è meglio cambiare il codice che cancellare questo file:

/home/$USER/.config/autostart/skypeforlinux.desktop

Avvio automatico: X-GNOME-autostart-abilitato = true

NO Autostart: X-GNOME-autostart-enabled = false

sed -i 's/X-GNOME-Autostart-enabled=true/X-GNOME-Autostart-enabled=false/g' $HOME/.config/autostart/skypeforlinux.desktop

2. Skype inizia in background

true :

/home/$USER/.config/skypeforlinux/settings.json

"app.launchMinimized": true

false :

/home/$USER/.config/skypeforlinux/settings.json

"app.launchMinimized": false

3. Skype viene eseguito in background

true :

/home/$USER/.config/skypeforlinux/settings.json

"app.onCloseKeepRunning": true

false :

/home/$USER/.config/skypeforlinux/settings.json

"app.onCloseKeepRunning": false

Testato con:

  • skypeforlinux 8.18.0.6 amd64
  • Ubuntu 16.04.1 LTS
  • Cannella
risposta data Werner Nöbauer 09.04.2018 - 14:47

Leggi altre domande sui tag