Aggiornamento software: richiede l'installazione di pacchetti da origini non autenticate

19

Quando si tenta di installare pacchetti tramite l'aggiornamento del software su Ubuntu 14.04.1 LTS, viene visualizzato l'errore seguente:

Riguarda questi pacchetti:

Ho selezionato le seguenti impostazioni da cui installare gli aggiornamenti da:

Ho eseguito i seguenti comandi:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade

sudo apt-get update fornisce il seguente output:

Reading package lists... Done
W: GPG error: https://download.01.org trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A902DDA375E52366
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)

sudo apt-get upgrade fornisce il seguente output:

The following packages have been kept back:
  libegl1-mesa libegl1-mesa-drivers libgbm1 libgl1-mesa-dri libgl1-mesa-glx
  libglapi-mesa libgles1-mesa libgles2-mesa libosmesa6 liboxideqt-qmlplugin
  liboxideqtcore0 libwayland-egl1-mesa libxatracker2 linux-generic
  linux-generic-pae linux-headers-generic linux-headers-generic-pae
  linux-image-generic linux-image-generic-pae oxideqt-codecs
  python-cupshelpers system-config-printer-gnome
0 upgraded, 0 newly installed, 0 to remove and 22 not upgraded.

UPDATE

Con domanda Come faccio trattare gli errori "fonti non autenticate" nel Software Center?

emettere i seguenti comandi:

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update

restituisce ancora l'output seguente:

Reading package lists... Done
W: GPG error: https://download.01.org trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A902DDA375E52366
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)

Seguì la seconda risposta:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A902DDA375E52366
sudo apt-get update

ma ricevi il seguente errore:

W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems

e apt-get update non risolve il problema

    
posta Noosrep 27.01.2015 - 09:43

3 risposte

8

Potresti eseguire:

sudo apt-get update && sudo apt-get dist-upgrade
    
risposta data Dustin 06.05.2015 - 17:32
1

Per correggere la voce duplicata nel file sources.list:

Aprilo in un editor con i diritti root / sudo e.g:

sudo nano /etc/apt/sources.list

e rimuovi la riga duplicata (non importa quale):

http://dl.google.com/linux/chrome/deb/

Quindi usa ctrl-x per uscire (y per salvare). Fai un aggiornamento e aggiorna apt-get come faresti normalmente.

    
risposta data NGRhodes 27.01.2015 - 12:06
0

Commenta quelle linee, di cui questo errore sta producendo.

Apri terminale

CTRL+ ALT+ T

usa i comandi.

cd /etc/apt/

modifica il file source.list

sudo nano source.list

Commenta le linee con il simbolo # menzionato nel log degli errori.

aggiornare il source.list e aggiornare il software tramite la riga di comando.

sudo apt-get clean    
sudo apt-get update 
sudo apt-get upgrade
    
risposta data Hafiz Shehbaz Ali 26.10.2015 - 17:56

Leggi altre domande sui tag