Come posso far funzionare fsck in modo non interattivo al momento dell'avvio?

19

Ho un server Ubuntu 12.04 senza testa in un datacenter a 1500 miglia di distanza. Due volte ora al riavvio il sistema ha deciso che doveva fsck. Sfortunatamente Ubuntu ha eseguito fsck in modalità interattiva, quindi ho dovuto chiedere a qualcuno del mio datacenter di andare oltre, collegare una console e premere il tasto Y. Come faccio a configurarlo in modo che fsck venga eseguito in modalità non interattiva all'avvio con il flag -y o -p (alias -a )?

Se comprendo correttamente il processo di avvio di Ubuntu, init richiama mountall che a sua volta richiama fsck. Tuttavia non vedo alcun modo per configurare come viene richiamato fsck. È possibile?

(Per evitare un suggerimento, sono consapevole che posso usare tune2fs -i 0 -c 0 per prevenire fscks periodici. Questo può aiutare un po 'ma ho bisogno che il sistema tenti di tornare anche se avesse una vera ragione per fsck , per esempio dopo un'interruzione di corrente.)

In risposta alle domande di follow-up, ecco i dettagli pertinenti del mio / etc / fstab. Non credo di averlo modificato da ciò che Ubuntu ha messo lì.

UUID=3515461e-d425-4525-a07d-da986d2d7e04 /               ext4    errors=remount-ro 0       1
UUID=90908358-b147-42e2-8235-38c8119f15a6 /boot           ext4    defaults        0       2
UUID=01f67147-9117-4229-9b98-e97fa526bfc0 none            swap    sw              0       0
    
posta Nelson 15.06.2012 - 01:44

3 risposte

27

L'impostazione che sto cercando è / etc / default / rcS , %codice%. Ciò significa "riparare automaticamente i filesystem con incoerenze durante l'avvio" e fa in modo che fsck venga eseguito con il flag FSCKFIX=yes . È stato impostato su -y in entrambi i miei sistemi Ubuntu.

Anche se impostato su no , il tempo di avvio fsck è ancora un po 'non interattivo. mountall esegue fsck con no , un sinonimo di -a , che significa "aggiusta automaticamente eventuali problemi del filesystem che possono essere risolti in modo sicuro senza l'intervento umano". Apparentemente -p scende in modalità interattiva se ci sono correzioni non sicure da fare. Per eseguire completamente automaticamente, devi -p o -y .

Ecco il bit di codice rilevante da mountall.c

if (fsck_fix || mnt->fsck_fix) {
  NIH_MUST (nih_str_array_add (&args, NULL, &args_len, "-y"));
} else {
  NIH_MUST (nih_str_array_add (&args, NULL, &args_len, "-a"));
}
    
risposta data Nelson 16.06.2012 - 16:42
1

Assicurati di non avere nessun flag che potrebbe causare questo in fstab e controlla i tuoi script di init. (Prova a eseguire gli script di init per 'fsck' per trovare dove è usato) Il mio sistema esegue fsck non interattivo, quindi ecco una copia del mio fstab e parte del mio script / etc / init / mountall da confrontare

$ cat /etc/fstab
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
UUID=acbe3514-33a3-4170-b1be-df7b8460a49a /               ext4    errors=remount-ro 0       1
UUID=d361f696-7abc-11e1-9043-5711de71ade6 /home           ext4    defaults        0       2
UUID=213e032c-fce9-4e1b-9d64-0779f0db4208 none            swap    sw              0       0

Snippet da / etc / init / mountall

script
    . /etc/default/rcS
    [ -f /forcefsck ] && force_fsck="--force-fsck"
    [ "$FSCKFIX" = "yes" ] && fsck_fix="--fsck-fix"

    # set $LANG so that messages appearing in plymouth are translated
    if [ -r /etc/default/locale ]; then
        . /etc/default/locale
        export LANG LANGUAGE LC_MESSAGES LC_ALL
    fi

    exec mountall --daemon $force_fsck $fsck_fix
end script
    
risposta data Sepero 15.06.2012 - 03:05
0

Per Ubuntu 15,16,17+ l'impostazione del valore FSCKFIX si trova in lib / init / vars.sh

Può usare il comando grep -r FSCKFIX * 2>/dev/null per finirlo.

    
risposta data setec 04.02.2018 - 17:14

Leggi altre domande sui tag