SLOW Boot e Login per Ubuntu 16.04

18

Ubuntu 16.04 64 bit impiega circa 20 secondi dalla schermata di login al desktop e circa 20 secondi da grub alla schermata di accesso,

dimmi quali servizi posso disabilitare in sicurezza, non uso frequentemente virtualbox e bluetooth, tutte le altre cose sono usate come stampante, wifi, ecc.
uscita di systemd-analyze

Startup finished in 5.145s (kernel) + 14.138s (userspace) = 19.284s

e output di

systemd-analyze blame


 5.837s accounts-daemon.service
          5.444s dev-sda6.device
          4.864s grub-common.service
          4.105s lightdm.service
          4.075s ModemManager.service
          4.001s preload.service
          3.844s apparmor.service
          3.566s networking.service
          3.468s apport.service
          3.332s ondemand.service
          3.272s rsyslog.service
          3.269s systemd-logind.service
          3.253s alsa-restore.service
          3.241s gpu-manager.service
          3.226s avahi-daemon.service
          3.185s systemd-user-sessions.service
          3.185s pppd-dns.service
          2.508s NetworkManager.service
          2.003s [email protected]
          1.640s plymouth-quit-wait.service
          1.245s colord.service
           712ms systemd-update-utmp.service
           687ms systemd-udevd.service
           669ms udisks2.service
           632ms polkitd.service
           602ms brltty.service
           572ms systemd-localed.service
           567ms [email protected]:intel_backlight.service
           543ms systemd-rfkill.service
           527ms systemd-tmpfiles-setup-dev.service
           519ms thermald.service
           490ms systemd-tmpfiles-setup.service
           464ms systemd-modules-load.service
           454ms systemd-tmpfiles-clean.service
           450ms systemd-timesyncd.service
           428ms systemd-journald.service
           371ms wpa_supplicant.service
           340ms ufw.service
           317ms systemd-random-seed.service
           284ms console-setup.service
           281ms plymouth-start.service
           270ms dev-hugepages.mount
           270ms sys-kernel-debug.mount
           224ms systemd-udev-trigger.service
           177ms dev-mqueue.mount
           168ms plymouth-read-write.service
           165ms upower.service
           131ms dns-clean.service
           103ms systemd-sysctl.service
           102ms dev-disk-by\x2duuid-8bd6db03\x2da87b\x2d4614\x2d927a\x2dd5916f3
            68ms systemd-hostnamed.service
            49ms systemd-journal-flush.service
            47ms kmod-static-nodes.service
            47ms snapd.socket
            32ms systemd-remount-fs.service
            28ms rc-local.service
            10ms resolvconf.service
            10ms rtkit-daemon.service
             9ms systemd-update-utmp-runlevel.service
             6ms ureadahead-stop.service
             4ms sys-fs-fuse-connections.mount lines 39-61/61 (END)

Così come:

systemd-analyze critical-chain

the time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @14.124s
└─lightdm.service @10.018s +4.105s
  └─systemd-user-sessions.service @6.731s +3.185s
    └─basic.target @6.625s
      └─sockets.target @6.625s
        └─snapd.socket @6.576s +47ms
          └─sysinit.target @6.574s
            └─swap.target @6.574s
              └─dev-disk-by\x2duuid-8bd6db03\x2da87b\x2d4614\x2d927a\x2dd5916f3c
                └─dev-disk-by\x2duuid-8bd6db03\x2da87b\x2d4614\x2d927a\x2dd5916f
lines 1-13/13 (END)

Sto usando un HDD con 7200 RPM, penso che il tempo di avvio sia ok, ma dopo la schermata di login, devo passare 20 secondi con uno schermo vuoto, ho già disabilitato alcuni elementi di avvio come ORCA, BLUETOOTH, monitor di backup, accessibilità ecc., condivisione di file personali e aggiornamento di cartelle utente ecc., ancora niente sta migliorando, come diagnosticare il colpevole e trattarlo.

    
posta Kanhiya 25.05.2016 - 11:58

1 risposta

5

Prova a rimuovere alcune dipendenze inutilizzate e pacchetti orfani. Questo aiuterà.
Ha funzionato nel mio caso. Esegui:

sudo apt autoremove && sudo apt autoclean

Inoltre, puoi installare Gtkorphan ( sudo apt-get install gtkorphan ) per rimuovere tutti i pacchetti orfani e le dipendenze lasciati da altre app.

    
risposta data Collin 11.09.2016 - 00:50

Leggi altre domande sui tag