Sfarfallio del mouse su uno dei miei due schermi

18

Ho appena installato Ubuntu 14.04 e il mouse ora sta tremolando su uno dei miei due schermi . L'altro schermo non ha lo sfarfallio. In precedenza stavo usando ubunutu 13.10 senza alcun problema.

  • Se disattivo lo schermo che funziona correttamente, il secondo schermo smette di lampeggiare e inizia a funzionare correttamente.
  • Se disattivo lo schermo sfarfallio, l'altra schermata continua a funzionare correttamente.

Ho già provato le soluzioni trovate qui:

Ecco come appaiono le mie impostazioni di visualizzazione:

Sto utilizzando il driver X.Org X Server - Nouveau display driver from xserver-xorg-video-nouveau (open source) . Se provo a passare a uno di proprietà nvidia proprietaria, e clicco sul pulsante Apply Changes , inizia e richiede sempre il completamento, le modifiche sembrano non essere mai applicate.

Ecco quali uscite xrandr :

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
VGA-1 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080      60.0*+
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
HDMI-1 disconnected (normal left inverted right x axis y axis)
VGA2 disconnected
HDMI2 disconnected
DP1 disconnected
HDMI3 disconnected
HDMI4 connected 1920x1080+1920+0 521mm x 293mm
   1920x1080      60.0*+   50.0     59.9     30.0     25.0     24.0     30.0     24.0  
   1920x1080i     60.1     50.0     60.0  
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1280x720       60.0     50.0     59.9  
   1440x576i      50.1  
   1024x768       75.1     60.0  
   1440x480i      60.1     60.1  
   800x600        75.0     60.3     56.2  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        75.0     72.8     66.7     60.0     59.9  
   720x400        70.1  
DP2 disconnected
DP3 disconnected
VIRTUAL1 disconnected
  1920x1080 (0x4b)  148.5MHz
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock   67.5KHz
        v: height 1080 start 1084 end 1089 total 1125           clock   60.0Hz
  1680x1050 (0xa2)  119.0MHz
        h: width  1680 start 1728 end 1760 total 1840 skew    0 clock   64.7KHz
        v: height 1050 start 1053 end 1059 total 1080           clock   59.9Hz
  1280x1024 (0xa3)  135.0MHz
        h: width  1280 start 1296 end 1440 total 1688 skew    0 clock   80.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   75.0Hz
  1280x1024 (0xa4)  108.0MHz
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock   64.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   60.0Hz
  1024x768 (0xa5)   78.8MHz
        h: width  1024 start 1040 end 1136 total 1312 skew    0 clock   60.1KHz
        v: height  768 start  769 end  772 total  800           clock   75.1Hz
  1024x768 (0xa6)   65.0MHz
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0xa7)   49.5MHz
        h: width   800 start  816 end  896 total 1056 skew    0 clock   46.9KHz
        v: height  600 start  601 end  604 total  625           clock   75.0Hz
  800x600 (0xa8)   40.0MHz
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0xa9)   36.0MHz
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz
  640x480 (0xaa)   31.5MHz
        h: width   640 start  656 end  720 total  840 skew    0 clock   37.5KHz
        v: height  480 start  481 end  484 total  500           clock   75.0Hz
  640x480 (0xab)   31.5MHz
        h: width   640 start  664 end  704 total  832 skew    0 clock   37.9KHz
        v: height  480 start  489 end  491 total  520           clock   72.8Hz
  640x480 (0xac)   30.2MHz
        h: width   640 start  704 end  768 total  864 skew    0 clock   35.0KHz
        v: height  480 start  483 end  486 total  525           clock   66.7Hz
  640x480 (0xad)   25.2MHz
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
  720x400 (0xae)   28.3MHz
        h: width   720 start  738 end  846 total  900 skew    0 clock   31.5KHz
        v: height  400 start  412 end  414 total  449           clock   70.1Hz
    
posta Timothée Jeannin 19.04.2014 - 16:04

9 risposte

2

Ho avuto lo stesso problema quando ho collegato il mio secondo display alla porta VGA. Problema risolto quando sono passato a DVI. Ho trovato altri problemi usando Display Port con un adattatore VGA. Il sistema diventa pazzo e diventa incapace di rilevare correttamente la risoluzione. Un bel casino.

    
risposta data Thiago Zanetti 09.04.2015 - 20:07
1

Se possibile, collega il monitor alla porta VGA. Ho un portatile con 2 monitor esterni collegati: uno sulla porta VGA e uno sulla porta HDMI. L'hardware è NVidia Optimus. Con i 2 monitor collegati, il cursore del mouse sfarfalla sul display integrato (il display HDMI funziona correttamente). Se scollego il monitor HDMI, lo sfarfallio del display integrato si interrompe. Questo è probabilmente un bug con i driver nvidia open source. Per favore dicci di più sul tuo hardware.

    
risposta data sмurf 29.04.2014 - 05:17
1

Vai a un terminale e digita o copia & amp; incolla [ sudo apt-get install linux-source ] - premi invio, ti verrà chiesto se vuoi davvero installare, basta dire SÌ.

Poi nello stesso tipo di terminale - [ sudo apt-get remove --purge nvidia-* ] - OR - [ sudo apt-get remove nvidia-current ] - OR - [ sudo apt-get remove nvidia-current-updates ] - quindi spegni e riavvia.

Dopo il riavvio, il sistema utilizzerà un driver generico, vai a Software & amp; aggiornamenti (driver aggiuntivi) e fare clic su uno dei driver binari NVIDIA elencati, dovresti scegliere tra un paio (proprietario, testato) o (proprietario), non utilizzerei il driver di visualizzazione Nouveau, è un driver generico e non dà piena funzionalità.

Fare clic su uno dei driver elencati e fare clic su Applica modifiche nell'angolo in basso a destra e consentire a tale driver di installare, dopo aver completato l'installazione, riavviare il sistema. Se il driver su cui hai fatto clic funziona perfettamente come vuoi, se hai ancora problemi devi rimuovere il driver in modo completo usando il comando remove come sopra e prova l'altro driver elencato nella tua casella (driver aggiuntivi). Il KEY è di rimuovere completamente qualsiasi altro driver che è nel tuo sistema o avrai sicuramente dei problemi!

Solo per quello che sai, puoi copiare e incollare tutti i miei comandi sudo , sono corretti :-) Non usare [o] quando si copia o si digita che sono solo per la separazione. Spero che questo ti sia stato d'aiuto, quindi puoi GODERE di usare LINUX tanto quanto me.

    
risposta data jim frederick 31.10.2014 - 17:34
1

Ho avuto questo problema in 14.04 con una configurazione simile. Inoltre, a un certo punto, ho avuto un problema di ritocco del testo da uno dei miei monitor.

Ho avuto due schede video: una con 1 porta DVI e l'altra con entrambe le porte VGA e DVI.

Alla fine, ho stabilito che il mio problema era che stavo mescolando le schede video: stavo usando due porte DVI da due schede diverse. Utilizzando invece una sola scheda video, utilizzando le porte VGA e DVI di quella scheda, tutti i miei problemi sono andati via.

    
risposta data graham 07.05.2016 - 01:52
0

Sotto il tuo monitor verde c'è un monitor sconosciuto. Sposta il monitor verde, seleziona il monitor sconosciuto e disattivalo.

    
risposta data 1 Ariel 1 27.04.2014 - 03:52
0

Non ho lo stesso problema ma uno simile.
Nel mio caso il display è touchscreen, ho risolto disabilitando il touchscreen come input:

  1. sudo gedit /usr/share/X11/xorg.conf.d/10-evdev.conf dal terminale
  2. Aggiungi Option "Ignore" "on" alla fine della sezione touchscreen (al suo interno)
  3. Reboot
risposta data cloutz 01.01.2015 - 21:46
0

Hai lo stesso identico problema. Risolto parzialmente utilizzando la soluzione in questo rapporto bug: Parti dell'interfaccia utente sfarfallano casualmente quando si sposta il mouse

sudo add-apt-repository ppa:townsend/compiz-nvidia-refresh-test
sudo apt-get update
sudo apt-get dist-upgrade

Almeno ora non sfarfalla quando sposto il mouse.

    
risposta data Karolis Šarapnickis 09.03.2015 - 16:27
0

Ho avuto questo problema da Ubuntu 14.10, con impostazioni simili. Ho appena rinunciato a Unity ed eseguo invece la sessione di flashback di Metacity.

Mi piace Unity, ma non sopporto il cursore che gioca a nascondino.

    
risposta data ASalazar 05.04.2015 - 02:59
0

Ho riscontrato lo stesso problema con Lenovo P50 con la scheda grafica NVIDIA. Ho risolto cambiando la configurazione del display in modo discreto dall'ibrido. Ora niente sfarfallio.

    
risposta data TonyParker 14.05.2017 - 17:09

Leggi altre domande sui tag