Dopo l'aggiornamento dal 14.04 al 16.04.1 il server Postgresql non si avvia

21

Ho appena aggiornato il mio sistema dalla 14.04. Da LTS a 16.04.1 LTS, postgresql non viene avviato su systemd:

/etc/init.d/postgresql start                                                                                                                                                                              
[ ok ] Starting postgresql (via systemctl): postgresql.service

# /etc/init.d/postgresql status                                                                                                                                                                             
● postgresql.service - PostgreSQL RDBMS
  Loaded: loaded (/lib/systemd/system/postgresql.service; enabled; vendor     preset: enabled)
  Active: active (exited) since Вт 2016-08-09 13:40:51 MSK; 3min 23s ago
  Process: 23142 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
  Main PID: 23142 (code=exited, status=0/SUCCESS)Seems that 

Sembra che lo script systemd contenga dati errati:

# cat /lib/systemd/system/postgresql.service                                                                                                                                                                
# systemd service for managing all PostgreSQL clusters on the system. This
# service is actually a systemd target, but we are using a service since
# targets cannot be reloaded.

[Unit]
Description=PostgreSQL RDBMS

[Service]
Type=oneshot
ExecStart=/bin/true
ExecReload=/bin/true
RemainAfterExit=on

[Install]
WantedBy=multi-user.target

Quale dovrebbe essere lo script corretto per postgresql?

    
posta Artur Eshenbrener 09.08.2016 - 13:13

4 risposte

7

Questo dovrebbe funzionare immediatamente se fornisci la versione e il nome del cluster corretti.

Diciamo che stai eseguendo la versione 9.5 e il cluster è chiamato main :

Inizio: systemctl start [email protected]

Stop: systemctl stop [email protected]

Stato: systemctl status [email protected]

Abilita avvio automatico all'avvio: systemctl enable [email protected]

Disattiva avvio automatico all'avvio: systemctl disable [email protected]

[email protected]:~$ systemctl status [email protected][email protected] - PostgreSQL Cluster 9.5-main
   Loaded: loaded (/lib/systemd/system/[email protected]; disabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-03-31 17:44:46 CEST; 59s ago
   Main PID: 4546 (postgres)
   CGroup: /system.slice/system-postgresql.slice/[email protected]
           ├ ─ 4546 /usr/lib/postgresql/9.5/bin/postgres -D /var/lib/postgresql/9.5/main -c config_file=/etc/postgresql/9.5/main/postgresql.conf
           ├ ─ 4548 postgres: checkpointer process
           ├ ─ 4549 postgres: writer process
           ├ ─ 4550 postgres: wal writer process
           ├ ─ 4551 postgres: autovacuum launcher process
           └ ─ 4552 postgres: stats collector process

Mar 31 17:44:44 postgres postgres[4546]: [1-2] 2017-03-31 17:44:44 CEST [4546] @ HINT:  Future log output will go to log destination "syslog".
Mar 31 17:44:44 postgres postgres[4547]: [2-1] 2017-03-31 17:44:44 CEST [4547] @ LOG:  database system was shut down at 2017-03-31 17:44:43 CEST
Mar 31 17:44:44 postgres postgres[4547]: [3-1] 2017-03-31 17:44:44 CEST [4547] @ LOG:  MultiXact member wraparound protections are now enabled
Mar 31 17:44:44 postgres postgres[4546]: [2-1] 2017-03-31 17:44:44 CEST [4546] @ LOG:  database system is ready to accept connections
Mar 31 17:44:44 postgres postgres[4551]: [2-1] 2017-03-31 17:44:44 CEST [4551] @ LOG:  autovacuum launcher started
Mar 31 17:44:45 postgres postgres[4553]: [3-1] 2017-03-31 17:44:45 CEST [4553] [unknown]@[unknown] LOG:  incomplete startup packet
Mar 31 17:44:46 postgres systemd[1]: Started PostgreSQL Cluster 9.5-main.
Mar 31 17:44:47 postgres systemd[1]: Reloading PostgreSQL Cluster 9.5-main.
Mar 31 17:44:47 postgres postgres[4546]: [3-1] 2017-03-31 17:44:47 CEST [4546] @ LOG:  received SIGHUP, reloading configuration files
Mar 31 17:44:47 systemd[1]: Reloaded PostgreSQL Cluster 9.5-main.
    
risposta data malte 31.03.2017 - 17:56
15

Systemd dovrebbe usare lo script da /etc/init.d . Invece, systemd usa un qualche tipo di file modello. Per risolvere il problema, segui questi passaggi:

  1. Rimuovi script di servizio non valido:

    # rm /lib/systemd/system/postgresql.service

  2. Ricarica gli script daemon:

    # systemctl daemon-reload

  3. Abilita il servizio postgresql:

    # systemctl enable postgresql

Dopodiché, potresti iniziare postgres con qualsiasi variante preferita: sudo systemctl start postgresql , sudo service postgresql start o sudo /etc/init.d/postgresql start . Per verificare l'effettiva esecuzione di postgresql, controlla lo stato del servizio: sudo systemctl status postgresql . Dovrebbe assomigliare a:

% sudo systemctl status postgresql                                                                                                                                                                          
● postgresql.service - LSB: PostgreSQL RDBMS server
   Loaded: loaded (/etc/init.d/postgresql; bad; vendor preset: enabled)
   Active: active (running) since Пт 2016-08-12 10:13:43 MSK; 1h 37min ago
     Docs: man:systemd-sysv-generator(8)
   CGroup: /system.slice/postgresql.service
           ├─4086 /usr/lib/postgresql/9.5/bin/postgres -D     /var/lib/postgresql/9.5/main -c  config_file=/etc/postgresql/9.5/main/postgresql.conf
           ├─4099 postgres: checkpointer process                                                                                              
           ├─4100 postgres: writer process                                                                                                    
           ├─4101 postgres: wal writer process                                                                                                
           ├─4102 postgres: autovacuum launcher process                                                                                       
           └─4103 postgres: stats collector process                                                                                           

авг 12 10:13:40 ubuntu-precise systemd[1]: Starting LSB: PostgreSQL RDBMS server...
авг 12 10:13:40 ubuntu-precise postgresql[4009]:  * Starting PostgreSQL 9.5 database server
авг 12 10:13:43 ubuntu-precise postgresql[4009]:    ...done.
авг 12 10:13:43 ubuntu-precise systemd[1]: Started LSB: PostgreSQL RDBMS server.
    
risposta data Artur Eshenbrener 09.08.2016 - 13:13
0

Ho avuto lo stesso problema dopo aver eliminato i postge9 e installato 10 sul mio ubuntu16. Inizialmente ho modificato il file /lib/systemd/system/postgresql.service con il seguente contenuto:

[Unit]
Description=PostgreSQL RDBMS

[Service]
Type=notify
User=postgres
ExecStart=/usr/lib/postgresql/10/bin/postgres -D /analysis2/postgresql/data
ExecReload=/bin/kill -HUP $MAINPID
KillMode=mixed
KillSignal=SIGINT
TimeoutSec=0

[Install]
WantedBy=multi-user.target

E posso usare systemctl restart / stop / start per controllare il servizio postgresql. Tuttavia, per qualche motivo, il suddetto file è stato sovrascritto (magari dopo l'aggiornamento del sistema) e non è stato possibile eseguire il comando systemctl per avviare e arrestare il server postgresql. Dopo alcune letture, mi sono reso conto che non dovresti editare il file sopra. Invece dovresti usare systemctl edit foo per sovrascrivere i valori di default. Dopo aver seguito la soluzione suggerita dal seguente link, il mio sistema sembra funzionare correttamente con postgresql.

Come faccio a sovrascrivere o configurare i servizi di sistema?

    
risposta data Kemin Zhou 04.01.2018 - 23:36
-1

Non è la soluzione più bella, ma questo risolve il problema senza dover immergersi in nulla. Aggiungi questo a cron:

@reboot sleep 5; systemctl start postgresql
    
risposta data user3136936 24.08.2017 - 09:44

Leggi altre domande sui tag