aggiornamento da 15.10 a 16.04 apt non installato

18

Quando si prova ad aggiornare usando il terminale, il mio aggiornamento si interrompe. Questa è la linea che mostra nel terminale:

The required dependency 'apt(>=1.0.10.2 ubuntu2)' is not installed.

il mio problema è che non conosco il comando per installare questa dipendenza. Usando altri comandi, dice che apt è aggiornato. Soluzioni?

    
posta paul 01.05.2016 - 00:57

5 risposte

19

Avuto lo stesso problema, risolto forzando l'aggiornamento di apt e ripulendo l'installazione corrente come suggeriva Andrew:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install   # (not "install -f"!)
sudo apt-get -y install apt
sudo do-release-upgrade
    
risposta data badger 02.05.2016 - 12:50
12

Ho avuto questo errore, per me mi mancava la linea wily-updates dal mio /etc/apt/sources.list:

deb http://archive.ubuntu.com/ubuntu/ wily-updates main restricted universe multiverse
    
risposta data Neil 14.05.2016 - 08:47
4

Ho avuto anche questo problema, questo aggiornerà tutti i tuoi gadget e aggiornerà da 15 a 16.

Vai a Software and Updates & gt; % Co_de%

Spunta nel seguito

  • Wily Security
  • Wily Updates
  • Proposta ottimamente

Aggiorna e aggiorna il sistema corrente

sudo apt-get update && sudo apt-get upgrade

Ottieni l'aggiornamento

sudo apt-get dist-upgrade

Aggiornamento in CLI

sudo do-release-upgrade
    
risposta data JREAM 04.08.2016 - 19:01
1

Ho avuto lo stesso identico problema con 'apt'. Ho ottenuto la soluzione da questo link . Esegui sudo dpkg -l | grep apt . È possibile visualizzare questa voce nell'output del comando:

ii  apt 1.0.10.2ubuntu1      amd64         commandline package manager

Se lo fai, avrai bisogno del apt (& gt; = 1.0.10.2 ubuntu2) richiesto. Ecco i passi che ho seguito:

  1. Vai a Software & amp; Aggiorna - & gt; Software Ubuntu. Cambiare il server sul server principale (nel mio caso, sono passato a Server for India). Stavo usando un mirror diverso in precedenza e quindi avevo una versione "apt" più vecchia.

  2. Esegui

        sudo apt-get update
        sudo apt-get install --reinstall apt 
    
  3. Esegui sudo dpkg -l | grep apt di nuovo per verificare che la versione sia cambiata. Speriamo che la voce nell'output debba essere cambiata in: apt 1.0.10.2ubuntu2 .

  4. Esegui un sudo apt-get update && sudo apt-get upgrade dopo il quale puoi procedere all'aggiornamento a ubuntu 16.04.

risposta data Rahul 07.05.2016 - 13:06
0

Le precedenti soluzioni pubblicate non funzionavano per me.

Ciò che ha funzionato è stato trovato nei commenti su launchpad :

wget http://launchpadlibrarian.net/254524267/apt_1.0.10.2ubuntu2_amd64.deb   
wget http://launchpadlibrarian.net/254524264/apt-transport-https_1.0.10.2ubuntu2_amd64.deb
wget http://launchpadlibrarian.net/254524266/apt-utils_1.0.10.2ubuntu2_amd64.deb    
wget http://launchpadlibrarian.net/254524269/libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb    
wget http://launchpadlibrarian.net/254524270/libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb

sudo dpkg --install apt_1.0.10.2ubuntu2_amd64.deb apt-transport-https_1.0.10.2ubuntu2_amd64.deb apt-utils_1.0.10.2ubuntu2_amd64.deb libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb

sudo do-release-upgrade
    
risposta data 07.11.2018 - 12:06

Leggi altre domande sui tag