Quando lancio un'applicazione, lo stato attivo non si sposta nell'app aperta

17

Supponiamo di avere Gthumb aperto, quindi di avviare Nautilus dal launcher di Unity (in 12.04). Perché a volte non mette a fuoco il mouse su Nautilus, che ho appena lanciato? Invece, l'attenzione rimane su Gthumb mentre Nautilus si apre di fronte a Gthumb (e non è focalizzato su).

Questo comportamento è corretto?

    
posta Gonzoza 30.04.2012 - 19:57

3 risposte

26

Puoi configurarlo con CompizConfig-Settings-Manager.

1) Installa it: sudo apt-get install compizconfig-settings-manager ,

2) Apri ccsm ( Alt + F2 e digita ccsm e premi Invio )

3) Vai a "Opzioni generali" & gt; "Focus & amp; Raise Behaviour" e impostare "Focus Prevention Level" su "Off".

4) Divertiti ;-)

Se ti senti pigro, basta incollarlo al terminale e il gioco è fatto:

gconftool-2  --type=Integer --set /apps/compiz-1/general/screen0/options/focus_prevention_level 0  
    
risposta data desgua 02.05.2012 - 22:44
9

No, non è un comportamento corretto. La risposta alla domanda "perché sta accadendo" è perché c'è un bug. Suggerisco di inviare una segnalazione di bug. Sorprendentemente non riesco a trovare una segnalazione di bug esistente per questo, anche se posso confermare che succede. Pubblica un link al bug quando lo hai fatto in modo da potermi legare a esso.

Modifica : trovato. Bug # 781931 Non sono sicuro del motivo per cui questa risposta è stata votata in quanto è certamente la risposta alla domanda sul perché questo accade. Il lavoro con ccsm non è una risposta alla domanda, è una soluzione per il bug. Questo di per sé è molto utile e vale la pena postare, ma non risponde alla domanda che è stata posta.

    
risposta data clanlaw 02.05.2012 - 23:00
7

Il comando sopra non funzionava per me e non volevo installare CCSM, quindi ho fatto qualche ricerca e ho scoperto che il seguente comando ha fatto il trucco (sto usando Ubuntu 15.04):

dconf write /org/compiz/profiles/unity/plugins/core/focus-prevention-level 0

Modifica: questa soluzione funziona ancora per 16.04

    
risposta data Tony 08.09.2015 - 14:03

Leggi altre domande sui tag