Ubuntu 15.04 lampeggia lo schermo di accesso quindi nero

18

Alcune settimane fa, ho costruito un desktop e ho installato Ubuntu 15.04 e da allora ho sempre combattuto. Sembra esserci un problema con la compatibilità dei driver NVIDIA e Ubuntu.

(Dopo settimane di difficoltà con vari schermi nero / viola, alternando nomodeset, blacklisting e riavvio di lightdm / try gdm, restituendo la mia GTX960 per una GTX750TI, installando Ubuntu 14.04 e 14.10, loop di login e alcune altre cose Sono sicuro che ho dimenticato, ho il seguente esempio minimo.)

  1. Creo un avvio USB con Ubuntu 15.04.
  2. Seleziono "Installa Ubuntu" (nota che devo modificare le opzioni per questo, cambiando "quiet splash" in "quiet splash nomodeset" altrimenti non funziona).
  3. Dopo aver installato Ubuntu, mi viene chiesto di riavviare. Posso avviare in modalità di ripristino (anche se la risoluzione è strana), ma non normalmente.
  4. A questo punto, ho provato varie cose (reinstallare i driver nvidia, aggiungere in modo permanente nomodeset alle opzioni di avvio, ecc.), la maggior parte delle quali finiscono con la necessità di reinstallare Ubuntu da zero a causa dell'impossibilità di vedere qualsiasi cosa senza rimuovere la scheda grafica e collegare il monitor alla scheda madre.

Ho appena completato i primi 3 passaggi, che sono ormai memoria muscolare, e sto chiedendo suggerimenti per un nuovo passaggio 4.

EDIT : ho provato i passaggi qui (che mi ha portato all'opzione nomodeset che mi permette di vedere lo schermo mentre installo Ubuntu ) ma quando aggiorno i driver NVIDIA (ho provato sia le versioni proprietarie che quelle non proprietarie, molti numeri di versione differenti), questo mi porta ad altri problemi. Molto spesso, è un loop di accesso , ma a volte è un nero / schermo viola. Quando seguo il suggerimento di indirizzare il ciclo di login, questo mi riporta invariabilmente a uno schermo vuoto e quindi reinstallare Ubuntu.

$ sudo lshw -C video
  *-display UNCLAIMED     
       description: VGA compatible controller
       product: GM107 [GeForce GTX 750 Ti]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: [email protected]:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff

Aggiornamento: l'installazione di bumblebee mi consente di evitare il loop di accesso. La risoluzione del mio monitor continua a non sembrare corretta e devo fare clic su una dozzina di caselle "Problema del sistema di segnalazione".

Modifica: Il mio xorg.log è qui.

    
posta Gschneider 13.05.2015 - 23:59

7 risposte

2

Anch'io ho costruito un desktop e ho usato 750Ti. Ho avuto il problema esatto che l'OP ha, e posso testimoniare personalmente che il sotto ha funzionato per me. Non ho un sacco di tempo, quindi dovrò riassumere. In caso di dubbi, Google è tuo amico.

  1. Vai al sito Web di NVIDIA da un altro PC e scarica il driver appropriato su un'unità USB.

  2. Collegare questa unità USB al desktop e avviare. Nella schermata di accesso, inserisci il runlevel 2 premendo CTRL + ALT + 2

  3. Ora sarai in un terminale (tempi divertenti!). Accedi utilizzando il tuo account.

  4. Elimina lightdm.

  5. Monta l'unità USB e deseleziona il driver.

  6. Avvia il programma di installazione del driver. Se non ci sono errori durante l'installazione, quindi riavviare. Il ciclo di accesso ora dovrebbe essere sparito.

Ciò lo rende semplice, ma sfortunatamente è in realtà piuttosto difficile. Mi ci sono voluti quattro tentativi per farlo bene.

Fammi sapere come funziona per te!

    
risposta data willem.hill 30.11.2015 - 05:00
0

OK, comprendiamo il punto numero 2 che hai menzionato, hai detto che dovevi passare il parametro del kernel nomodeset durante l'avvio via USB.

Questo indica che la scheda grafica ha GTX750TI, non vuole funzionare bene con il driver Open Source Nouveau. Quindi questo è il tuo primo problema. Non procederei con l'installazione se dovessi usare nomodeset solo per avviare il programma di installazione.

Non ho esperienza con questa scheda, ma la Maxwell Architecture su cui si basa ha un sacco di problemi con Nouveau Driver, che è Open Source.

Ubuntu Per impostazione predefinita viene fornito con i driver Open Source e se la tua scheda ha problemi di funzionamento, vedrai schermi neri ecc.

Qual è il modo migliore per confermare questo?

Scarica Manajaro Linux e, all'avvio, seleziona i driver non liberi e riceverai una conferma. Puoi anche provare Archlinux che ha il kernel 4.0 e molti problemi relativi alla grafica sono corretti in quella versione.

NON STO INCORAGGIANDO L'USO DI MANJARO O DELL'ARCO. SUGGERISCO DI PROVARLI UNA VOLTA UNA VOLTA PER CONFERMARE QUELLO CHE HO FATTO SOPRA.

CONTINUERAI VEDENDO SCHERMO NERO FINO A CHE INSTALLI IL DRIVER NVIDIA PROPRIETARIO. È NECESSARIO INSTALLARE LA VERSIONE CORRETTA DEL DRIVER PROPRIETARIO COMPATIBILE CON LA TUA SCHEDA !!

    
risposta data Rajat Pandita 18.05.2015 - 19:12
0

Penso che sia a causa della versione kernel . Come sapete, la versione del kernel di Ubuntu 15.04 è 3.16 . Prova ad usare un Linux live con la versione di aggiornamento. (ad esempio arch ).

Ho visto questo problema con Ubuntu 14.04 e lenovo flex II .

    
risposta data M.Fooladgar 05.06.2015 - 14:46
0

beh, in realtà ho avuto lo stesso problema provato così tante volte con così tanti modi ... non risultato ..

ma finalmente ho appena installato questa versione del driver direttamente

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get install ppa-purge
sudo apt-get update
sudo apt-get install nvidia-334
sudo apt-get install nvidia-334-uvm

questo è tutto

Non sono sicuro che questo funzioni per te non sono un professionista ma funziona per me e io dovrei comunque notarlo qui

ma sono sicuro che la versione del driver è la stessa che fa funzionare giochi di vapore e così via che funzionano molto bene e puoi trovare il pacchetto sorgente qui:

link

spero che funzioni

    
risposta data CatChMeIfUCan 28.08.2015 - 06:17
0

Ho avuto un problema come questo, quando ho aggiornato a 15.10. Si è scoperto che il problema era che la scheda NVIDIA si surriscaldava a circa il 30% in più rispetto alla temperatura suggerita. Ottieni un'installazione live del disco e installa psensor per controllare le temperature della scheda video.

    
risposta data Wolf Halton 02.12.2015 - 06:27
0

Ho avuto un problema simile dopo aver installato una scheda nvidia in una macchina 15.04 esistente. Dopo aver lottato per un po ', cercando risposte qui e non trovando nulla che mi aiutasse veramente, ho rinunciato e ho installato 14.04 (LTS). I driver nvidia sono stati installati automaticamente e tutto funziona come per magia. (Vedi Problemi nell'installazione dei driver Nvidia, Ubuntu 15.04 )

Dalla tua domanda sembra che tu abbia fatto esattamente quello che alla fine ha risolto il mio problema, tranne che hai installato una nuova 15.04 mentre ho installato una 14.04 fresca. Sospetto che la 15.04 abbia un problema specifico. Quindi installare 14.04 potrebbe essere una soluzione per te.

    
risposta data laugh 23.12.2015 - 20:18
-2

Ho avuto lo stesso problema, e hai bisogno di una nuova installazione, prima di entrare nel bios e di impostare il boot da uefi a legacy, e non un boot sicuro, e quindi installare di nuovo Ubuntu.

    
risposta data Michael 12.06.2015 - 21:17

Leggi altre domande sui tag