Nessun suono in Ubuntu 13.04, elencato solo dispositivo di output fittizio

18

I miei suoni improvvisamente hanno smesso di suonare su Ubuntu 13.04 a 64 bit. Posso solo vedere il dispositivo di output Dummy nelle Impostazioni audio e nessun suono viene riprodotto durante i test.

Posso far funzionare temporaneamente il suono uccidendo uno dei processi più strani, ma devo ripetere lo stesso dopo il riavvio

[email protected]:~$ ps -ef|grep pulseaudio
112       1405     1  0 09:38 ?        00:00:00 /usr/bin/pulseaudio --start --log-target=syslog
112       2132  1405  0 09:38 ?        00:00:00 /usr/lib/pulseaudio/pulse/gconf-helper
jan       2575     1  0 09:39 ?        00:00:00 /usr/bin/pulseaudio --start --log-target=syslog
jan       2597  2575  0 09:39 ?        00:00:00 /usr/lib/pulseaudio/pulse/gconf-helper
jan       3160  2975  0 09:40 pts/2    00:00:00 grep --color=auto pulseaudio

[email protected]:~$ sudo kill 1405

C'è una soluzione permanente per questo problema?

    
posta theczechsensation 11.05.2013 - 18:50

7 risposte

8

Seguendo le istruzioni al link , ho disabilitato il dispatcher vocale come segue:

sudo vi /etc/default/speech-dispatcher

E ho cambiato RUN=yes in RUN=no , quindi riavviato.

Il mio sistema ora si avvia con audio e molto più velocemente.

    
risposta data Geoff 25.05.2013 - 17:06
9

Ho avuto questo problema dopo aver avuto un problema con Xorg, disinstallando l'unità e reinstallando xfce. Probabilmente il mio probblem ruotava attorno non aggiungendo gconf e gli script di re-installazione che non aggiungevano il mio utente ai vari gruppi audio. Ho ottenuto il suono lavorando dopo:

sudo apt-get install pulseaudio-module-x11 \
    pulseaudio-module-zeroconf \
    pulseaudio-module-gconf

E aggiungendo anche il mio nome utente ai gruppi correlati all'audio in /etc/groups :

audio:x:29:pulse,jreynolds
pulse:x:123:jreynolds
pulse-access:x:124:jreynolds

Ovviamente, sto scaricando le mie varie impostazioni relative agli impulsi:

pulseaudio -k
sudo alsa force-reload
rm ~/.pulse-cookie
rm -rf ~/.config/pulse
sudo shutdown -r now

Quando il mio sistema si è riavviato (e non so se fosse necessario) ho eseguito un controllo:

pacmd list-sinks

E questo ha mostrato le mie schede audio e non il dispositivo fittizio!

    
risposta data memnoch_proxy 15.10.2013 - 15:44
7

Ecco cosa ho fatto, ha funzionato per me. Assicurarsi che l'utilità di controllo pulseaudio sia installata:

sudo apt-get install pavucontrol

esegui l'utility

pavucontrol

Spostati nella scheda più a sinistra (configurazione), c'è una lista di profili adrop. Lavora attraverso questo fino a qualcosa di forchette (per me era "Uscita stereo analogica", mentre il valore predefinito era "Uscita stereo digitale (IEC958)")

HTH

Rob

    
risposta data rtmie 13.05.2013 - 16:25
1

Ce l'avevo anche - funziona il suono prima di riavviarsi dopo un aggiornamento? Se sì, probabilmente è lo stesso.
È bug relativo al kernel 3.8.0-18.

  1. Esegui uname -r per verificare la versione del kernel. Se è 3.8.0-18-generic , prova i passaggi successivi
  2. Riavvia e in GRUB seleziona Advanced options
  3. Ho scelto Ubuntu with Kernel ... (Qualsiasi prima di -18 )

Inoltre puoi sottoscrivere questo bug su Launchpad, spero che lo risolvano presto

    
risposta data kubahaha 13.05.2013 - 18:12
1

Ho usato Ubuntu 13.04 a 64 bit con Kernel versione 3.8.0-19-generica. Ho avuto lo stesso problema con il dispositivo di output fittizio, ma l'ho risolto seguendo la prima soluzione fornita nel seguente sito Web:

link

Spero che questo aiuti!

    
risposta data user139352 21.05.2013 - 12:06
1

Ho avuto lo stesso problema con il kernel 3.8.0-19-generic installato. E il kernel aggiornato era disponibile, ma era trattenuto da apt-get . Quindi ho usato Synaptic per installare l'aggiornamento del kernel (3.8.0-25-generic), ho riavviato il sistema e il suono funzionava di nuovo.

Quindi la soluzione potrebbe essere semplice come aggiornare il kernel.

    
risposta data Serrano 18.06.2013 - 01:25
0

Per me, ciò che ha funzionato è stato un

sudo apt-get install linux-image-3.8.0-25-generic

riavvio, notando, con mio grande orrore, che non funzionavano la scheda video né la scheda wlan, emettendo panico

sudo apt-get remove linux-image-3.8.0-25-generic

riavvio e, con mio grande sollievo, trovare sia nuovi (video, wlan) che vecchi problemi (audio) da sparire in una sola volta.

    
risposta data user170824 28.06.2013 - 00:42

Leggi altre domande sui tag