Ubuntu 16.04 avvio lento (apt-daily.service)

29

Il mio avvio è orribilmente lento e non so perché.

$ systemd-analyze 
Startup finished in 10.975s (kernel) + 49.732s (userspace) = 1min 708ms
$ systemd-analyze blame 
         34.971s apt-daily.service
         20.590s snapd.refresh.service
         17.113s grub-common.service
         16.033s apport.service
         16.027s networking.service
         15.894s ondemand.service
         15.860s irqbalance.service
         15.655s speech-dispatcher.service
         11.695s ModemManager.service
          9.772s accounts-daemon.service
          8.626s NetworkManager-wait-online.service
          8.058s systemd-logind.service
          8.053s bluetooth.service
          7.944s gpu-manager.service
          7.896s alsa-restore.service
          7.892s pppd-dns.service
          7.882s rsyslog.service
          7.860s avahi-daemon.service
          7.844s dev-sda1.device
          7.842s systemd-user-sessions.service
          7.648s lightdm.service
          7.610s teamviewerd.service
          6.445s apparmor.service

Inoltre, durante l'avvio, vedo un messaggio che dice qualcosa del tipo:

device descriptor read/all, error -62
ata1 softreset failed (device not ready) #most of the times
error loading journal #(sometimes)
Test WP failed, assume Write Enabled
Asking for cache data failed     #most of the times
Assuming drive cache: write through

apt-daily.service rallenta maggiormente l'avvio. Qualche idea su come affrontarlo?

Ho Ubuntu MATE 16.04.

    
posta Ashwin Kumar k 19.07.2016 - 15:38

3 risposte

26

Questo è bug Debian # 844453 . apt-daily.service non dovrebbe essere eseguito durante l'avvio, ma solo dopo un po 'di tempo.

Per ovviare al problema, fai sudo systemctl edit apt-daily.timer e incolla il seguente testo nella finestra dell'editor:

# apt-daily timer configuration override
[Timer]
OnBootSec=15min
OnUnitActiveSec=1d
AccuracySec=1h
RandomizedDelaySec=30min

Cambia il "timer" che attiva apt-daily.service per essere eseguito in un momento casuale tra 15 minuti e 45 minuti dopo l'avvio e una volta al giorno successivamente. Vedi la manpage systemd.timer per ulteriori (non molto ben scritto, ahimè) spiegazione di cosa significa.

    
risposta data zwol 27.03.2017 - 16:22
3

Se si tratta di un desktop, aprilo e disconnetti, quindi ricollega tutti i cavi HDD compreso MB.

In caso contrario, sembra che il tuo HDD stia scadendo. BACKUP tutti i dati ora.

Masterizza l'installazione di rete Live di Ubuntu per suite del tuo sistema, avvia per provare Ubuntu. Quindi esegui Gparted: per impostazione predefinita controlla gli errori di lettura dell'HDD. Se hai un backup di tutti i tuoi dati forse qualcun altro potrebbe consigliarti.

    
risposta data smokingwheels 20.10.2016 - 00:51
1

L'altra risposta riguarda il secondo blocco di testo nella domanda.

Per me, per risolvere apt-daily.service prendendo per sempre, questo post sui forum di Ubuntu sembra aver funzionato.

% Bl0ck_qu0te%

Rimuovi il% co_de iniziale che disabilita la riga e modifica il valore.

    
risposta data cat 28.02.2017 - 16:12

Leggi altre domande sui tag