Come posso fare in modo che NetworkManager ignori la mia scheda wireless?

19

Non voglio che NetworkManager elenchi o manipoli la mia scheda wireless. Posso nascondere la sua interfaccia da NetworkManager in qualche modo?

Ho provato ad aggiungerlo in /etc/network/interfaces ,

iface wlan0 inet static
    address 192.168.1.101
    netmask 255.255.255.0
    gateway 192.168.1.1
    wireless-essid Synaptotagmin
    pre-up wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
    post-down killall -q wpa_supplicant

e questo in /etc/NetworkManager/nm-system-settings.conf ,

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[keyfile]
unmanaged-devices=/org/freedesktop/Hal/devices/net_00_19_e0_57_86_af

ma l'applet di NetworkManager continua a elencare e mi consente di connettermi alle reti wireless.

    
posta ændrük 17.01.2011 - 04:37

7 risposte

23

Secondo Wiki di Gnome , la sintassi in /etc/NetworkManager/NetworkManager.conf (nelle versioni precedenti era /etc/NetworkManager/nm-system-settings.conf ) è diverso da quello che ho letto Arch Linux Wiki . Dovrebbe essere:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[keyfile]
unmanaged-devices=mac:00:19:e0:57:86:af

Questa configurazione rende il NetworkManager ignaro dell'esistenza della mia scheda wireless, ma mi consente comunque di controllarlo usando altri metodi.

    
risposta data ændrük 18.01.2011 - 20:45
7

Penso che la linea sbagliata potrebbe essere:

unmanaged-devices=/org/freedesktop/Hal/devices/net_00_19_e0_57_86_af

perché non ho trovato il formato specificato nella documentazione ufficiale.

I formati validi sono unmanaged-devices=mac:<hwaddr> o, nelle versioni recenti di Network Manager, unmanaged-devices=interface-name:<ifname> . Entrambi sono accettati insieme separati da punto e virgola, ad esempio:

unmanaged-devices=mac:00:22:68:1c:59:b1;mac:00:1E:65:30:D1:C4;interface-name:eth2

Questo è un estratto dal manuale di NetworkManager.conf:

  

unmanaged-dispositivi

     

Imposta i dispositivi che devono essere ignorati da NetworkManager quando si utilizza il plugin keyfile. I dispositivi sono specificati nel seguente formato:

     

mac: o interface-name :. Qui hwaddr è l'indirizzo MAC del dispositivo da ignorare, in notazione esadecimale-e-colon. ifname è il nome dell'interfaccia del dispositivo ignorato.

     

Più voci sono separate da punti e virgola. Non sono consentiti spazi nel valore.

     

Esempio:

     

unmanaged-devices = interface-name: EM4

     

gestite-devices = mac: 00: 22: 68: 1c: 59: b1; mac: 00: 1E: 65: 30: D1: C4; nome-interfaccia: eth2

    
risposta data Diego 27.05.2014 - 11:23
5

Utilizza il seguente /etc/NetworkManager/nm-system-settings.conf :

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

In questo modo le tue interfacce da /etc/network/interfaces non saranno gestite da Network Manager, cioè non tenterà di fare nulla con loro.

    
risposta data ulidtko 17.01.2011 - 12:26
0

In Ubuntu 14.04, è in /etc/NetworkManager/NetworkManager.conf . Ma potresti aver bisogno di gestire le autorizzazioni.

    
risposta data user306519 17.07.2014 - 17:57
0

Metodo KEYFILE alternativo

Indipendentemente da quale distribuzione di Linux è in esecuzione, è possibile utilizzare un metodo alternativo per dire a Network Manager di interrompere il controllo di un'interfaccia. Questo viene fatto aggiungendo le seguenti righe al file di configurazione di Network Manager /etc/NetworkManager/NetworkManager.conf :

[main]
plugins=keyfile

[keyfile]
unmanaged-devices=mac:00:11:22:33:44:55;mac:66:77:88:99:00:aa

Elenca l'indirizzo MAC di ciascuna interfaccia che vuoi ignorare dal gestore di rete, separato da un punto e virgola. Assicurati che gli indirizzi MAC elencati qui siano LOWER CASE (se c'è già una sezione [main] con plugins=... , aggiungi il plugin keyfile a quella lista lì)

Per ottenere l'indirizzo mac del tuo dispositivo wlan0 usa

LANG=c ifconfig wlan0|grep HWaddr

Questo mostrerà il Mac del dispositivo, qualcosa di simile a

wlan0     Link encap:Ethernet  HWaddr ac:51:4f:70:13:72

Riavvia NetworkManager con

sudo /etc/init.d/network-manager restart
    
risposta data rubo77 13.01.2015 - 19:45
-1

Suppongo che tu sia su Ubuntu Desktop; In questo caso, fai clic con il pulsante destro del mouse su nm-applet (credo su Natty fai clic) e deseleziona "Abilita wireless". L'unica avvertenza è che dovrai farlo ogni volta che accedi.

    
risposta data zpletan 17.01.2011 - 13:59
-6

Crea semplicemente un file .sh contenente killall -q wpa_supplicant ed eseguilo usando cron quando esegui l'accesso.

    
risposta data Luciano Facchinelli 17.01.2011 - 04:43

Leggi altre domande sui tag