vboxdrv.sh: non riuscito: modprobe vboxdrv non riuscito. Si prega di utilizzare 'dmesg' per scoprire perché

31

Ho problemi con l'esecuzione di VirtualBox sul mio portatile Ubuntu. Il mio laptop è dual boot e funziona (Windows 10 - credo, non l'ho usato da anni), così come Ubuntu 16.0.4 LTS.

Ho attivato l'avvio sicuro nelle impostazioni del BIOS del mio laptop.

Sono consapevole che ci sono domande simili pubblicate qui, in particolare queste due:

Ho seguito tutte le istruzioni fornite nelle sezioni delle risposte per queste due domande, tuttavia il problema rimane irrisolto.

Ecco l'output della console, quando tento di eseguire virtualbox:

[email protected]:~$ virtualbox
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (4.4.0-47-generic) or it failed to
         load. Please recompile the kernel module and install it by

           sudo /sbin/vboxconfig

         You will not be able to start VMs until this problem is fixed.

ecco l'output della console quando eseguo /sbin/vboxconfig come suggerito:

[email protected]:~$ sudo /sbin/vboxconfig  
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.

Ecco la fine della coda dell'output di dmesg :

[   44.319682] audit: type=1400 audit(1491313982.374:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/evince-previewer" pid=705 comm="apparmor_parser"
[   45.041433] cgroup: new mount options do not match the existing superblock, will be ignored
[   59.682936] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   59.697820] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   59.702008] IPv6: ADDRCONF(NETDEV_UP): enp2s0f0: link is not ready
[   60.267000] IPv6: ADDRCONF(NETDEV_UP): enp2s0f0: link is not ready
[   62.473044] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   70.681706] audit_printk_skb: 60 callbacks suppressed
[   70.681709] audit: type=1400 audit(1491314008.734:32): apparmor="STATUS" operation="profile_load" profile="unconfined" name="docker-default" pid=2009 comm="apparmor_parser"
[   70.850936] aufs 4.x-rcN-20160111
[   75.407218] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[   75.408555] Bridge firewalling registered
[   75.427172] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[   75.848416] ip_tables: (C) 2000-2006 Netfilter Core Team
[   76.703232] Initializing XFRM netlink socket
[   77.060003] IPv6: ADDRCONF(NETDEV_UP): docker0: link is not ready
[   80.101042] aufs au_opts_verify:1597:dockerd[1402]: dirperm1 breaks the protection by the permission bits on the lower branch
[  113.895236] wlp3s0: authenticate with 84:16:f9:77:e1:54
[  113.910483] wlp3s0: send auth to 84:16:f9:77:e1:54 (try 1/3)
[  113.912712] wlp3s0: authenticated
[  113.915101] wlp3s0: associate with 84:16:f9:77:e1:54 (try 1/3)
[  113.919397] wlp3s0: RX AssocResp from 84:16:f9:77:e1:54 (capab=0x1411 status=0 aid=1)
[  113.919516] wlp3s0: associated
[  113.919559] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready

Ora, non ho intenzione di mentire - non ho assolutamente idea di ciò che dmesg ha appena svelato - e per quanto posso dire, non ci sono messaggi di errore nell'output del log - che rende la situazione ancora più esasperante.

Qualcuno ha mai installato VirtualBox 5.x su un laptop con Ubuntu 16.0.4 LTS - ma con avvio sicuro abilitato su BIOS ? - se sì, qual è la soluzione. ???!

Un sacco di persone hanno questo problema - anche andando alcuni anni fa. è molto strano che nessuno sembra avere una soluzione per questo - ???

    
posta Homunculus Reticulli 04.04.2017 - 16:14

2 risposte

37
% Bl0ck_qu0te%

Nota: la risposta di cui sopra è stata interamente ricavata dal post del blog di Øyvind Stegard, VirtualBox + Secure Boot + Ubuntu = fail .

    
risposta data Android Dev 04.04.2017 - 16:24
7

La risposta sopra probabilmente funziona bene, ma se vuoi un momento più semplice per questo:

Sono riuscito a risolverlo

fare il boot nel BIOS e andare & gt; avanzato (f7) & gt; boot & gt; scorri verso il basso fino a "avvio sicuro" & gt; cambia "Modalità EUFI di Windows" in "altro sistema operativo"

La mia virtualbox funziona perfettamente ora.

    
risposta data Lee Gildemeester 19.04.2018 - 03:27

Leggi altre domande sui tag