Adobe Flash Player non funziona con Amazon Prime

17

Ho Ubuntu 12.04 64 bit usando Google Chrome. Ho avuto il cromo dal centro app poi oggi il primo video di Amazon ha smesso di funzionare. Mi ha detto di aggiornare Flash. Così ho disinstallato chromium e installato Google Chrome. Non ha funzionato Poi ho scaricato il flash per ubuntu via apt. Quello mi ha dato un messaggio "flash version non supportato". La versione flash era 11.

Ora ho provato link

Ha funzionato, ma proprio nel bel mezzo del video, ha nuovamente visualizzato il messaggio di errore.

Sorry we are unable to stream this video. This is likely because your Flash Player needs to be updated.

Quindi non so cosa sia successo.

    
posta Alex 03.06.2012 - 04:12

10 risposte

4

Probabilmente non funziona in Google Chrome per Linux a causa delle limitazioni di Pepper Flash, come menziona Google su la loro pagina di supporto :

  

Utenti Linux: Adobe Flash Player utilizza un'API multipiattaforma, API Pepper   (PPAPI), per eseguire il proprio plug-in in Chrome. Potresti notare alcuni dei   problemi noti sotto specifici di Linux Chrome:

     

[...]

     
  • La visualizzazione del contenuto di Adobe Access (DRM) non è supportata, poiché Adobe non lo supporta su Linux.
  •   

[...]

Penso che sia molto probabile che:

  • Il supporto per il precedente 11.2 Flash per Linux (che utilizza l'API regolare) è stato abbandonato da Amazon.
  • Il supporto per il DRM richiesto in 11.7 in Chrome per Linux non funziona a causa delle limitazioni di cui sopra.

Questo fa cadere Ubuntu tra due sgabelli nel supporto per la visione di video abilitati al DRM.

    
risposta data gertvdijk 21.06.2013 - 14:24
23

Ho avuto questo stesso problema su Ubuntu 12.04 usando Chromium. Ho risolto il problema seguendo le istruzioni sulla adobe pagina di aiuto per l'installazione del modulo Hardware Abstraction Layer:

Prerequisiti per la riproduzione di contenuti protetti

Per Ubuntu 10.04 o successivo, assicurarsi che il modulo Hardware Abstraction Layer sia stato installato per la prima volta usando apt-get. (Osserva attentamente gli errori di installazione "hal", poiché l'installazione di un pacchetto danneggiato può continuare a influire sulla riproduzione del video.)

sudo apt-get install hal

Una volta completata l'installazione della libreria "libhal" (HAL), chiudi il browser e cancella le directory di Adobe Access eseguendo i seguenti comandi della shell:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Nota: Se manca il modulo Hardware Abstraction Layer, Flash Player funziona ancora. Tuttavia, non può riprodurre contenuto protetto che richiede il modulo DRM (Digital Rights Management) di Adobe Flash Access.

    
risposta data jpetersen 11.06.2012 - 02:26
3

prova ad aprire questa pagina . Vedrai una piccola scatola con il titolo informazioni sulla versione . Inoltre, eseguirà un breve video flash come test e ti dirà

1) se il tuo plug-in flash funziona correttamente

2) la versione esatta del flash che hai installato (buona base per un'ulteriore risoluzione dei problemi)

Anche se non è una soluzione direttamente, potrebbe esserti utile.

    
risposta data offline 11.06.2012 - 00:32
1

Sul mio sistema 10.04, ho eseguito Gestore pacchetti Synaptic , cercato flash e trovato un pacchetto chiamato flashplugin-installer version 11.2.202.238ubuntu0.10.04.1 . Selezionandolo per l'installazione ha causato la rimozione della versione precedente del plug-in Flash che era per 64 bit. Tuttavia, questo ha risolto il problema per me. Ora posso riprodurre video istantanei di prima qualità.

    
risposta data Cynthia 11.09.2012 - 03:48
1

A volte quando il flash viene aggiornato automaticamente, la versione più recente non funziona come la mia precedente. Non ho trovato un modo semplice per effettuare il downgrade, ma ecco un modo che funziona per me quando utilizzo firefox:

  1. Scarica la versione precedente di Adobe dagli archivi flash player . Da quello che posso dire, le versioni 11.2.202.xxx sono per Linux. La versione che ho scaricato, 11.2.202.275 , è arrivata in una cartella compressa. Quando l'ho estratto, ho visto che libflashplayer.so era all'interno.
  2. Ho spostato libflashplayer.so in ~/.mozilla/plugins/ .
  3. Riavvia firefox. Guarda i tuoi video.
risposta data Kevin 13.04.2013 - 17:10
0

Un altro problema comune con Flash, specialmente in 12.04, è "Gnash", che mi ha causato numerosi problemi con il flash. Rimuovi completamente Gnash, quindi scarica il plug-in Flash da Adobe o dal "Software center".

Il modo terminale:

sudo apt-get autoremove --purge gnash && sudo apt-get install adobe-flashplugin -y

Per coloro che non sanno, rimuove Gnash e le configurazioni (con purge) quindi installa l'ultima versione di Flash. Potrebbe essere necessario riavviare in seguito (qualcosa che non faccio molto spesso se sono onesto).

Modifica Potrebbe essere necessario riavviare il sistema una volta rimosso Gnash, a volte le sue configurazioni sono attive nella sessione corrente.

    
risposta data ash 12.06.2012 - 18:27
0

Chrome ha il supporto per Flash integrato nel browser. Non è come il modo in cui Firefox usa flashplugin-installer / flashplugin-nonfree o adobe-flashplugin (che sono separati dal browser, ma utilizzati dal browser). Il plug-in di Ubunbu può utilizzare l'HAL, mentre il plug-in integrato da chrome non può.

    
risposta data David Walker 07.08.2012 - 15:29
0

/. adobe / Flash_Player / * probabilmente non ha i permessi giusti anche se si reinstalla. Prova quanto segue se sei bloccato dopo tutto quanto sopra:

sudo apt-get purge flashplugin-installer ubuntu-restricted-extras
sudo apt-get install flashplugin-installer ubuntu-restricted-extras

Chiudi Chromium e:

cd ~/.adobe/Flash_Player
rm -rf ./*

Apri Chromium e prova a riprodurre il video problematico (probabilmente non verrà ancora riprodotto) e poi:

cd ~/.adobe/Flash_Player
chmod 777 *

È probabile che questi ultimi due comandi siano tutto ciò che devi davvero fare. Il resto è lì solo per completezza.

    
risposta data jarederaj 12.08.2014 - 23:50
0

Sono un principiante di Ubuntu e ho provato varie cose da fare con il flash non installato, o non avendo una versione aggiornata di cromo o cromo ecc. per far funzionare la musica di Amazon in Chrome e Chromium. Alla fine è andato a Firefox e è andato ad aggiungere ons & gt; plug-in & gt; ... imposta il flash dell'onda d'urto per attivarlo sempre e ora funziona bene.

    
risposta data Gary Tomkins 25.02.2018 - 10:42
-1

Vai al tuo componente aggiuntivo Google Chrome e cerca Adobe Flash per Google Chrome e installa quello giusto per il tuo browser. Penso che abbia qualcosa a che fare con il tuo browser. Hai provato in altri browser come Firefox?

    
risposta data all4naija 11.06.2012 - 16:15

Leggi altre domande sui tag