Come disabilitare le scorciatoie di alt-f1 / alt-f2?

18

Posso assegnare Alt + F1 e Alt + F2 a qualsiasi funzione che mi piace nella configurazione della tastiera finestra, ma non è stata utilizzata. Alt + F1 è sempre 'dash home' e Alt + F2 è sempre 'eseguito'

    
posta remco hosman 28.04.2012 - 10:18

4 risposte

23

Mi sono seduto con lo stesso problema dopo l'aggiornamento alla 12.04 e l'installazione di Gnome Shell. Ho provato a disabilitare ALT + F1 da dove potevo, senza risultato.

Mentre stavo per mollare ho trovato questo succo: link

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "[]" # disable Alt+F1

Crediti per link

    
risposta data johanmynhardt 30.04.2012 - 20:14
21

Con il plugin di ubuntu unity installato, il frammento di musinsky gist nel terminale non era sufficiente.

Disabilitare usando compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager
sudo apt-get install compiz-plugins-extra
ccsm
ubuntu unity plugin

scheda generale

  • Tasto per mostrare l'HUD - disabilitare
  • Chiave per eseguire un comando - disabilita

scheda di avvio

  • Chiave per dare il focus della tastiera a Launcher - disable
risposta data andersoyvind 23.08.2013 - 11:09
2

Su Ubuntu 16.04 puoi farlo usando il seguente comando:

gsettings set org.compiz.unityshell:/org/compiz/profiles/unity/plugins/unityshell/ keyboard-focus ''
    
risposta data rmaruszewski 08.12.2017 - 23:17
1

Sebbene johanmynhardt ci abbia dato la risposta giusta per l'Alt-F1, non ci ha detto cosa sia per Alt-F2. Con il ciclo for, come mostrato da Jesse Glick, ho capito il comando Alt-F2. In questo modo rimuovi i tasti BOTH:

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "[]" # disable Alt+F1
gsettings set org.gnome.desktop.wm.keybindings panel-run-dialog "[]" # disable Alt-F2
    
risposta data Alexis Wilke 22.09.2013 - 09:36

Leggi altre domande sui tag