Chromium shutdown immediato all'avvio di Ubuntu 16.04

17

Ho provato i suggerimenti di altri thread e niente ha funzionato. Chromium si spegne immediatamente dal launcher e dalla riga di comando. Ho rimosso Chromium accuratamente e reinstallato. Firefox funziona bene. Ho provato quanto segue:

sudo apt-get remove chromium --purge
rm -rf ~/.config/chromium
rm -rf ~/.cache/chromium
sudo rm -rf /etc/chromium

Ho reinstallato più volte usando Ubuntu Software Updater.

Quando lancio dalla riga di comando, ecco cosa ottengo:

chromium-browser --password-store=basic
Received signal 11 SEGV_MAPERR 000000000010
#0 0x7f85710a8425 base::debug::StackTrace::StackTrace()
#1 0x7f85710a880b <unknown>
#2 0x7f85713d3390 <unknown>
#3 0x557a2f3badc8 <unknown>
#4 0x557a2f3bd656 <unknown>
#5 0x557a2f3bddf9 <unknown>
#6 0x557a2f3be143 <unknown>
#7 0x7f8571123821 <unknown>
#8 0x7f85710a9eea base::debug::TaskAnnotator::RunTask()
#9 0x7f85710d2e90 base::MessageLoop::RunTask()
#10 0x7f85710d497d base::MessageLoop::DeferOrRunPendingTask()
#11 0x7f85710d583d <unknown>
#12 0x7f85710d6300 base::MessagePumpLibevent::Run()
#13 0x7f85710d1f15 base::MessageLoop::RunHandler()
#14 0x7f85710fc628 base::RunLoop::Run()
#15 0x7f8571128e36 base::Thread::ThreadMain()
#16 0x7f8571123726 <unknown>
#17 0x7f85713c96ba start_thread
#18 0x7f855aa783dd clone
r8: 000000000000002e  r9: 0000557a30e116ec r10: 0000000000000000 r11: 00007f855ab05f50
r12: 00007f84c9ff8ff0 r13: 0000000000000008 r14: 0000000000000008 r15: 00007f84c9ff8eb0
di: 0000000000000000  si: 00007f84c9ff8eb0  bp: 00007f84c9ff8f00  bx: 00007f84c9ff8eb0
dx: 0000000000000065  ax: 0000000000000000  cx: 0000557a33308720  sp: 00007f84c9ff8e60
ip: 0000557a2f3badc8 efl: 0000000000010206 cgf: 0000000000000033 erf: 0000000000000004
trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000010
[end of stack trace]
Calling _exit(1). Core file will not be generated.

Ma quando uso l'aggiornamento del software Ubuntu, l'applicazione mi consente di installare un 2 ° Chromium, un 3 ° Chromium o altro. A volte il programma di aggiornamento vede un Chromium esistente e dice "Rimuovi" invece di "Installa". Se seleziono "Rimuovi", rimuove uno dei Chromium, ma non tutti. Cercare di rimuoverli dalla riga di comando non ha alcun effetto:

sudo apt-get remove chromium --purge
[sudo] password for karen: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'chromium' is not installed, so not removed
The following packages were automatically installed and are no longer required:
libmircommon5 linux-headers-4.4.0-31 linux-headers-4.4.0-31-generic
linux-headers-4.4.0-62 linux-headers-4.4.0-62-generic linux-headers-4.4.0-63
linux-headers-4.4.0-63-generic linux-headers-4.4.0-64
linux-headers-4.4.0-64-generic linux-headers-4.4.0-66
linux-headers-4.4.0-66-generic linux-headers-4.4.0-70
linux-headers-4.4.0-70-generic linux-headers-4.4.0-71
linux-headers-4.4.0-71-generic linux-headers-4.4.0-72
linux-headers-4.4.0-72-generic linux-headers-4.4.0-75
linux-headers-4.4.0-75-generic linux-headers-4.4.0-78
linux-headers-4.4.0-78-generic linux-image-4.4.0-31-generic
linux-image-4.4.0-62-generic linux-image-4.4.0-63-generic
linux-image-4.4.0-64-generic linux-image-4.4.0-66-generic
linux-image-4.4.0-70-generic linux-image-4.4.0-71-generic
linux-image-4.4.0-72-generic linux-image-4.4.0-75-generic
linux-image-4.4.0-78-generic linux-image-extra-4.4.0-31-generic
linux-image-extra-4.4.0-59-generic linux-image-extra-4.4.0-62-generic
linux-image-extra-4.4.0-63-generic linux-image-extra-4.4.0-64-generic
linux-image-extra-4.4.0-66-generic linux-image-extra-4.4.0-70-generic
linux-image-extra-4.4.0-71-generic linux-image-extra-4.4.0-72-generic
linux-image-extra-4.4.0-75-generic linux-image-extra-4.4.0-78-generic
linux-signed-image-4.4.0-59-generic linux-signed-image-4.4.0-62-generic
linux-signed-image-4.4.0-63-generic linux-signed-image-4.4.0-64-generic
linux-signed-image-4.4.0-66-generic linux-signed-image-4.4.0-70-generic
linux-signed-image-4.4.0-71-generic linux-signed-image-4.4.0-72-generic
linux-signed-image-4.4.0-75-generic linux-signed-image-4.4.0-78-generic
snap-confine torsocks ubuntu-core-launcher
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

Ora ho tre icone di Chromium Launcher che lampeggiano Chromium prima di spegnerlo immediatamente.

I risultati sono confusi perché a volte sono stato in grado di utilizzare uno dei Chromium per ottenere il login di Google. Quando effettuo il login, Chromium si spegne immediatamente.

L'accesso come ospite produce gli stessi risultati. Inoltre, qui viene emesso da fsdk:

sudo fsck -n fsck from util-linux 2.27.1 e2fsck 1.42.13 (17-May-2015) 
Warning! /dev/sda8 is mounted. Warning: skipping journal recovery because doing a read-only filesystem check. /dev/sda8: clean, 654869/57204736 files, 7153620/228803072 blocks fsck.fat 3.0.28 (2015-05-16) 
0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt. Automatically removing dirty bit. Leaving filesystem unchanged. /dev/sda1: 198 files, 8082/65536 clusters

L'unica cosa che ha impedito a Chromium di chiudersi è la risposta fornita di seguito per avviarla con

chromium-browser --disable-extensions

C'è un post identico esattamente nello stesso giorno e una risposta era usare il cromo invece del cromo. Chrome funziona perfettamente e ho rimosso completamente il cromo. Considero questa questione chiusa. Grazie ad Alex O. in Chromium si blocca non appena effettuo l'accesso

    
posta KCinAZ 04.07.2017 - 19:23

5 risposte

24

Sorpresa, sorpresa! Sembra essere l'ultimo cast "fix". L'estensione del router multimediale è stata abilitata per impostazione predefinita per 59 e ora si blocca come 58 quando l'hai abilitata manualmente.

Avvia chrome con:

chromium-browser --disable-extensions

Passa a chrome: // flags, cerca "media router" e impostalo su Disabled.

Segnalazione di bug all'indirizzo link

Ora ci sono test dei pacchetti collegati dalla segnalazione di bug che sembrano risolvere il problema. Provali e segnala i risultati.

    
risposta data Trent Nelson 05.07.2017 - 20:24
4

1) Avvia Chromium sulla riga di comando con:

chromium-browser --disable-extensions

2) digita questo nella barra degli indirizzi di Chromium:

chrome://flags

3) premi ctrl-F e cerca " router multimediale ", quindi imposta su " Disabilitato ".

Fonte: Bug di Ubuntu 1702407 | Commento 19 .

    
risposta data Lonnie Best 07.07.2017 - 07:11
3

Non è una soluzione reale, ma se puoi vivere senza estensioni,

chromium-browser --disable-extensions

ha interrotto il cromo causato dall'arresto anomalo di me.

Se vuoi chiudere il terminale che ha generato il processo Chromium senza chiudere Chromium, utilizza:

nohup chromium-browser --disable-extensions <&- >&- 2>&- &

Modifica: anche questo è iniziato per me oggi.

  

Chromium 59.0.3071.109 Costruito su Ubuntu, eseguito su Ubuntu 16.04

    
risposta data Therealtahu 05.07.2017 - 03:02
0

Lo stesso qui e lo uso solo per il segnale ...

Dall'ultimo aggiornamento, su 59.0.3071.109-0u, se lo avvio senza estensioni e poi con:

chromium-browser --disable-extensions & amp; & amp; / usr / bin / chromium-browser --profile-directory = Predefinito --app-id = bikioccmkafdpakkkcpdbppfkghcmihk

viene eseguito per alcuni minuti prima di bloccarsi allo stesso modo ...

(16.04.2 con mainline 4.9.35)

    
risposta data Alex 06.07.2017 - 17:17
0

in qualche modo qualcosa è cambiato in:  / Usr / lib / cromo browser

ha copiato i file dal backup in quella directory e il browser ha funzionato di nuovo.

se succede di nuovo, posterò quale file è stato modificato o cancellato.

    
risposta data glennac 16.07.2017 - 04:30

Leggi altre domande sui tag