Come faccio a far sì che Update Manager interrompa l'apertura automaticamente?

17

Update Manager continua ad aprirsi automaticamente e sta diventando molto fastidioso, specialmente quando sto usando Gnome Shell. Come faccio a smettere?

    
posta Devon Garber 05.12.2011 - 03:32

7 risposte

9

Questo potrebbe funzionare per te. Non ho verificato se funziona in GNOME.

  • Apri l'applicazione Sorgenti software .
  • Seleziona la scheda "Aggiornamenti".
  • Per l'opzione "Verifica automaticamente aggiornamenti", seleziona Mai .

Dopodiché, dovrai aprire manualmente l'applicazione Update Manager.

    
risposta data Ryan McClure 26.04.2012 - 09:31
9

Ho trovato questo post con le seguenti istruzioni:

  

apri gconf-editor , scorri verso il basso fino a Apps - & gt; Update Notifier e deseleziona l'opzione auto_launch

OK, prova questo . È simile all'altra risposta ma la disabilita invece di eliminarla completamente. Potrebbe essere più sicuro per te aprire il file in un editor e modificare la riga manualmente anziché il comando sed utilizzato dal post.

La procedura, utilizzando un editor:

  1. Apri un terminale
  2. Passa alla directory di avvio automatico ( cd /etc/xdg/autostart ) ed elenca i file lì ( ls ).
  3. Trova il programma di avvio che vuoi eseguire (nel nostro caso update-notifier.desktop ) e aprilo in un editor ( gksudo gedit update-notifier.desktop ). Inserisci la password, se necessario.
  4. Fai attenzione a non cambiare nulla tranne questa linea. Trova questa riga:
    NoDisplay=true
    e modificala in:
    NoDisplay=false
  5. Salva il file ed esci.
  6. Riavvia per assicurarti che funzioni.
risposta data Kevin 25.11.2011 - 19:39
5

Ubuntu 12.04 LTS

Il gestore aggiornamenti viene visualizzato quando rileva un nuovo aggiornamento. Questo comportamento può essere piuttosto fastidioso per molti, specialmente quando sei nel bel mezzo del tuo lavoro. Per peggiorare le cose, se lo si chiude senza eseguire l'aggiornamento, continuerà ad apparire a intervalli regolari e ogni volta dopo l'avvio, fino a quando non si sarà aggiornato il sistema. Per disattivarlo:

Metodo 1 - Disabilita Notificatore aggiornamenti dall'autostart

Gli autostarts Notifier Update all'avvio e attivano Update Manager. Con questo metodo, evitiamo che l'Update Notifier stesso non si avvii automaticamente, in modo che Update Manager non venga attivato. Modifica la voce di Update Notifier negli autostarts a livello di sistema - /etc/xdg/autostart/update-notifier.desktop (Si noti che non si sarà in grado di utilizzare l'app Applicazioni di avvio, poiché riguarda solo le voci di avvio automatico per utente) e aggiungere la seguente riga:

X-GNOME-Autostart-enabled=false

Riavvia ora e scoprirai che non è presente alcuna notifica di aggiornamento.

Svantaggio: disabilita completamente le notifiche di aggiornamento automatiche. Devi controllare manualmente gli aggiornamenti (che per me vanno bene, ma potrebbe non esserlo per alcune persone)

Metodo 2 - Mostra indicatore di aggiornamento

Questa opzione fa sì che l'Update Notifier mostri un Indicatore di aggiornamento nel pannello, invece di far apparire il Gestore aggiornamenti. Penso che questa dovrebbe essere l'impostazione predefinita per Update Notifier in Ubuntu. Per farlo:

Modo grafico: Apri l'editor di dconf. Vai a com & gt; ubuntu- & gt; update-notifier . Deseleziona la voce auto-launch e chiudi l'editor di dconf. Per ripristinare la funzione popup di Update Manager, è sufficiente ripetere il passaggio precedente, ma inserire un controllo nella voce auto-launch .

Modo di comando: per gli amanti del terminale, inserisci questi comandi per fare lo stesso.

gsettings set com.ubuntu.update-notifier auto-launch false

e per ripristinare:

gsettings set com.ubuntu.update-notifier auto-launch true

Questi metodi sono stati testati e sono risultati funzionanti su Ubuntu 12.04 LTS con update-manager versione 0.156.14.11. Ho avuto l'idea dal post Come rimuovere l'aggiornamento fastidioso manager Pop-up in Ubuntu Jaunty e semplicemente modificato per lavorare su Ubuntu 12.04 LTS alias Precise Pangolin

    
risposta data HEXcube 28.11.2013 - 13:27
4

In Preciso, è fatto usando ora dconf piuttosto che gconf.

  1. Installa dconf-tools

    $ sudo apt-get install dconf-tools

  2. lancia dconf-editor e vai a com & gt; ubuntu & gt; update-notifier.

  3. Spunta no-show-notifications

Ed ecco come farlo dalla riga di comando:

dconf write /com/ubuntu/update-notifier/no-show-notifications true
    
risposta data Bryce 27.06.2012 - 08:13
1

Al fine di interrompere Update Manager dall'avvio:

gconftool -s --type bool /apps/update-notifier/auto_launch false

Per attivare di nuovo :

gconftool -s --type bool /apps/update-notifier/auto_launch true

Spero che aiuti;)

    
risposta data Cormite 25.11.2011 - 20:02
0

Modifica /etc/update-manager/release-upgrades e imposta:

Prompt=never cambia con il tuo editor preferito.

Non utilizzare mai update-manager con -d controlla se la prossima versione è disponibile o meno.

    
risposta data Akshay Patil 18.01.2017 - 09:47
-1

Dovrebbe essere

gconftool -s --type bool /apps/update-notifier/auto_launch false
    
risposta data Panther 05.12.2011 - 05:08

Leggi altre domande sui tag