Richiesto costantemente per password WiFi e certificato CA.

19

Ho una connessione PEAP Enterprise WPA che mi chiede la password WiFi e il certificato CA ogni volta che mi trovo nella schermata di accesso.

Non ho un certificato CA per la connessione WiFi della mia scuola.

Questo è su Ubuntu 14.04 Questo avvertimento continua a venire ancora e ancora. Continuo a fare clic su Ignora e faccio clic su "Non avvisarmi più" Ma l'errore continua a venire.

Inoltre, ho provato a cambiare andando a

etc/NetworkManager/system-connections

trovare la mia connessione e cambiare la linea

system-ca-certs=true

a

system-ca-certs=false

Ma questo non ha aiutato affatto.

    
posta Ben Banks 28.04.2014 - 14:21

4 risposte

15

L'avvertimento stava succedendo ancora e ancora. Per prima cosa ho fatto questo Ho fatto clic su "Scegli un certificato di autorità di certificazione ..."

Poi sono passato a "/usr/share/ca-certificates/mozilla/AddTrust_External_Root.crt" e l'ho aggiunto come certificato.

L'errore del certificato è andato via ma la richiesta della password per il WiFi non è stata

Così sono andato su "Modifica connessioni" e ho selezionato la mia connessione wireless.

Poi sono passato alla scheda "Generale" e non selezionato "Tutti gli utenti possono connettersi a questa rete"

Nessun prompt CA o password wireless.

    
risposta data Ben Banks 29.04.2014 - 16:47
1

Alcune scuole e organizzazioni utilizzano l'autenticazione basata su EAP senza un certificato firmato dalla CA, solitamente a causa dei costi. Questo messaggio di avviso è fondamentalmente la stessa cosa dell'avvertimento del browser Web sui certificati SSL non validi o non firmati per i siti Web. Se ti fidi del certificato utilizzato per la connessione, puoi fare clic sulla casella "Non avvisarmi di nuovo" e quindi selezionare Ignore e Network Manager dovrebbe archiviare le credenziali per l'utilizzo al prossimo collegamento.

    
risposta data 0xSheepdog 28.04.2014 - 14:57
1

Ho aperto la finestra di dialogo, ma senza rimuovere i certificati di sistema ho continuato a non riuscire a connettermi alla rete correlata al certificato autofirmato. Una volta rimosso completamente il flag system-ca-certs, avrei potuto almeno collegarmi alla mia rete usando le mie credenziali. Quindi, era strano. Successivamente, ho selezionato un certificato di root come suggerito da qualcuno, e il fastidio del dialogo è andato via. Poi ho notato che il sistema-ca-certs era tornato, ma stranamente tutto è andato bene. Quindi, qualcosa di decisamente buggy lì, ma il modo in cui ha funzionato non lo rende chiaro su quello che è.

    
risposta data Wade Chandler 30.04.2014 - 23:42
1

Seguendo Ben Banks e le risposte dell'utente276463 ho risolto il problema con i seguenti passaggi.

  1. Prova a connetterti usando il menu wifi. Non funziona e richiede di nuovo la password.
  2. Disconnetti il ​​wifi dal menu dopo aver chiesto nuovamente la password.
  3. Modifica /etc/NetworkManager/system-connections/CONNECTION_NAME ed elimina la riga system-ca-certs=true
  4. Connetti di nuovo usando il menu wifi. Questa volta funziona.
risposta data paulinus 06.05.2014 - 17:17

Leggi altre domande sui tag