Problema con il riavvio di Apache 2 [duplicato]

74

Sto cercando di riavviare Apache 2:

sudo service apache2 restart

Ma ottieni l'errore seguente:

* Restarting web server apache2 

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1.

Set the 'ServerName' directive globally to suppress this message

Ho provato a cambiare

sudo gedit /etc/apache2/httpd.conf

Viene visualizzato un file vuoto e ho aggiunto:

ServerName localhost

Ma quell'errore non scompare!

Come posso risolvere questo problema?

    
posta Hamed Kamrava 06.08.2013 - 15:42

4 risposte

111

Ho trovato questo: Come posso riavviare / ricaricare Apache quando non è in grado di determinare il nome del dominio?

  

Buone notizie! Apache si sta riavviando con successo. Apache non è sicuro   da dove vuoi servire, quindi scegli il tuo localhost (127.0.0.1)   per impostazione predefinita. Per evitare che questo messaggio appaia, chiarisci che tu   voglio servire da localhost (127.0.0.1) aggiungendo la seguente riga   nel tuo file /etc/apache2/apache2.conf :

ServerName localhost
    
risposta data Meintjes 06.08.2013 - 15:52
34

Specificare ServerName localhost nei file di configurazione al di fuori delle sezioni dell'host virtuale è il modo per farlo.

Altre risposte suggeriscono di modificare /etc/apache2/httpd.conf . Questo file viene sovrascritto quando Apache viene aggiornato da apt. Per la configurazione di Apache che non vuoi sovrascrivere, devi creare un nuovo file. Ecco il "modo Debian" per modificare questa configurazione:

# create the configuration file in the "available" section
echo "ServerName localhost" | sudo tee /etc/apache2/conf-available/servername.conf
# enable it by creating a symlink to it from the "enabled" section
sudo a2enconf servername
# restart the server
sudo service apache2 restart
    
risposta data Stephen Ostermiller 10.03.2014 - 21:03
4

L'indirizzo IP dell'host locale dovrebbe essere 127.0.0.1, anziché 127.0.1.1. Configura correttamente il tuo file /etc/hosts . Quindi modifica il file httpd.conf :

sudo -H gedit /etc/apache2/httpd.conf

Quando viene visualizzato un file vuoto, aggiungi questa riga, quindi salva:

ServerName localhost
    
risposta data Masabza 02.03.2014 - 13:36
0

Ecco un'altra soluzione:

Prima:

[[email protected] ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: apr_sockaddr_info_get() failed for centos.wks.local
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
                                                           [  OK  ]

Aggiunto 192.168.226.131 centos.wks.local in /etc/hosts file

Nota: 192.168.226.131 è il mio indirizzo IP del server Apache.

Dopo

[[email protected] ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
    
risposta data Rahul Patil 06.08.2013 - 16:02

Leggi altre domande sui tag