Il modem 3G USB non funziona in 12.04

18

Quando connetto il mio modem USB 3G al mio laptop con 12.04, non compare nulla in Network-Manager. Questo modem funziona in 11.10 e il modem è mostrato in Network-Manager ma non in 12.04 !!

Ecco le uscite di lsusb e usb-devices su due macchine, una con 11.10 e l'altra con 12.04:

Ubuntu-11.10:

$ lsusb
    Bus 002 Device 009: ID 1c9e:6061  

$ usb-devices
    T:  Bus=02 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#=  9 Spd=12  MxCh= 0
    D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=1c9e ProdID=6061 Rev=00.00
    S:  Manufacturer=3G USB Modem        ￴￴
    S:  SerialNumber=000000000002
    C:  #Ifs= 4 Cfg#= 1 Atr=a0 MxPwr=500mA
    I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

Ubuntu-12.04:

$ lsusb
    Bus 002 Device 003: ID 1c9e:6061 OMEGA TECHNOLOGY WL-72B 3.5G MODEM

$ usb-devices
    T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
    D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=1c9e ProdID=6061 Rev=00.00
    S:  Manufacturer=Qualcomm, Incorporated
    S:  Product=USB MMC Storage
    S:  SerialNumber=000000000002
    C:  #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
    I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)

Come mostra l'output dei comandi precedenti, il dispositivo viene rilevato come modem in 11.10, ma in 12.04 viene rilevato come dispositivo di archiviazione USB (il dispositivo è sia un modem 3G che un adattatore USB per scheda SD).

Qualsiasi aiuto?!

    
posta Seyed Mohammad 30.05.2012 - 07:10

10 risposte

22

Dopo molte ricerche e letture in diversi forum ho trovato una soluzione al mio problema. Si noti che mentre le altre risposte non risolvono il mio problema, potrebbero essere utili per gli altri che affrontano problemi con i modem 3G USB (specialmente il sakis-3g script).

Ho trovato la mia soluzione in questo thread , che illustrerò nel seguito:

Quando si collega il mio modem USB, viene rilevato come una memoria USB. Secondo quel thread, l'esecuzione di sudo modprobe option potrebbe far rilevare il dispositivo come un modem. In caso contrario, si consiglia di eseguire i seguenti comandi:

sudo su
echo 1c9e 6061 > /sys/bus/usb-serial/drivers/option1/new_id

dove 1c9e 6061 è l'ID dispositivo ottenuto dal comando lsusb . Questo ha funzionato per il mio dispositivo ed è stato rilevato in Network-Manager. Nota che devi diventare root usando sudo su e l'esecuzione del comando con sudo non funzionerà.

Per automatizzare le cose, vengono presentati i seguenti passaggi:

  1. sudo su
  2. nano /usr/bin/usbModemScript e inserisci quanto segue nel file:

       #!/bin/bash
       echo 1c9e 6061 > /sys/bus/usb-serial/drivers/option1/new_id
    

    Quindi salva il file (Ctrl + O) e esci da nano (Ctrl + X).

  3. chmod +x /usr/bin/usbModemScript

  4. nano /etc/udev/rules.d/option.rules e inserisci quanto segue nel file:

        ATTRS{idVendor}=="1c9e", ATTRS{idProduct}=="6061", RUN+="/usr/bin/usbModemScript"
        ATTRS{idVendor}=="1c9e", ATTRS{idProduct}=="6061", RUN+="/sbin/modprobe option"
    

    Quindi salva il file (Ctrl + O) e esci da nano (Ctrl + X).

  5. reboot

NOTA: dovresti sostituire i valori 1c9e e 6061 con i valori ID dispositivo appropriati del tuo modem.

Dopo il riavvio, il tuo modem dovrebbe essere rilevato quando lo colleghi al computer. Certo, questo potrebbe non essere il caso (come non lo era per me)! Il mio dispositivo non è stato rilevato correttamente dopo la prima connessione al computer. Invece, ho dovuto disconnetterlo e quindi riconnetterlo, e questa volta è stato correttamente rilevato come modem in Network-Manger. Alcune persone potrebbero anche aver bisogno di riavviare il servizio network manager (come ho fatto io):

sudo service network-manager restart

=============================================== =================================

Un'altra possibile soluzione è utilizzare wvdial .

  1. Installazione: sudo apt-get install wvdial
  2. Collega il modem al computer.
  3. Esegui: sudo wvdialconf /etc/wvdial.conf . Se dice "nessun modem trovato", allora sei sfortunato!
  4. Se viene trovato il modem, esegui: sudo nano /etc/wvdial.conf e inserisci le informazioni del tuo ISP dove necessario riempiendo i campi che conosci. Esegui man wvdial.conf in un terminale separato per informazioni sulle opzioni. Una volta che sei pronto, salva il file (Ctrl + O) e esci da nano (Ctrl + X).
  5. Ora prova a connetterti: sudo wvdial

Per ulteriori informazioni su wvdial , leggi la pagina man (cioè man wvdial ).

Spero che questo aiuti :)

    
risposta data Seyed Mohammad 06.06.2012 - 09:25
5

Ho una chiavetta USB Huawei E156 HSDPA (3G) e ho fatto quanto segue, inoltre ha funzionato per il mio Samsung 3G via cavo USB.

sudo apt-get install wvdial

dopo aver installato il tipo di wvdial seguendo le righe nel terminale per modificare wvdial.conf

sudo gedit /etc/wvdial.conf

Incolla nell'editor, le seguenti righe:

[Dialer name]
Modem Type = Analog Modem
Phone = *99#
ISDN = 0
Baud = 460800
Username = " "
Password = " "
Modem = /dev/ttyUSB0
Init1 = ATZ
Init2 = at+cgdcont=1,"ip","your Access Point Name"
Stupid Mode = 1

Ogni volta che devi connetterti, digita il tuo terminale

sudo wvdial name

Ora sarai online con velocità incredibile. Penso che questo metodo richieda meno tempo e sia più veloce di altri metodi.

    
risposta data gunjan parashar 18.01.2012 - 20:58
2

try

sudo modprobe usbserial vendor=0x1c9e product=0x6061

E aspetta un po 'di tempo. Funziona sempre per me

    
risposta data virpara 30.05.2012 - 07:26
2

hai provato a usare usb_modeswitch:

link

per cambiare il tipo da USB MMC Storage a 3G USB Modem?

    
risposta data Steve 05.06.2012 - 14:17
1

Hai installato usb-modeswitch? Ubuntu 10.10 deve essere arrivato con esso. Prova a verificare con Synaptics se è installato il selettore di modalità usb. Una volta installato, collegare il modem USB e attendere. Ci sarà un'opzione nell'icona di connettività dove scrive creare una nuova banda larga mobile. Quindi seguire i passaggi dalla finestra. Sto usando un modem usb con Ubuntu 10.10 e funziona bene. =)

    
risposta data Wilsonzaizai 23.10.2010 - 13:24
0

Sai qual è la marca e il modello del tuo modem? Huawei, Opzione o Sony Ericsson? Alcuni modelli Huawei necessitano di qualche ritocco. Nel sito danese qui: link puoi scaricare ed eseguire uno script che farà funzionare la maggior parte dei modelli Huawei. Puoi tradurre la pagina con google translate; -)

    
risposta data Areius 25.10.2010 - 11:18
0

installa usb-modeswitch e usa wvdial o gnome-ppp per connettersi a internet. Potrai anche connetterti usando il gestore di rete se viene rilevato il tuo modem. usb-modeswitch è il trucco.

Se il tuo modem ha driver personalizzati disponibili, installali.

    
risposta data srinathhs 25.10.2010 - 18:45
0

Per questo MODEM USB, prova sakis-3g. Puoi scaricarlo: link

    
risposta data Octávio Filipe Gonçalves 05.06.2012 - 13:39
0

Semplicemente, usa una connessione alternativa, un pieno aggiornamento di ubuntu. Connetti di nuovo usando il tuo Dongg 3g.

E funzionerà benissimo!

    
risposta data BigSack 05.06.2012 - 13:52
0

Ho un'idea perché net setter funziona su ubuntu 10.04, 11.04 ecc.
Connetti e amp; aggiungere una connessione bb mob nel gestore di rete. Per assistenza con Network Manager, guarda qui

    
risposta data Prasad V N. 08.04.2013 - 12:23

Leggi altre domande sui tag