upgrade git su Ubuntu 10.04 (Lucid Lynx)

18

Al momento ho installato Git 1.7.1.0 ma devo aggiornare alla 1.7.1.1 (almeno). Ho provato a correre:

sudo apt-get update
sudo apt-get upgrade

e anche provato

sudo apt-get install git-core

ma ogni volta ricevo un messaggio che indica che non esiste una versione successiva di git disponibile. Ho le seguenti fonti software configurate in /etc/apt/sources.list

deb http://ubunturepo.de.bonial.lan lucid main restricted multiverse universe
deb http://ubunturepo.de.bonial.lan lucid-security main restricted multiverse universe
deb http://ubunturepo.de.bonial.lan lucid-updates main restricted multiverse universe
deb http://archive.canonical.com/ lucid partner
deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu lucid main
deb-src http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu lucid main
deb http://archive.ubuntu.com/ubuntu lucid multiverse universe
    
posta Dónal 08.04.2013 - 10:48

2 risposte

34

Per installare l' ultima versione stabile dalla riga di comando ...

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:git-core/ppa
sudo apt-get update
sudo apt-get install git

Questo dovrebbe consentire di installare 1.8.2-1~ppa0~lucid2 .

    
risposta data Rinzwind 08.04.2013 - 11:13
0

Apri il terminale usando questo collegamento

Ctrl + Alt + T

Quindi inserisci questi comandi sul terminale

sudo apt-get update

sudo apt-get install git

    
risposta data Ashish Saini 22.09.2014 - 11:48

Leggi altre domande sui tag