Ubuntu 16.04 senza barra dei menu o launcher - aiuto!

20

Appena aggiornato alla 16.04. A causa dello sfarfallio dello schermo ho seguito la guida pubblicata da Zacharee 1! Lo schermo non lampeggia più. Tuttavia, anche se posso effettuare il login non c'è barra dei menu di avvio. Ho provato varie guide per ripristinarlo in precedenti Ubuntu come rm -rf .compiz-1 , rm -rf ~/.config e sudo apt-get install unity . Niente funziona e non riesco a trovare qualcosa di specifico per 16.04. Sono su un sistema Skylake con Nvidia GTX 950.

    
posta Tom Nadia 23.04.2016 - 08:33

4 risposte

29

Avuto lo stesso problema dopo aver scherzato con lo strumento di unità-tweak. I seguenti comandi del terminale mi hanno aiutato (da tnx a ubuntuhandbook.org):

dconf reset -f /org/compiz/
setsid unity
    
risposta data pauldm 24.04.2016 - 10:06
7
rm -rf ~/.config/compiz-1/compizconfig/*

è il miglior trucco. Riavvia dopo.

    
risposta data dr_smit 30.07.2016 - 15:02
2

digitando ccsm e selezionando unità launcher lo ha fatto.

Da un tty, esegui i seguenti comandi:

export DISPLAY=:0
ccsm

Quindi, potresti dover premere CTRL + ALT + f7 per tornare alla sessione x.

    
risposta data Tom Nadia 23.04.2016 - 10:30
1

Risposta breve: se nessuna delle soluzioni standard pubblicate (utilizzando dconf, gconftool-2, ccsm, unity, ecc.) funziona, prova a disattivare temporaneamente le app di avvio automatico. Ecco un modo per farlo:

mv ~/.config/autostart ~/.config/autostartBAK 

Esci, quindi riaccedi. Se il problema è risolto, è una buona scommessa che uno dei programmi di avvio automatico si è arrestato. Puoi quindi capire quale, quindi spostare tutto tranne quello in ~ / .config / autostart.

Risposta lunga : nel mio caso, l'aggiornamento 16.04 è andato a buon fine, ma inaspettatamente diverse settimane dopo questo problema "nessun menu barra o avvio" è apparso. Nessuna delle solite soluzioni pubblicate ha funzionato. Ma l'accesso a un account utente appena creato non mostrava il problema, quindi sapevo che il problema era strettamente nella mia home directory. Controllando ~ / .xsession-errors, ho notato che un'app si arrestava in modo anomalo all'avvio (my-weather-indicator). Rimozione del file "my-weather-indicator-autostart.desktop" da ~ / .config / autostart risolto.

    
risposta data Plenus Franckly 04.01.2017 - 14:38

Leggi altre domande sui tag