Installa Skype su Ubuntu 12.04 LTS a 64 bit

18

Da settimane cerco di installare Skype sul mio computer. Ho immaginato che sarebbe stato un compito semplice ma sta diventando un incubo.

Quello che ho provato finora:

Installazione da riga di comando con apt

Il più semplice e il più probabile che qualcuno proverebbe: % Co_de%

Ma sfortunatamente lo trovo:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed.
This may mean that you have requested an impossible situation or if you are
using the unstable distribution that some required packages have not
yet been created or been moved out of Incoming. The following
information may help to resolve the situation:

The following packages have unmet dependencies:
  skype :
     Depends:
       skype-bin
     E: Unable to correct problems, you have held broken packages.

Se provo sudo apt-get install skype ottengo:

 Some packages could not be installed. This may mean that you have
 requested an impossible situation or if you are using the unstable
 distribution that some required packages have not yet been created or
 been moved out of Incoming. The following information may help to
 resolve the situation:

 The following packages have unmet dependencies:  skype-bin:i386 :
    Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not going to be installed
    Depends: libqt4-network:i386 (>= 4:4.8.0) but it is not going to be installed
    Depends: libqt4-xml:i386 (>= 4:4.5.3) but it is not going to be installed
    Depends: libqtcore4:i386 (>= 4:4.7.0~beta1) but it is not going to be installed
    Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
    Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed
    Recommends: sni-qt:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Dopo ho provato con comandi come sudo apt-get intall skype-bin , sudo apt-get clean , sudo apt-get update e sudo apt-get autoclean , tra gli altri, per correggere qualsiasi problema con la dipendenza dei pacchetti ma non ha avuto successo.

Ho seguito le istruzioni spiegate qui ( Come installo Skype? ) ma non funziona neanche.

Installazione da Software Center

Se provo a installare da Software Center, ottengo esattamente lo stesso errore rispetto all'esecuzione di sudo apt-get -f install dal terminale.

Installazione con Ubuntu Tweak

Errore, ho ricevuto il seguente errore:

% Bl0ck_qu0te%

Installazione con Synaptic

Ho seguito anche le istruzioni qui descritte:

community.skype.com/t5 / Linux / Unable-to-install-due-unmet-dependencies-Skype-bin / m-p / 1339650 / highlight / true # M3329

Gran parte della stessa cosa non funziona neanche.

Installazione ufficiale di .deb Skype

Dopo aver scaricato skype-ubuntu-precise_4.1.0.20-1_i386.deb da link Ho provato ad installarlo anche se Software Center ma visualizza il seguente errore:

Impossibile installare 'lbqt4-dbus: i386'

Cercando di correggere apt

Ho provato a risolvere qualsiasi possibile problema con i pacchetti seguendo questo post ( Come fare Risolvo le dipendenze non soddisfatte dopo l'aggiunta di un PPA? ) ma non ha funzionato.

Seguendo le istruzioni della guida di Ubuntu

Se provo a seguire le istruzioni spiegate nel link ho problemi durante l'esecuzione di sudo apt-get install skype , ottengo il seguente :

% Bl0ck_qu0te%

Ho anche provato altri approcci seguendo altri post e soluzioni che ho trovato, ma nulla di ciò ha funzionato per me. A questo punto sono completamente perso e non so cos'altro posso fare. Spero che qualcuno possa trovare una soluzione.

Questo è il contenuto del mio sources.list, nel caso in cui:

# deb cdrom:[Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64 (20130213)]/ dists/precise/main/binary-i386/

# deb cdrom:[Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64 (20130213)]/ dists/precise/restricted/binary-i386/
# deb cdrom:[Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64 (20130213)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu precise universe
deb http://archive.ubuntu.com/ubuntu precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu precise multiverse
deb http://archive.ubuntu.com/ubuntu precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb http://archive.ubuntu.com/ubuntu precise-security main restricted
deb http://archive.ubuntu.com/ubuntu precise-security universe
deb http://archive.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb http://extras.ubuntu.com/ubuntu precise main
# deb-src http://extras.ubuntu.com/ubuntu precise main
deb http://archive.canonical.com/ precise partner
deb-src http://archive.canonical.com/ precise partner
    
posta Alejandro García Seco 23.04.2013 - 22:28

5 risposte

3

OK, ho trovato una soluzione per il mio problema. Ho seguito i passaggi descritti qui: link

Dopodiché, ho semplicemente eseguito sudo apt-get install skype e ... voilà, funziona!

Devo dire che ha una conseguenza negativa. Dopo aver eseguito sudo apt-get dist-upgrade come descritto nel terzo passaggio, ottengo quanto segue se eseguo sudo apt-get autoremove :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up grub-efi-amd64 (1.99-21ubuntu3.9) ...
/var/lib/dpkg/info/grub-efi-amd64.postinst: line 684: grub-install: command not found
dpkg: error processing grub-efi-amd64 (--configure):
 subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of grub-efi-amd64-signed:
 grub-efi-amd64-signed depends on grub-efi-amd64 (>= 1.99-21ubuntu3.5); however:
  Package grub-efi-amd64 is not configured yet.
dpkg: error processing grub-efi-amd64-signed (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 grub-efi-amd64
 grub-efi-amd64-signed
E: Sub-process /usr/bin/dpkg returned an error code (1)

Tutto funziona fortunatamente, ma ora vorrei risolvere il problema con i pacchetti di Grub, specialmente perché è correlato con Grub che è molto critico. Mi chiedo solo se riesco a trovare ulteriori problemi imprevisti durante l'avvio del mio computer ...

Bene aggiornerò questa risposta se riesco a correggere questa conseguenza indesiderata. Se qualcuno sa come, per favore fatemelo sapere.

UPDATE:

Sono riuscito a risolvere il problema con i pacchetti GRUB, ho descritto il problema e la soluzione qui: Impossibile correggere il sistema di pacchetti danneggiato

    
risposta data Alejandro García Seco 24.04.2013 - 17:01
13

Una combinazione di Gx1sptDTDa e Alejandro García Seco ha funzionato perfettamente per me.

  1. Apri terminale ( Ctrl + Alt + T ).
  2. Copia e incolla questo nel terminale:

    sudo apt-get install libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 sni-qt:i386
    

    Premere Invio .

  3. Quindi installa Skype incollando questo:

    sudo apt-get install skype
    

Skype 4.2 è in esecuzione sul mio fresco Ubuntu 12.04 LTE 64 bit.

    
risposta data Robi 01.06.2013 - 00:56
7

& gt; & gt; Per 32 bit

Comandi del terminale:

wget  http://download.skype.com/linux/skype-ubuntu-lucid_4.2.0.11-1_i386.deb
sudo dpkg -i skype-ubuntu-lucid_4.2.0.11-1_i386.deb
sudo apt-get -f install;rm skype-ubuntu-lucid_4.2.0.11-1_i386.deb

& gt; & gt; Per 64 bit

Comandi del terminale:

sudo dpkg --add-architecture i386
sudo apt-get install ia32-libs
sudo apt-get update
wget http://download.skype.com/linux/skype-ubuntu-lucid_4.2.0.11-1_i386.deb
sudo dpkg -i skype-ubuntu-lucid_4.2.0.11-1_i386.deb
sudo apt-get -f install;rm skype-ubuntu-lucid_4.2.0.11-1_i386.deb

Dopo tutto questo corri nel terminale sudo apt-get install sni-qt:i386 ; Questo ripristinerà la finestra di contatto skype

Questo è tutto, lavoro svolto in massimo 5 minuti. Io uso Ubuntu su 64 bit e questo metodo per installare Skype ha funzionato sempre perfettamente.

    
risposta data Dave 04.07.2013 - 05:25
2

Skype è stato un vero problema per me installare su Ubuntu 12.04 LTS a 32 bit. Ho provato la maggior parte delle cose elencate qui, ma ho solo avuto il diritto di installare tramite la sezione App di Ubuntu Tweak .

    
risposta data MorganSBailey 23.04.2013 - 22:32
0

Ho trovato un modo incredibilmente semplice per farlo. Basta eseguire questi comandi in un terminale:

sudo apt-get install libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 sni-qt:i386

wget http://download.skype.com/linux/skype-debian_4.2.0.13-1_i386.deb

sudo dpkg -i skype-debian_4.2.0.13-1_i386.deb

Il primo scarica le dipendenze, il secondo scarica il pacchetto .deb e poi l'ultimo lo installa. Semplice!

    
risposta data Elijah Goforth 06.04.2014 - 06:24

Leggi altre domande sui tag