Come impedire a Nautilus di creare miniature di tipi di file specifici?

18

Sto tentando di impedire a Nautilus di creare miniature di file PDF. In un'altra discussione sui "forum di Ubuntu" qualcuno ha detto di aprire gconf-editor e disabilitare la voce PDF nella directory "/ desktop / gnome / thumbnailers". Tuttavia l'unica voce in quel DIR è disabilita tutto. Inutile dire che non lo voglio.

Come posso disabilitare le miniature per un tipo di file specifico?

    
posta RADXack 12.05.2012 - 18:58

2 risposte

19

Le miniature di tipi di file specifici possono essere disabilitate usando l'editor di dconf.

Installa l'editor di dconf:

Premi Alt + Ctrl + T ed esegui il seguente comando:

sudo apt-get install dconf-tools

Oppure cerca "dconf-tools" in Software Center e installalo da lì.

Come disabilitare le miniature di un tipo di file specifico

  • Una volta installato, premi il tasto super (tasto Windows) per aprire il trattino Unity e cerca "editor dconf" e aprilo.

  • Vai a org > gnome > desktop > thumbnailer

  • Incolla il tipo MIME di PDF 'application/pdf' nel campo valore della chiave di disabilitazione, come mostrato di seguito.

Ciò impedirà a Nautilus di generare miniature dei PDF in futuro, ma le vecchie miniature saranno lì. Per risolvere questo problema, dovrai cancellare il cache delle miniature Nautilus.

  • Apri la tua home directory e premi Ctrl + H per mostrare i file e le cartelle nascoste.
  • Apri .thumbnails ed elimina tutti i file al suo interno.

  • Riavvia il sistema o uccidi Nautilus affinché le modifiche abbiano effetto.

Per disabilitare le anteprime per altri tipi di file, aggiungi il tipo MIME nell'elenco Disabilita come descritto sopra. Seprate più tipi con una virgola. così:

[ 'application / pdf', 'image / jpeg', 'video / mp4']

Per l'elenco completo dei tipi MIME, visita iana.org .

    
risposta data Basharat Sialvi 13.05.2012 - 05:05
3

Per impedire la visualizzazione dell'anteprima qualsiasi file video (perché nel mio piccolo HTPC, causa un elevato utilizzo della CPU):

Prima, pulisci la cache delle miniature:

rm -rf ~/.cache/thumbnails

Applica l'elenco dei tipi mime:

gsettings set org.gnome.desktop.thumbnailers disable "['application/annodex','application/mp4','application/ogg','application/vnd.rn-realmedia','application/x-matroska','video/3gpp','video/3gpp2','video/annodex','video/divx','video/flv','video/h264','video/mp4','video/mp4v-es','video/mpeg','video/mpeg-2','video/mpeg4','video/ogg','video/ogm','video/quicktime','video/ty','video/vdo','video/vivo','video/vnd.rn-realvideo','video/vnd.vivo','video/webm','video/x-bin','video/x-cdg','video/x-divx','video/x-dv','video/x-flv','video/x-la-asf','video/x-m4v','video/x-matroska','video/x-motion-jpeg','video/x-ms-asf','video/x-ms-dvr','video/x-ms-wm','video/x-ms-wmv','video/x-msvideo','video/x-sgi-movie','video/x-tivo','video/avi','video/x-ms-asx','video/x-ms-wvx','video/x-ms-wmx']"

Quindi assicurati che

nautilus -q

Ottengo l'elenco dei tipi mime da qui .

    
risposta data Maxwel Leite 22.09.2013 - 05:39

Leggi altre domande sui tag