Il touchpad Synaptics tap-to-click non funziona su Ubuntu 15.10 (Gnome)

17

Ho aggiornato la mia installazione di ubuntu gnome alla 15.10 e tutto è abbastanza buono ad eccezione della funzionalità touch-tap single-tap. Il tocco singolo per clic non funziona . E ho provato tutte le possibili soluzioni come la modifica del file synaptics.conf .

Una cosa che ho notato è la seguente, che è piuttosto strano. Per ogni dispositivo di input lo schema ha una voce originale e deprecated ma per touchpad ha appena deprecated . È questa la causa?

Non so come risolvere questo problema. Per favore aiuto!

org.gnome.settings-daemon.peripherals.input-devices 
org.gnome.settings-daemon.peripherals.keyboard 
org.gnome.settings-daemon.peripherals.keyboard.deprecated:/
org.gnome.settings-daemon.peripherals.mouse 
org.gnome.settings-daemon.peripherals.mouse.deprecated:/
org.gnome.settings-daemon.peripherals.smartcard 
org.gnome.settings-daemon.peripherals.touchpad.deprecated:/
org.gnome.settings-daemon.peripherals.touchscreen 
org.gnome.settings-daemon.peripherals.trackball.deprecated:/
org.gnome.settings-daemon.peripherals.wacom:/
org.gnome.settings-daemon.peripherals.wacom.eraser:/
org.gnome.settings-daemon.peripherals.wacom.stylus:/
org.gnome.settings-daemon.peripherals.wacom.tablet-button:/

Di seguito è riportato lo screenshot delle impostazioni del mio mouse e touchpad:

Inoltre,imieirisultatidisynclientsonocome,

$synclient|grepTapButtonTapButton1=0TapButton2=0TapButton3=0

ilmiocomandoxinputrestituiscequantosegue,

$xinputlistVirtualcorepointerid=2[masterpointer(3)]↳VirtualcoreXTESTpointerid=4[slavepointer(2)]↳SynPS/2SynapticsTouchPadid=12[slavepointer(2)]↳MCEIRKeyboard/Mouse(ene_ir)id=13[slavepointer(2)]Virtualcorekeyboardid=3[masterkeyboard(2)]↳VirtualcoreXTESTkeyboardid=5[slavekeyboard(3)]↳PowerButtonid=6[slavekeyboard(3)]↳VideoBusid=7[slavekeyboard(3)]↳PowerButtonid=8[slavekeyboard(3)]↳SleepButtonid=9[slavekeyboard(3)]

Risultatidelcomandoxinputlist-props12:

    
posta kmario23 26.10.2015 - 13:36

10 risposte

17

Ho finalmente trovato una soluzione per risolvere il mio problema:

Ho aggiunto la seguente riga al mio bashrc in modo che possa essere compilata ogni volta che accedo.

synclient TapButton1=1 TapButton2=3 TapButton3=2

Anche se non è un bel trucco, ma funziona bene. Spero che la community risolva il bug ..

Aggiornamento: Questo trucco sembra funzionare correttamente anche in Ubuntu 17.04, il che significa che il bug non è ancora stato risolto dalla community.

P.S. Vedi anche questa ottima soluzione

    
risposta data kmario23 20.11.2015 - 17:15
31

Apri un terminale premendo ctrl + alt + t e scrivi:

synclient TapButton1=1 TapButton2=3 TapButton3=2

ha funzionato per me ...

    
risposta data ryuffhant 19.11.2015 - 14:30
10

Hai aggiornato le impostazioni del mouse? Dopo l'aggiornamento ho avuto lo stesso problema, ma era solo che il tocco per fare clic era stato disabilitato.

Altrimenti,secondo questo thread potrebbe valere la pena di disconnettersi e di nuovo dentro.

    
risposta data christopherlovell 27.10.2015 - 10:56
6

Ho avuto lo stesso problema in Ubuntu Gnome 16.04 e l'ho risolto con una tecnica simile menzionata nella link risposta ma con alcune differenze:

1- pranzo " Editor di dconf ". (se non installato, esegui: sudo apt-get install dconf-tools )

2- vai a: org > gnome > desktop > peripherals > touchpad

3- controlla tap-to-click

    
risposta data Jalil.me 20.11.2016 - 21:31
2

Ho avuto lo stesso problema, dopo che sono passato a GNOME di Ubuntu, licantropo. quindi faccio scorciatoie personalizzate nella tastiera per riprendere la funzionalità del touchpad, basta riempire synclient TapButton1=1 sul comando, inoltre compila il modulo del nome, quindi scegli le combinazioni di tastiere preferite. va abbastanza bene per un po 'e attendi l'aggiornamento.

    
risposta data ryuffhant 20.11.2015 - 14:59
1

Nella finestra delle impostazioni consente agli utenti di impostare il mouse. Ma ho bisogno di configurare il touchpad. La console aiuta a riavviare o dormire prima "synclient tapbutton1 = 1"

A quanto ho capito, il sistema identifica erroneamente il dispositivo, sembra un bug.

    
risposta data Tamahome Mamonov 01.11.2015 - 10:00
1

Ho appena effettuato l'aggiornamento a Ubuntu 17.04, alcuni giorni fa e ho affrontato gli stessi problemi. Questo è il trucco:

    sudo apt install xserver-xorg-input-synaptics

Ha solo bisogno di scaricare questa roba, nient'altro.

    
risposta data f.a.abadi 04.10.2017 - 19:54
0

Fai una prova, ha funzionato per me su UbuntuGnome 15.10 quindi ho creato una voce nelle applicazioni di avvio.

Usando il tuo editor preferito, crea uno script con i seguenti contenuti e salvalo come ad es. % Co_de%.

#!/bin/bash

xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 4

# Below width 1 finger touch, above width simulate 2 finger touch. - value=pad-pixels
xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Width" 8

# vertical scrolling, horizontal scrolling - values: 0=disable 1=enable
xinput --set-prop --type=int --format=8  "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 1 1

# vertical, horizontal, corner - values: 0=disable  1=enable
xinput --set-prop --type=int --format=8  "SynPS/2 Synaptics TouchPad" "Synaptics Edge Scrolling" 0 0 0

# stabilize 2 finger actions - value=pad-pixels
xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Jumpy Cursor Threshold" 250

# pad corners rt rb lt lb tap fingers 1 2 3 (can't simulate more then 2 tap fingers AFAIK) - values: 0=disable 1=left 2=middle 3=right etc. (in FF 8=back 9=forward)
xinput --set-prop --type=int --format=8  "SynPS/2 Synaptics TouchPad" "Synaptics Tap Action" 0 0 0 0 1 2 3   

exit

Rendi eseguibile lo script:

chmod +x touchpad.sh

Ora esegui lo script e verifica se funziona.

Informazioni originali trovate qui: link

    
risposta data Mistgun 17.11.2015 - 22:26
0

Come utente finale, il modo più semplice che ho trovato è quello di passare a "Pulsante principale" con il tasto destro del mouse nelle impostazioni del touchpad del mouse.

Il doppio tocco funziona ancora come prima a sinistra, tocca l'area dei pulsanti per fare clic con il pulsante destro del mouse.

Ubuntu 17.04.

    
risposta data jeff 28.05.2017 - 16:25
0

Ho creato uno script per automatizzare questo processo. Verrà avviato automaticamente all'avvio del sistema. Quindi, non è necessario eseguire lo stesso comando più e più volte. Il link dello script è github.com/Ryko-git/click-on-touchpad .

Il processo di installazione è molto semplice. Viene fornito sulla pagina github.

    
risposta data Ryko 30.04.2018 - 23:37

Leggi altre domande sui tag