Come ottengo Ctrl + Sinistra / Ctrl + Destra per saltare di nuovo una parola in byobu?

17

Sulle mie macchine Ubuntu 11.10 che eseguono byobu 4.37 Posso usare la combinazione di tasti Ctrl + / Ctrl + per saltare una parola alla volta nel terminale. Tuttavia, sulle mie macchine Ubuntu 12.04 con byobu 5.17 questo non funziona più.

Ho letto che byobu ha rimappato quelle combinazioni di tasti per ridimensionare le suddivisioni, e ora Alt + e Alt + ha l'effetto desiderato. Tuttavia, non riesco a trovare dove Alt + e Alt + sono mappati, al fine di rimappare Ctrl + e Ctrl + . Se rimuovo il mapping dei tasti per Ctrl + e Ctrl + , il cursore si sposta solo di 1 carattere alla volta, non 1 parola alla volta.

    
posta chmac 31.05.2012 - 19:08

3 risposte

10

Una soluzione era quella di passare il back-end allo schermo. Tuttavia, ho avuto problemi ricorrenti con ctrl-right quando l'ho fatto. Per fare ciò modifica ~/.byobu/backend a BYOBU_BACKEND=screen .

Successivamente ho trovato una soluzione molto migliore usando tmux da questo bug . Crea ~/.byobu/.tmux.conf con questo valore:

set-window-option -g xterm-keys on

Quindi ~/.byobu/keybindings.tmux con:

unbind-key -n C-Left
unbind-key -n C-Right

Ora ctrl-left e ctrl-right saltano una parola alla volta in tmux.

    
risposta data chmac 01.06.2012 - 21:46
0

Il motivo del cambiamento è dovuto al fatto che ora Byobu sta usando tmux come back-end, anziché come schermo.

CTRL-Left & amp; CTRL-Right sono usati in tmux per navigare nei riquadri, quindi dobbiamo dire a tmux di non farlo! Modifica il tuo ~ / .byobu / keybindings.tmux e aggiungi le seguenti righe alla fine:

unbind-key -n C-Left
unbind-key -n C-Right

Basta disconnettersi / rientrare e dovresti vedere la modifica.

* Nota, funzionerà solo per xterm, non per gli effettivi tty. Noterai che anche senza usare byobu, ctrl-left e ctrl-right non si comportano come previsto da una tty. Ubuntu sembra ignorare / etc / inputrc quando si usa un tty per qualche motivo.

    
risposta data reverendj1 31.05.2012 - 19:45
0

Nel mio ~/.zshrc

bindkey '^[[1;5D' backward-word
bindkey '^[[1;5C' forward-word

... E ora ctrl+left / right salta le parole in byobu / tmux.

    
risposta data yPhil 30.04.2013 - 16:09

Leggi altre domande sui tag