Google Chrome "Sfarfallio"

18

Sto riscontrando un problema con Google Chrome su Ubuntu 12.10 64.

Circa il 20-30% dei siti web viene visualizzata la pagina e inizia a "sfarfallio". Sembra che ci sia un rendering diverso o parziale della pagina in un buffer diverso e diverse volte al secondo la pagina si scambia tra i due buffer dello schermo, causando un tipo di lampo epilettico di immagini diverse.

Non riesco a scorrere la pagina anche quando è in questo stato di sfarfallio, qualsiasi tentativo di scorrimento fa tornare la pagina in alto sullo sfarfallio successivo.

Sto usando il driver fglrx se questo significa qualcosa:

$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7900 Series
OpenGL version string: 4.2.12002 Compatibility Profile Context 8.961

La versione di Chrome è:

Google Chrome   25.0.1364.172 (Official Build 187217) 

Qualche idea?

    
posta Andrew Tomazos 08.04.2013 - 04:20

4 risposte

10

Questo è un problema noto con la scheda grafica ATI / AMD e il compositing.

Per alcune persone che avviano Chrome con il parametro --blacklist-accelerated-compositing è utile. Altri riportano che il parametro --disable-gpu aiuta.

Vedi link

Per quanto ho capito, l'unica vera soluzione è passare a Nvidia o Intel GPU. Aggiungendo parametri come quelli sopra le prestazioni di costo e disabilitando alcune funzionalità che richiedono il compositing. Per controllare lo stato della GPU di Chrome, visita chrome: // gpu

    
risposta data longsleep 16.04.2013 - 16:01
7

Rivedendo questa pagina dopo un mese, il problema era che l'accelerazione hardware non era abilitata. Questo è evidente anche nei video HTML5!

Vai a chrome: // flags

Cerca "Override Software Rendering List", cioè abilita l'accelerazione GPU su hardware non supportato e abilitalo. Riavvia Chrome (chiudi il processo in background se hai quello in esecuzione nella parte superiore della barra) e verifica se funziona per te.

Ulteriori informazioni qui .

    
risposta data ben lifehacker 13.07.2014 - 19:01
5

Potresti provare ad avviare Chrome con --disable-gpu .

Riferimento: link

    
risposta data jox 20.12.2014 - 13:51
4

Questa soluzione è molto simile alla risposta di @ jox (disattivando il supporto della GPU ho risolto questo problema per me), ma se qualcuno è curioso su come farlo, puoi semplicemente andare su Impostazioni - & gt; "Mostra impostazioni avanzate ..." - & gt; Sistema e deseleziona "Usa accelerazione hardware quando disponibile"

Sto usando Ubuntu 15.04 e fglrx dai repository di Ubuntu su Chromium 45.0.2454.85.

    
risposta data wchest 29.09.2015 - 19:28

Leggi altre domande sui tag