Hanno strappato (senza Vsync) nei film (driver proprietario Nvidia)

18

Questo è più di KDE di una domanda su Ubuntu, ma ...
Ho visibile lacrimazione sullo schermo. La composizione di KDE, il video flash in Firefox e giochi semplici come kpat sono vsynced, ma nei giochi a vapore e nei film c'è una distinta lacerazione costante. Se spengo VSync ovunque, la rottura è doppia come evidente, quindi non è solo la GPU che ignora le impostazioni.
Quello che mi infastidisce di più è che sto avendo lo stesso problema in molte configurazioni diverse. Tutti hanno questo problema e a nessuno importa?
Il mio setup

  • Kubuntu (ultime versioni) o OpenSuse o Gentoo.
  • KDE 4.12 - 4.13
  • Nvidia GTX 260, 570, TITAN, diverse versioni di driver.
  • Guardo film in SMplayer con il backend mplayer2. VLC ha lo stesso problema.

Che cosa ho provato (e non ha aiutato)

  • Accensione e spegnimento in diverse configurazioni delle impostazioni Vsync in nvidia-settings e KDE Desktop effects.
  • Modifica delle impostazioni di Mplayer e direct rendering .
  • Disattivazione della modalità di alimentazione adattiva nelle impostazioni di nvidia.
  • Disattivazione del compositing
  • Modifica del monitoraggio Hz
  • Esecuzione di mplayer dalla CLI
  • Esecuzione di rituali e sacrifici

Che cosa ha funzionato (ma non è una soluzione accettabile)

  • Disabilitazione di KDE e esecuzione di Mplayer nella sessione X pura
  • Passare a nuovo e disattivare la composizione e aprire i video a schermo intero - senza alcuna parte è ancora lacerante.

Si prega di consulenza.

UPDATE 1 Ho scoperto che se vado su Effetti desktop - Avanzate e cambio qualcosa di valido (versione OpenGL, algoritmo di ridimensionamento) e spingo Applica, lo strappo è andato fino al riavvio. Tuttavia, nessuna impostazione risolve questo una volta per tutte. Dopo il riavvio devo andare a cambiare qualcosa di nuovo. Suppongo che sia sufficiente dare la colpa a un bug, non ai miei errori, quindi scriverò una segnalazione.

    
posta Barafu Albino 27.04.2014 - 14:33

6 risposte

8

La fonte del problema era (ovviamente) driver nvidia difettosi. La soluzione è semplice. Aggiungi variabili ambientali:

export __GL_YIELD="USLEEP"
export __GL_THREADED_OPTIMIZATIONS=1

da qualche parte prima dell'inizio di X. Il /etc/profile/ dell'intero sistema funziona correttamente.

    
risposta data Barafu Albino 27.09.2014 - 10:27
8

Guida semplice per risolvere questo fastidioso problema:)

  1. Crea file:

    /etc/profile.d/Tearing.sh
    
  2. Inserisci questo codice:

    export __GL_YIELD="USLEEP"
    
  3. Quindi rendilo eseguibile con:

    chmod +x /etc/profile.d/Tearing.sh
    
  4. Una volta fatto, riavvia o premi ctrl + alt + F2, accedi ed esegui sudo service lightdm restart Oppure riavvia ciò che mai è il tuo display manager.

Il GL_YIELD ha funzionato per me, e ora la sincronizzazione verticale sembra funzionare come dovrebbe.

( link )

    
risposta data Dominik Najberg 28.09.2014 - 15:40
5

L'ho fatto inchiodare ...

Quindi, prima di tutto assicurati di controllare se il problema persiste dopo aver disattivato gli Effetti desktop (Alt + Maiusc + F10). Posso garantire che il problema potrebbe già essere risolto.

Vai a Impostazioni di sistema e apri Effetti desktop:

  • Metodo di ridimensionamento su qualcos'altro che impostato correntemente & lt; - correzione effettiva

So che le opzioni potrebbero non essere nominate esattamente come sopra. Mi dispiace, ma sto usando la versione polacca di Kubuntu.

I passaggi precedenti hanno risolto il problema per me. Ma solo dopo una nuova installazione. :)

EDIT: nella versione corrente di Kubuntu 14.04 il problema è collegato al metodo di scalatura. Modificandolo su un valore diverso da quello attualmente selezionato, aiuta a risolvere il problema TEMPORANEAMENTE.

    
risposta data Dominik Najberg 28.04.2014 - 17:37
5

Ho provato tutti i trucchi e non ho risolto nulla su Ubuntu 15.04 (insieme a xorg-edgers e nvidia-355), fino a quando non sono arrivato nvidia archlinux page .

Prova con:

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Per rendere permanente la modifica, è necessario aggiungere quanto segue sulla riga "Schermo" del tuo file di configurazione Xorg, per esempio in /etc/X11/xorg.conf.d/20-nvidia.conf

Option  "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
    
risposta data Giovanni Toraldo 13.08.2015 - 21:52
0

Rimozione del driver NVIDIA risolto per me. Per XFCE, l'unica cosa che mi ha aiutato è stata la sostituzione del window manager.

    
risposta data Waterscroll 15.06.2015 - 17:12
0

Ho provato ogni suggerimento per provare a risolvere il problema dello strappo dello schermo mentre guardavo i video in Unity, Gnome e Gnome Classic su due computer (uno con Nvidia Titan X e l'altro con una vecchia scheda Radeon). Niente ha funzionato

Poi ho notato che quando ho cambiato l'uscita video nella mia configurazione VLC da OpenGL a X11, la lacrimazione è andata via, ma ho iniziato a ottenere un sacco di quadrati bianchi / neri casuali o "rumore".

Per far funzionare la riproduzione del video, ho installato Lubuntu Desktop che utilizza OpenBox invece di OpenGL. Lubuntu è un derivato di Ubuntu che ha LXDE installato di default. È estremamente leggero e perfetto per la riproduzione in background mentre usi Kodi e Steam, o semplicemente guarda video.

Si può verificare uno strappo della finestra mentre si trascina velocemente Windows, ma questo non mi interessa in questa situazione dato che uso solo Kodi e Steam in modalità a schermo intero su questo computer.

Esegui il seguente comando per installare sia LXDE personalizzato di LUBE che vanilla LXDE su Ubuntu:

sudo apt-get install lubuntu-desktop

Usa questo comando per installare solo Lilla di Vanilla:

sudo apt-get install lxde

Puoi anche dare a LXDE una svolta scaricando un live CD di Lubuntu .

Ogni ambiente differisce solo nelle sue impostazioni predefinite. Vengono con temi diversi, sfondi e layout del pannello. Ad esempio, il browser Chromium è l'impostazione predefinita su Lubuntu, mentre Mozilla Firefox è l'impostazione predefinita su vanilla LXDE. Naturalmente, puoi usare qualsiasi browser che ti piace con entrambi. Entrambi utilizzano il file manager PCManFM, un sostituto leggero per il file manager Nautilus trovato in GNOME.

Dopo aver installato entrambi i pacchetti, disconnettiti e seleziona la sessione di Lubuntu o LXDE dalla schermata di accesso.

I miei video non sono mai stati migliori di quelli di Lubuntu. Sono stato in grado di battere la mia frequenza fino a 120 Hz per abbinare la mia TV. La riproduzione era straordinariamente fluida per 1920x1080p.

    
risposta data guttermonk 12.07.2015 - 03:19

Leggi altre domande sui tag