16.04: Come ottenere il pacchetto intel-microcode consigliato per risolvere il problema di hyper-threading?

18

La mailing list Debian ha un post relativo ad alcuni utenti Skylake e Kaby Lake: [ATTENZIONE] Processori Intel Skylake / Kaby Lake: hyper-threading interrotto

Gli utenti devono eseguire

grep name /proc/cpuinfo | sort -u

per ottenere i dettagli del processore e quindi per verificare link o link a seconda dei casi.

Se il loro processore è elencato, dovrebbero prima eseguire

grep -q '^flags.*[[:space:]]ht[[:space:]]' /proc/cpuinfo && \
echo "Hyper-threading is supported"

Secondo un post di follow-up , il comando sopra riportato che ho colpito non è affidabile e gli utenti devono eseguire lscpu e controllare se

  

l'output lscpu riporta: "Thread (s) per core: 2", cioè   hyper-threading è abilitato e supportato.

Se l'hyper-threading è supportato, vengono forniti consigli per Skylake e Kaby Lake.

Ho un processore Skylake interessato su 16.04 che può essere corretto perché

grep -E 'model|stepping' /proc/cpuinfo | sort -u

ritorna

model       : 78
model name  : Intel(R) Core(TM) i3-6006U CPU @ 2.00GHz
stepping    : 3

Per tali processori la correzione suggerita è quella di installare

  

il pacchetto "intel-microcode" non libero      con la versione di base 3.20170511.1 e riavviare il sistema. QUESTO È      LA SOLUZIONE RACCOMANDATA PER QUESTI SISTEMI, COME FISSE ALTRE      PROBLEMI DEL PROCESSORE NONCHÉ.

Ma il repository 16.04 mi mostra una versione precedente:

apt policy intel-microcode
intel-microcode:
Installed: (none)
Candidate: 3.20151106.1
Version table:
3.20151106.1 500
500 http://archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages

È possibile ottenere la versione consigliata e, se possibile, come posso farlo?

Modifica: ho trovato link ma sembrano tutte versioni precedenti.

La seconda modifica: link ha l'aggiornamento pertinente, ma è per Artful Aadvark .

    
posta DK Bose 26.06.2017 - 15:44

3 risposte

5

Installa manualmente l'ultimo pacchetto ufficiale . Ad esempio, per il sistema operativo a 64 bit:

wget http://ftp.us.debian.org/debian/pool/non-free/i/intel-microcode/intel-microcode_3.20170511.1~bpo8+1_amd64.deb
sudo dpkg -i intel-microcode_3.20170511.1~bpo8+1_amd64.deb

Riavvia la macchina e sei pronto. ANCHE , devi installare l'ultimo aggiornamento del BIOS dal tuo computer. Consulta il produttore del tuo computer per l'ultimo aggiornamento ufficiale del BIOS.

    
risposta data DevNull 26.06.2017 - 18:50
3

Puoi installare il pacchetto che è per artful .

Questo pacchetto contiene firmware binario. È indipendente dal rilascio.

    
risposta data Pilot6 26.06.2017 - 15:54
0

Puoi installare l'aggiornamento del BIOS usando windows pe.

Il supporto di installazione di Windows contiene windows pe. La shell cmd può essere richiamata premendo shift + f10 per accedere all'aggiornamento eseguibile del BIOS.

    
risposta data user705241 28.06.2017 - 09:05

Leggi altre domande sui tag