Ubuntu 16.04 LTS Network Manager non può aggiungere VPN - in grigio

21

Sto cercando di aggiungere una VPN alla mia rete, ma l'opzione è in grigio.

Schermata dell'indicatore disattivato

Ho installato network-manager-openvpn ma ancora senza fortuna. La modifica della mia connessione non mostra alcuna impostazione o scheda VPN.

Sarei grato se qualcuno potesse indicarmi la giusta direzione!

EDIT : nel caso in cui qualcun altro abbia questo problema, la dicitura "Aggiungi una connessione VPN" è fuorviante in quanto ti dice che devi aggiungere una connessione VPN , non che tu debba fare clic per aggiungerne uno da lì.

Quindi seleziona Modifica connessioni, Aggiungi, quindi seleziona la tua VPN da lì.

    
posta Harmonic 09.04.2017 - 19:52

3 risposte

37

Nel caso in cui qualcun altro abbia questo problema, la dicitura "Aggiungi una connessione VPN" è fuorviante in quanto ti dice che devi aggiungere una connessione VPN , non che devi fare clic aggiungi uno da lì.

Quindi seleziona Modifica connessioni, Aggiungi, quindi seleziona la tua VPN da lì.

    
risposta data Harmonic 09.04.2017 - 20:05
8

Recentemente ho configurato VPN su Xubuntu 16.04 LTS per la prima volta. Questo è quello che dovevo fare:

sudo apt install openvpn
sudo apt install network-manager-openvpn-gnome 

Ho usato network-manager-openvpn-gnome invece di network-manager-openvpn per ottenere l'opzione per importare i file di configurazione VPN.

Dopo potrei andare a:

  1. Modifica connessioni nella parte inferiore del menu
  2. Fai clic sul pulsante Aggiungi nella finestra successiva
  3. Scegli tipo di connessione
  4. Importa una configurazione VPN salvata

Dopo sono riuscito a modificare la connessione VPN

  1. Modifica connessioni ... nella parte inferiore del menu
  2. Seleziona la connessione VPN che voglio modificare
  3. Fai clic sul pulsante Modifica

    
risposta data fliegenpilzmann 10.04.2017 - 02:23
3

Il modo semplice è usare un comando sul terminale:

nm-connection-editor

nm-applet normalmente inizia all'accesso dal gestore della sessione desktop e non deve essere eseguito manualmente.

In alcune versioni di Ubuntu c'erano problemi nella politica di sicurezza.

Per risolvere questo problema, devi modificare il file "org.freedesktop.NetworkManager.policy" in / usr / share / polkit-1 / actions /

sudo -H gedit /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy

E cambia questa azione:

<action id="org.freedesktop.NetworkManager.settings.modify.own">
.
.
.
<allow_inactive>no</allow_inactive>

a

<allow_inactive>yes</allow_inactive>

Quindi riavvia il gestore di rete

sudo systemctl restart network-manager
    
risposta data Marco A. Pivetta 28.01.2017 - 21:50

Leggi altre domande sui tag