Forza la schermata di login di gdm al monitor principale

22

Ho due monitor collegati alla mia scheda video. Il monitor principale ha una risoluzione pari a 1280x1024 e il secondo ha 1920x1200. La mia schermata di login gdm appare sempre sul secondo monitor anche se è spenta. La mia domanda è come forzare gdm a mostrare sempre la schermata di login sul monitor principale con risoluzione 1280x1024?

Uso la videcard Nvidia GT9500 in modalità Twinview. Non posso usare Xinerama perché vpdau non funziona correttamente in questa modalità.

Quello che ho trovato è che il puntatore del mouse appare sempre al centro dell'unione degli schermi e il centro è sempre sul monitor con una risoluzione più alta. La schermata di accesso mostra sempre dove si trova il cursore del mouse.

Ora il mio monitor principale ha una risoluzione pari a 1920x1080. Il problema persiste, il cursore del mouse appare sempre nell'angolo in basso a destra del secondo monitor.

    
posta Kirill V. Lyadvinsky 06.11.2010 - 13:26

6 risposte

1

Recentemente ho aggiornato il sistema alla versione 11.10. Ubuntu 11.10 utilizza un nuovo display manager (lightgdm) e sembra che la schermata di accesso sia sempre visualizzata sul monitor principale. Questo risolve il mio problema.

    
risposta data Kirill V. Lyadvinsky 03.12.2011 - 21:12
20

Per le versioni più recenti di Ubuntu come 13.10 o aggiornato 13.04 utilizzando Gnome 3.8, questa procedura è diversa perché il file di configurazione X non controlla più il layout del monitor. È necessario effettuare le seguenti operazioni:

  1. Imposta il layout del monitor correttamente come utente loggato (vedi Monitoraggio permanente del monitor come principale )

  2. Copia il file di configurazione sulle impostazioni di gdm

    cp ~/.config/monitors.xml ~gdm/.config/
    

Per ulteriori dettagli, consulta link

    
risposta data Andrew Mao 18.09.2013 - 20:40
1

stai usando una scheda Nvidia con una configurazione a doppio schermo?

In tal caso, ho avuto lo stesso problema e l'ho risolto nel modo seguente: Spegni il computer, scollega il secondo monitor, riaccendi il computer, esegui "sudo nvidia-settings", collega di nuovo il secondo monitor, eseguire 'Rileva visualizzazioni' nella GUI Nvidia ed effettuare le configurazioni necessarie prima di salvare le impostazioni. Il punto IMPORTANTE è che la schermata in cui desideri che il login venga visualizzato è impostata su "Numero schermo: 0".

Nel mio caso, lasciare il secondo monitor collegato prima di eseguire 'nvidia-settings' lo ha lasciato come schermo 0 per qualche motivo, ma collegandolo dopo, questo è stato ordinato.

    
risposta data spinoza666 07.11.2010 - 08:47
0

prova a cambiare l'ordine sinistro / destro dei tuoi monitor, non cambia quale sia il principale, ma potrebbe aiutarti a mostrare il tuo GDM.

    
risposta data hansioux 06.11.2010 - 14:59
0

Se twinview lo fa allo stesso modo del centro di controllo del catalizzatore ATI, c'è un xorg.conf che puoi modificare con gksu gedit /etc/X11/xorg.conf

La mia parte rilevante è la seguente:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[1]-0" 0 0
    Screen         "amdcccle-Screen[1]-1" 1400 0
EndSection

Tutto quello che devi fare (dopo aver eseguito il backup di xorg.conf ovviamente) è cambiare il ServerLayout scambiando le voci Screen (e adattando i numeri dello schermo), nel mio caso sarebbe:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[1]-1" 1400 0
    Screen         "amdcccle-Screen[1]-0" 0 0
EndSection
    
risposta data Tobias Kienzler 12.01.2011 - 11:57
0

È possibile provare "Impostazione schermata X separata" nelle impostazioni di NVIDIA X Server. Se si imposta il display desiderato su 0, la finestra di accesso apparirà lì. Funziona per me.

    
risposta data kissgyorgy 30.11.2011 - 12:08

Leggi altre domande sui tag