Come eseguire il downgrade del kernel in 11.10

17

A causa dell'elevato consumo di energia, vorrei eseguire il downgrade del mio kernel in Ubuntu 11.10 alla versione utilizzata in 10.10 o 11.04. Come posso farlo e non causerà alcun problema?

    
posta Borsook 23.10.2011 - 21:49

1 risposta

19

Come posso fare ...

Potresti scaricare i binari del kernel dalle vecchie o nuove versioni di Ubuntu / 1 /.

Ricerca pacchetti di Ubuntu: link

Scegliere natty-updates kernel linux-image-2.6.38-10-generic: link

Scaricandolo e installandolo con il comando:

sudo dpkg -i linux-image-2.6.38-10-generic_2.6.38-10.46_i386.deb

La gestione dei pacchetti dice:

Selecting previously deselected package linux-image-2.6.38-10-generic.
(Reading database ... 127436 files and directories currently installed.)
Unpacking linux-image-2.6.38-10-generic (from linux-image-2.6.38-10-generic_2.6.38-10.46_i386.deb) ...
Done.
Setting up linux-image-2.6.38-10-generic (2.6.38-10.46) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.38-10-generic /boot/vmlinuz-2.6.38-10-generic
update-initramfs: Generating /boot/initrd.img-2.6.38-10-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.38-10-generic /boot/vmlinuz-2.6.38-10-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 2.6.38-10-generic /boot/vmlinuz-2.6.38-10-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 2.6.38-10-generic /boot/vmlinuz-2.6.38-10-generic
Generating grub.cfg ...
Found background image: /lib/plymouth/themes/my-plymouth/my-wallpaper.png
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found linux image: /boot/vmlinuz-2.6.38-10-generic
Found initrd image: /boot/initrd.img-2.6.38-10-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sda1
Found Ubuntu 10.10 (10.10) on /dev/sdd1
done

Il riavvio

Scegliere da grub & gt; Versioni precedenti di Linux & gt; Kernel 2.6.38-10

... e la (K) Ubuntu dice che sto correndo con 2.6.38-10-generic / 2 /.

... non causerà alcun problema?

Bene;) potresti dirci ...

Link

  1. link
  2. link
risposta data user26687 23.10.2011 - 22:48

Leggi altre domande sui tag