Avviso di file non valido all'avvio

2

Circa 1/3 del tempo in cui avvio il mio laptop, ricevo un messaggio di errore che dice

Error: Malformed file.
Press any key to continue...

Premendo un tasto, il computer si avvia e non riesco a distinguere effetti negativi.

È piuttosto sconcertante e fa ritardare il processo di avvio.

Come posso risolvere questo errore e assicurarmi che il mio sistema sia stabile?

    
posta Questioner 28.05.2014 - 05:41

3 risposte

4

È un bug in Grub, vedi bug del launchpad # 1311247 - errore: file malformato, premi qualsiasi chiave per continuare . Il bug report a monte è al bug # 42134: loadenv.c - check_blocklists - l'algoritmo per il controllo della sovrapposizione di blocchi è sbagliato . Non sembra esserci una soluzione affidabile: dovrai solo aspettare che venga risolto.

    
risposta data bain 28.05.2014 - 18:09
1

Molti utenti hanno questo problema, incluso me stesso.

Ho trovato una parte di testo che ha risolto il problema per me e, si spera, anche per gli altri.

modifica /etc/default/grub e aggiungi:

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

Dopo aver salvato il file update grub:

sudo update-grub

Riavvia il computer e il problema potrebbe essere risolto: -)

Recentemente ho scoperto che le impostazioni ACPI nel BIOS possono anche causare il messaggio "file malformato" durante l'avvio. Il mio computer non si spegne completamente e quindi mi trovavo a fare i conti con le impostazioni ACPI. È interessante notare che questo avviso ha più cause principali

    
risposta data RogerRamjet 30.10.2014 - 20:46
0

Attualmente sto usando Linux Mint 17 con kernel 3.14.5-031405-lowlatency. Ho installato questo kernel per risolvere problemi wireless lenti.

Ho iniziato a notare questo stesso problema solo pochi giorni fa. Premo qualsiasi tasto e si avvia bene.

La soluzione per me era di rimuovere completamente tutti i vecchi kernel (stock fornito con Mint 17). Ho quindi eseguito un dist-upgrade, riavviato e non ricevo più il messaggio.

Non sono un guru di linux quindi non posso spiegare perché questo ha funzionato, ho solo intuito.

    
risposta data Eric the Grave 03.06.2014 - 06:03

Leggi altre domande sui tag