Come cambio il browser predefinito con cui konsole apre gli URL?

18

Ho impostato google-chrome come browser Web predefinito in applicazioni Ubuntu e gnome. Tuttavia, quando utilizzi konsole , tutti i link si aprono in konqueror e non in google-chrome!

Ho provato a impostare il browser predefinito con: sudo update-alternatives --config 'x-www-browser'

Questo funziona per aprire i collegamenti in gnome-terminal e altri programmi gnome ... ma non quelli come konsole. Inoltre, sembra che non ci sia alcun programma kcontrol per accedere alle impostazioni di kde.

Qualcuno sa come impostare le impostazioni di kde per questo mentre usa ancora gnome?

EDIT: Da quello che posso dire, ho configurato tutte le impostazioni correlate a cui posso pensare ...

grep 'chrome' ~/.local/share/applications/mimeapps.list

x-scheme-handler/http=google-chrome.desktop;firefox.desktop;
x-scheme-handler/https=google-chrome.desktop;firefox.desktop;
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/chrome=firefox.desktop
text/html=google-chrome.desktop
application/x-extension-htm=google-chrome.desktop;firefox.desktop;
application/x-extension-html=google-chrome.desktop;firefox.desktop;
application/x-extension-shtml=google-chrome.desktop;firefox.desktop;
application/xhtml+xml=google-chrome.desktop;firefox.desktop;
application/x-extension-xhtml=google-chrome.desktop;firefox.desktop;
application/x-extension-xht=google-chrome.desktop;firefox.desktop;
x-scheme-handler/about=google-chrome.desktop
x-scheme-handler/unknown=google-chrome.desktop

grep 'chrome' /usr/share/applications/defaults.list

text/html=firefox.desktop;google-chrome.desktop
text/xml=firefox.desktop;google-chrome.desktop
application/xhtml_xml=google-chrome.desktop
x-scheme-handler/http=firefox.desktop;google-chrome.desktop
x-scheme-handler/https=firefox.desktop;google-chrome.desktop
x-scheme-handler/ftp=google-chrome.desktop

E non ci sono riferimenti a konqueror:

grep -i 'konqueror' /usr/share/applications/defaults.list
grep -i 'konqueror' ~/.local/share/applications/mimeapps.list
grep -i 'kon' /usr/share/applications/defaults.list
grep -i 'kon' ~/.local/share/applications/mimeapps.list
    
posta TrinitronX 20.09.2011 - 01:35

4 risposte

13

Mi sono imbattuto in questo problema nell'esecuzione di konsole in Ubuntu / Unity. Quando tutto il resto è fallito, ho modificato ~/.kde/share/config/kdeglobals :

[General]
BrowserApplication[$e]=!google-chrome

Esci, accedi - bingo!

    
risposta data vadim 12.11.2012 - 20:33
8

Il problema con "le applicazioni predefinite" al giorno d'oggi è che i programmi diversi cercano i valori predefiniti in modi diversi. Quello che possiamo chiamare l'approccio tradizionale è $BROWSER e mailcap file.

Ma, recentemente, molti programmi grafici hanno iniziato a fare affidamento sui file .desktop , e c'è un set di strumenti xdg-* dedicati a manipolare e recuperare alcuni dei valori predefiniti.

Prova:

xdg-settings get default-web-browser

Se mostra konqueror, quindi

xdg-settings set default-web-browser google-chrome.desktop

Dovrebbe risolverlo, almeno se la documentazione xdg-settings deve essere attendibile.

Ora, tutto ciò che xdg-settings fa sta parlando con l'ambiente desktop attualmente in esecuzione, quindi dovrebbe essere GNOME , e dovrebbe essere già impostato su google-chrome ...

    
risposta data njsg 23.05.2012 - 15:25
4

Questo è il comportamento corretto di Konsole . Apre i collegamenti nel browser predefinito di KDE. Se non viene specificato alcun browser, verrà avviato Konqueror . Poiché non è stato possibile trovare alcun riferimento a Konqueror nei file di configurazione, quest'ultimo è esattamente il tuo caso.

Per impostare il tuo browser preferito fai quanto segue (presumo che il tuo Konsole e Konqueror siano di KDE4 ):

  • apri le impostazioni di sistema di KDE (ad esempio lanciando Kcontrol )
  • vai a Applicazioni predefinite (deve trovarsi da qualche parte in "Aspetto area di lavoro")
  • trova la browser web sezione
  • scrivi il [percorso e] nome del tuo browser preferito

Spero che questo aiuti.

    
risposta data Vitalie Ciubotaru 25.05.2012 - 14:04
0

Dai un'occhiata a questa pagina: link

Esiste un'applicazione per le impostazioni predefinite del sistema kde. Tuttavia, dal tuo in gnome, dai un'occhiata a questo file:

/usr/share/applications/defaults.list

Inoltre guarda qui:

~/.local/share/applications/mimeapps.list

Rimuovi qualsiasi riferimento a konqueror.

    
risposta data balloons 17.02.2012 - 22:25