Avvia un secondo WiFi sul laptop

2
  • Uso standard Ubuntu 14.04 con network-manager .

  • Sono connesso a una rete Wi-Fi con la mia seconda% carta% carta_.%

Come faccio a dire a network-manager di permettermi di configurare la mia wlan1 card da sola con wlan0 ?

Alla fine mi piacerebbe adattare questo script , quindi lascia il controllo di ifconfig a network-manager

    
posta rubo77 11.09.2014 - 23:45

1 risposta

5

Ci sono due modi che conosco per far sì che Network Manager ignori un dispositivo:

Menzionalo in /etc/network/interfaces

Qualsiasi configurazione valida funzionerà. Questo dipende da managed impostato su false (o non impostato) in /etc/NetworkManager/NetworkManager.conf . Dalla manpage :

[ifupdown]
This section contains ifupdown-specific options and thus only has effect
when using ifupdown plugin.

managed=false | true
    Controls whether interfaces listed in the 'interfaces' file are 
    managed by NetworkManager.  If set to true, then interfaces listed 
    in /etc/network/interfaces are managed by NetworkManager.  
    If set to false, then any interface listed in /etc/network/interfaces 
    will be ignored by NetworkManager. Remember that NetworkManager 
    controls the default route, so because the interface is ignored, 
    NetworkManager may assign the default route to some other interface.  
    When the option is missing, false value is taken as default.

Quindi, puoi aggiungere a /etc/network/interfaces qualcosa del tipo:

auto wlan0
iface wlan0 inet manual

Aggiungilo all'elenco dei dispositivi non gestiti

Dalla manpage:

[keyfile]
This section contains keyfile-specific options and thus only has effect
when using keyfile plugin.
...
unmanaged-devices=mac:<hwaddr>;mac:<hwaddr>;...
    Set devices that should be ignored by NetworkManager when using 
    the keyfile plugin. Devices are specified in the following format: 
    "mac:<hwaddr>", where <hwaddr> is MAC address of the device to be 
    ignored, in hex-digits-and-colons notation. Multiple entries are 
    separated by a semicolon. No spaces are allowed in the value.
    Example:
    unmanaged-devices=mac:00:22:68:1c:59:b1;mac:00:1E:65:30:D1:C4

Prima cerca l'indirizzo MAC:

ifconfig wlan0 | grep -i HWaddr

Qui modificherai /etc/NetworkManager/NetworkManager.conf . Sotto una sezione [keyfile] (aggiungine una se non esiste), aggiungi:

unmanaged-devices=mac:some-mac-address

Il primo metodo dipende dal fatto che venga utilizzato il plug-in ifupdown , mentre il secondo dipende dal plugin keyfile utilizzato. Per impostazione predefinita, vengono utilizzati entrambi e managed è false .

È necessario riavviare Network Manager per rendere effettive le modifiche al file di configurazione (grazie, @ rubo77):

sudo service network-manager restart
    
risposta data muru 12.09.2014 - 00:00

Leggi altre domande sui tag