Le dipendenze dei pacchetti non possono essere risolte. Ubuntu 14.04 vlc-audacius

2
vlc: Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but 2.1.4-0ubuntu14.04.1 is to be installed

     Depends: libc6 (>= 2.15) but 2.19-0ubuntu6 is to be installed
     Depends: libfreetype6 (>= 2.2.1) but 2.5.2-1ubuntu2.2 is to be installed
     Depends: libgcc1 (>= 1:4.1.1) but 1:4.9-20140406-0ubuntu1 is to be installed
     Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4 is to be installed
     Depends: libqtgui4 (>= 4:4.8.0) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4 is to be installed
     Depends: libstdc++6 (>= 4.6) but 4.8.2-19ubuntu1 is to be installed
     Depends: zlib1g (>= 1:1.2.3.3) but 1:1.2.8.dfsg-1ubuntu1 is to be installed

The following packages have unmet dependencies:

    audacious: Depends: libaudclient2 (= 3.4.3-1) but 3.4.3-1 is to be installed
           Depends: libaudcore1 (= 3.4.3-1) but 3.4.3-1 is to be installed
    
posta Simiris Pandelis 14.07.2014 - 20:20

6 risposte

5

Quello che segue è il codice che ho usato per installare vlc su Ubuntu 14.04:

Rimozione della vecchia vlc e dei suoi pacchetti: sudo apt-get purge vlc vlc-nox gstreamer1.0-libav:i386 libavcodec-extra-54:i386 libavformat54:i386 libopus0:i386

Aggiunta di architettura: sudo dpkg --add-architecture i386

Quindi installa vlc: sudo apt-get install vlc

    
risposta data ramsudharsan 12.10.2014 - 09:16
0

Significa che hai dipendenze non soddisfatte per un sacco di software che è già installato. Esegui "sudo apt-get -f install" per risolvere il problema e consentire l'installazione di più software

    
risposta data sbergeron 14.07.2014 - 20:22
0

Verifica se questo aiuta:

sudo apt-get purge vlc vlc-nox

sudo apt-get install vlc

Facci sapere.

    
risposta data thatmaheshrs 15.07.2014 - 00:10
0

Avevo quasi gli stessi problemi di dipendenza del pacchetto e ho scoperto i pacchetti installati di vino per l'architettura i386 sul mio sistema i686. Rimozione di questi pacchetti

  • gstreamer1.0-libav: i386
  • libavcodec-extra-54: i386
  • libavformat54: i386
  • libopus0: i386

ho risolto il mio problema e sono riuscito a installare nuovamente vlc utilizzando apt-get .

    
risposta data wolf 13.08.2014 - 08:40
0

Ho avuto anche lo stesso problema e si è risolto dopo che ho eseguito
sudo apt-get purge vlc vlc-nox     
- & gt; Questo ha cancellato i file di configurazione per la versione precedente vlc installata

in seguito è stato installato dopo che le suddette dipendenze sono state installate .. con il comando seguente, sudo apt-get install libpostproc52 vlc-nox vlc

Spero che questo aiuti.

Subbarayudu A.

    
risposta data venkata subbarayudu 18.09.2014 - 12:07
0

aptitude è in grado di risolvere il problema di dipendenza eseguendo:

sudo aptitude install vlc

Il conflitto effettivo è il pacchetto libpostproc-extra-52 , che può essere risolto eseguendo

sudo apt-get purge libpostproc-extra-52
sudo apt-get install vlc
    
risposta data FredericChopin 27.01.2015 - 20:39

Leggi altre domande sui tag