Perché non riesco a installare "ia32-libs" (nessun candidato)?

2

Voglio installare eagle cadsoft 6.2.0 su Ubuntu 11.10, eagle è compatibile con 32 bit quindi ho bisogno di installare ia32-libs ma il suo errore è il seguente:

Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ia32-libs' has no installation candidate

dopo aver usato il comando sudo apt-cache search ia32 Ho ottenuto questo:

grub-efi - GRand Unified Bootloader, version 2 (dummy package)
grub-efi-ia32 - GRand Unified Bootloader, version 2 (EFI-IA32 version)
grub-efi-ia32-bin - GRand Unified Bootloader, version 2 (EFI-IA32 binaries)
lsb-core - Linux Standard Base 4.0 core support package
lsb-cxx - Linux Standard Base 4.0 C++ support package
lsb-desktop - Linux Standard Base 4.0 Desktop support package
lsb-graphics - Linux Standard Base 4.0 graphics support package
lsb-printing - Linux Standard Base 4.0 Printing package
elilo - Bootloader for systems using EFI-based firmware
libasm0 - Disassembling engine provided to the ERESI framework
libasm0-dev - Disassembling engine provided to the ERESI framework
lsb-languages - Linux Standard Base 4.0 Runtime Languages package
lsb-multimedia - Linux Standard Base 4.0 Multimedia package
lsb-qt4 - Linux Standard Base 4.0 Qt4 support package
refit - graphical boot menu for ia32 and x64 EFI systems
ia32-libs-multiarch - Multi-arch versions of former ia32-libraries
microcode.ctl - Intel IA32/IA64 CPU Microcode Utility

per favore aiuto.

    
posta ravi 17.07.2012 - 08:01

2 risposte

6

Sei già su un sistema a 32 bit!

  • ia32-libs , o librerie di compatibilità a 32 bit per sistemi a 64 bit, è disponibile solo nei repository amd64 , ad esempio se si utilizza una versione a 64 bit di Ubuntu.
  • Viene visualizzato solo l'errore "nessun candidato all'installazione" se si è già in un sistema a 32 bit.
  • Come questa pagina mostra , è disponibile per Ubuntu 11.10 64-bit .

Puoi eseguire pacchetti "compatibili a 32 bit" come Eagle Cadsoft su un sistema Ubuntu a 32 bit senza dover installare ia32-libs . (Provalo: -)

    
risposta data ish 17.07.2012 - 10:13
-1

Prova con:

sudo apt-get install ia32-libs-multiarch
    
risposta data jasmines 17.07.2012 - 08:11

Leggi altre domande sui tag