Come posso configurare Eclipse per lavorare con un programma Quickly?

2

Ho installato PyDev in Eclipse e ho configurato il mio progetto in modo che il progetto si trovi sotto Workspace/Eclipse ei file Quickly si trovano in Workspace/Quickly . Per connettere i due ho collegato il progetto Quickly creando una nuova cartella in Eclipse sotto il progetto e selezionando l'opzione avanzata nella finestra di dialogo per collegare una cartella al progetto. In questo modo non ho bisogno di avere i file di progetto Eclipse nel mio progetto rapido.

Ma ci sono due problemi per me:

  1. In Eclipse devo selezionare un interprete Python e non ho idea di cosa fare. Ho cercato su google una risposta, ma non riesco a trovare se Quickly usa Python 3 o 2.7. Qualcuno può aiutarmi a fare una scelta informata? (Sono nuovo nello sviluppo di Python, ecco perché non posso dire la differenza con la sintassi - se c'è anche una differenza)
  2. Non riesco a premere il pulsante "Esegui" per avviare l'applicazione. Devo inizializzare un programma con quickly run ? Voglio essere in grado di eseguire il debug di Eclipse, come posso configurarlo?

Sto usando Ubuntu 12.04.1 LTS e la versione di Eclipse dai repository.

    
posta Niklas 26.09.2012 - 10:21

1 risposta

5

Quindi mi sono interessato a questo dopo aver visto la tua domanda, dopo un po 'di goggling senza risultati interessanti ho deciso di provare me stesso e vedere se riuscivo a capire qualcosa. Questa è più una soluzione alternativa a una soluzione reale.

Ho iniziato creando un progetto di test utilizzando rapidamente:

quickly create ubuntu-application foo

Poi ho lanciato eclipse e creato un nuovo progetto python e importato la cartella del progetto rapidamente. Fai clic destro su project- & gt; import

Poi ho aggiunto il percorso rapido del progetto al progetto eclipse: tasto destro del mouse sulle proprietà project- & gt;

vai a PyDev - PYTHONPATH- & gt; aggiungi la cartella sorgente e seleziona la mappa radice del progetto rapidamente

(Questo non è necessario ma rimuove quei fastidiosi segni di lettura che si lamentano di non trovare le importazioni)

Quindi ora l'unica cosa che rimane è essere in grado di lanciare il progetto da Eclipse. Per farlo, fai clic sul menu di esecuzione nella parte superiore di eclipse- & gt; Strumenti esterni- & gt; Configurazione strumenti esterni

Fai clic con il tasto destro del mouse su Programma e seleziona "Nuovo" Assegnagli un nome simile a Esegui

  1. Per posizione inserisci il percorso da eseguire rapidamente (/ usr / bin / rapidamente)
  2. Per la directory di lavoro fai clic su "sfoglia area di lavoro" e seleziona il root foolder del progetto rapidamente
  3. Per gli argomenti typ run
  4. Vai alla scheda comune e in "Visualizza nel menu Preferiti" seleziona Strumenti esterni

Creane uno nuovo e chiamalo qualcosa come il design, l'unica cosa da cambiare in questo sarebbe digitare "design" invece di "eseguire" sotto argomento.

Ora puoi eseguire o avviare glade per modificare il design dal menu a discesa che sto cercando di mostrare nell'ultima immagine.

Per la domanda python suggerirei di usare Python3 perché Ubuntu punta a includere solo python3 in Ubuntu 12.10 e forward. ( link )

Come configurare python in eclipse: quando crei un nuovo progetto pydev, dovresti vedere un'opzione per selezionare la versione e l'interprete della grammatica python. Se non riesci a trovare la versione giusta di Python sotto l'interprete fai clic su "Fai clic qui per configurare un interprete non elencato"

Nella nuova finestra fai clic su new e dagli un nome, quindi fai clic su browse to / usr / bin e seleziona la versione python che desideri aggiungere ad esempio python3.2mu, quindi fai clic su apply e ok. ora dovresti essere in grado di selezionare quella versione dalla finestra di creazione del nuovo progetto

Spero che questo ti aiuti

    
risposta data Kempe 02.10.2012 - 02:07

Leggi altre domande sui tag