Dov'è l'opzione di configurazione Multichannel / Coassiale / SPDIF in Ubuntu 12.04?

2

Recentemente sono passato dal 10.04 al 12.04. Ho fatto una nuova installazione. Tuttavia non posso configurare 5.1 surround con il mio home coassiale / SPDIF, semplicemente perché la nuova interfaccia di sound manager non fornisce opzioni come in 10.04. In 10.04 potrei configurare 'output digitale + input analogico' e tutto andava bene, ma in 12.04 non posso farlo.

Come posso modificare la configurazione?

    
posta Jonatan 15.05.2012 - 04:39

2 risposte

3

Ubuntu disabilita e nasconde l'uscita audio digitale SPDIF in tutte le schede Realtek / Nvidia di default, di fatto fa lo stesso in tutti i gusti di Ubuntu.

La procedura per risolvere il problema è la stessa in tutte le versioni di Ubuntu e funziona con tutte le schede audio Ati Nvidia Realtek Creative Bosse, ecc. È necessario modificare un file per farlo funzionare. Apri un terminale con Ctrl Alt t e scrivi questo:

sudo nano /etc/modprobe.d/alsa-base.conf

quindi aggiungi questa linea alla fine del file

options snd-hda-intel model=auto    

quindi usa Ctrl o per salvare il file e Ctrl x per uscire.

Al momento è necessario riavviare la macchina e funzionerà lo spdif audio digitale mancante. Vai all'icona della barra delle applicazioni per selezionare il dispositivo appropriato (che verrà visualizzato ora) per evitare l'uscita audio a tutti i diffusori allo stesso tempo.

Per gli spagnoli, prendi questo link: link

    
risposta data boggart 16.12.2012 - 06:40
2

Sembra che tu abbia lo stesso problema che abbiamo qui, anche se nella direzione opposta. La nostra nuova installazione di 12.04 32 bit non ci permetterà di passare dall'output digitale all'analogico. L'impostazione predefinita andrà su analogico solo se non è collegata alcuna altra scheda audio (ovvero rimuovi le cuffie USB).

C'è un'opzione in pavucontrol per selezionare tra uscite digitali e analogiche, ma non è riconosciuta dal controllo di volume predefinito e non sono possibili più uscite (la commutazione delle applicazioni tra i flussi è disabilitata).

Prova pavucontrol e vedi se puoi accedere alla configurazione aggiuntiva lì?

In alternativa puoi configurare la configurazione con pactl tramite terminale, consulta la manpage per maggiori dettagli. Inoltre dovresti controllare le impostazioni di alsamixer nel terminale, a volte provi a cercare la causa principale in pulseaudio, mentre alsa invece.

    
risposta data Niall Parker 29.05.2012 - 06:39

Leggi altre domande sui tag