uget con il plugin aria2

2

Ho letto che uget con il plugin aria2 abilitato è il miglior downloader. Così ci ho provato.

Ho scaricato uget da Ubuntu Software Center e installato anche aria2 dal terminale.

Poi ho aperto uget e ho aperto Impostazioni & gt; Sezione Plugin e attivato "Abilita plugin aria2". I miei argomenti hanno letto: --enable-rpc=true -D --check-certificate=false

Quindi, quando ho fatto clic su OK, ha risposto:

Failed to connect to aria2.

Aria3 è spento? Oppure il lancio di aria2 ha avuto esito negativo?

Ho anche provato alcuni comandi dal web:

[email protected]:~$ aria2c --enable-rpc=true --check-certificate=false --disable-ipv6

2013-09-07 09:42:08.483317 ERROR - IPv4 RPC: failed to bind port 6800
Exception: [SocketCore.cc:308] errorCode=1 Failed to bind a socket, cause: Address already in use

2013-09-07 09:42:08.483629 ERROR - Exception caught
Exception: [DownloadEngineFactory.cc:181] errorCode=1 Failed to setup RPC server

Poi ho aperto YouTube e ho provato a scaricare un video. Non verrà scaricato e in fondo c'era questo messaggio:

Message: aria2.getVersion result error

Per favore aiutami con questo. Ho davvero bisogno di avere il plugin Aria2 funzionante. Grazie.

    
posta ROshan 07.09.2013 - 05:50

5 risposte

4

Digita questo comando nel terminale:

aria2c --daemon --enable-rpc=true

per maggiori dettagli vai a questo link .

    
risposta data john9983 24.05.2014 - 19:49
1

"Ho scaricato uget da Ubuntu Software Center e ..."

C'è il tuo problema. Canonical sembra odiare uGet ... non ho idea del perché, ma Ubuntu non ha mai una versione aggiornata. L'USC ha la versione 1.8.2 e la versione corrente è 1.10.3

Vai al sito uGet ufficiale al link e scarica un file DEB per la versione di Ubuntu che usi o installa il PPA.

Disinstalla prima la versione USC ... per garantire l'installazione corretta della versione corrente.

    
risposta data Michael Tunnell 07.09.2013 - 06:11
0

La mia soluzione allo stesso identico problema era questa:

Nelle impostazioni di UGet sotto l'argomento modifica scheda plug-in a questo: --enable-RPC = true

Quindi riavvia Uget e aria2 dovrebbe funzionare. La versione di Uget che uso è 1.10.3.

    
risposta data danijelc 16.10.2013 - 23:16
0

Il messaggio di errore Address already in use ti dice che localhost:6800 è occupato da altri programmi. Hai 2 opzioni per risolverlo:
1. Scopri il programma che occupa localhost:6800 , cambia la sua porta;
2. Cambiare la porta di aria2, ad es. 6801.

    
risposta data Bruce Sun 29.04.2014 - 16:00
0

Ho la mia risposta in uGet 1.10.4 in Ubuntu 14.04 con aria2c versione 1.18:

  1. Devi specificare la tua porta RPC. Nel mio esempio, 9299. Questa porta numero non deve essere utilizzato da un altro processo.
  2. Quindi dovresti aggiungere --enable-rpc=true --rpc-listen-port=9299 agli argomenti .
  3. Puoi specificare argomenti aggiuntivi come --check=certificate=false .

Per provarlo, ho eseguito uGet via console. Quindi posso vedere qualsiasi output di aria2 nella mia console.

Risultato

Funziona. uGet e aria2 finalmente lavorano insieme. Ho aspettato ~ 3 mesi per questo.

    
risposta data Ade Malsasa Akbar 22.02.2015 - 07:35

Leggi altre domande sui tag